summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-dns-nsone')
-rw-r--r--app-crypt/certbot-dns-nsone/Manifest3
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild34
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0-r1.ebuild35
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild30
-rw-r--r--app-crypt/certbot-dns-nsone/metadata.xml15
5 files changed, 77 insertions, 40 deletions
diff --git a/app-crypt/certbot-dns-nsone/Manifest b/app-crypt/certbot-dns-nsone/Manifest
index 825236135af9..d8d93538f258 100644
--- a/app-crypt/certbot-dns-nsone/Manifest
+++ b/app-crypt/certbot-dns-nsone/Manifest
@@ -1 +1,2 @@
-DIST certbot-dns-nsone-0.39.0.tar.gz 1350312 BLAKE2B 5f21c45d25754cb1ed0ad92e8d03637928a274637de09903509c7e78c40fd197e95cfa1f3effecef938d6ab8369dc6811714ddb5a93a806048e0998d1032e4f9 SHA512 17ab17a5f74e3fba58b1a8b9afe0c3656c7b2a5ea3585edb05ad84e36250c6a8d4d28bd692bc97d033c95eb0bbeff4eb84981ae0006e36d55846cd38373b86a0
+DIST certbot-1.18.0.gh.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
+DIST certbot-dns-nsone-1.18.0.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
deleted file mode 100644
index 92ce17bb7251..000000000000
--- a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/certbot-${PV}/${PN}
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=app-crypt/certbot-0.31.0[${PYTHON_USEDEP}]
- >=app-crypt/acme-0.39.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- >=dev-python/dns-lexicon-2.2.1[${PYTHON_USEDEP}]"
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0-r1.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0-r1.ebuild
new file mode 100644
index 000000000000..925d64f17b47
--- /dev/null
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=certbot-${PV}
+DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot/
+ https://letsencrypt.org/
+"
+SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/${PN}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
new file mode 100644
index 000000000000..8691a783350c
--- /dev/null
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S=${WORKDIR}/certbot-${PV}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot-dns-nsone/metadata.xml b/app-crypt/certbot-dns-nsone/metadata.xml
index f3de5f693ed8..393083b41065 100644
--- a/app-crypt/certbot-dns-nsone/metadata.xml
+++ b/app-crypt/certbot-dns-nsone/metadata.xml
@@ -1,8 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>patrick@gentoo.org</email>
- <name>Patrick Lauer</name>
- </maintainer>
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">certbot/certbot</remote-id>
+ <remote-id type="pypi">certbot-dns-nsone</remote-id>
+ </upstream>
</pkgmetadata>