summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/cfssl')
-rw-r--r--app-crypt/cfssl/Manifest1
-rw-r--r--app-crypt/cfssl/cfssl-1.4.1.ebuild5
-rw-r--r--app-crypt/cfssl/cfssl-1.6.0.ebuild7
-rw-r--r--app-crypt/cfssl/cfssl-1.6.4.ebuild33
-rw-r--r--app-crypt/cfssl/metadata.xml2
5 files changed, 44 insertions, 4 deletions
diff --git a/app-crypt/cfssl/Manifest b/app-crypt/cfssl/Manifest
index 28bf72a18d46..cbb44b34801c 100644
--- a/app-crypt/cfssl/Manifest
+++ b/app-crypt/cfssl/Manifest
@@ -1,2 +1,3 @@
DIST cfssl-1.4.1.tar.gz 5736648 BLAKE2B 581627eb269fcbbbe9ff3afe558c6ddc7afa10f563444899244045baa0ae195d8822b389e7c59bec6c9135b1159b18d2a5e497c83cd26eaa47a3a87de23ce694 SHA512 0aa557708a300e2eaf48a99d55794069530b6842584cdd867a864272b205c89d5abc2acf3a19d34b3b5519a6429b5f55685129638e65d574ad6afe5b7e1e1e8f
DIST cfssl-1.6.0.tar.gz 7428162 BLAKE2B 100313b756885e00a09003bfd326f8b0d69a14d148cd65b97a53667716c14a8841d862740b7dafbca74da30a8f1d6465ca3f3bad6ccd2ed39379bb1de80fd225 SHA512 a1470c50a6ffa506d2c1798a9e8af5a60206cd41d24cc3ca8a071e9ddfc3249a07fa79c03dabc3df0800985be7e930018045ae95ee83d31486cba93e516da111
+DIST cfssl-1.6.4.tar.gz 7890450 BLAKE2B d179f8768894b3686b377698120df6dd33f7dd82b4f8c74b626ca62168f59eff350129793f0954cc7db5e621d26d99f4e26ea579cf7eb5d5f89520cad060f5ee SHA512 6327d15dda24bf072958c74f4cd0bf1aa4023f935bb24da7f5655739992970fa777f6771603dd3a6edfee6cd2ed418a2fef335f7209ce88cf07674d592c3110f
diff --git a/app-crypt/cfssl/cfssl-1.4.1.ebuild b/app-crypt/cfssl/cfssl-1.4.1.ebuild
index b660f9c05730..7541ce49e832 100644
--- a/app-crypt/cfssl/cfssl-1.4.1.ebuild
+++ b/app-crypt/cfssl/cfssl-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,9 @@ PATCHES=(
)
src_compile() {
+ # bug 905997
+ use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
+
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
}
diff --git a/app-crypt/cfssl/cfssl-1.6.0.ebuild b/app-crypt/cfssl/cfssl-1.6.0.ebuild
index 58eda26f63bc..3d244721ab37 100644
--- a/app-crypt/cfssl/cfssl-1.6.0.ebuild
+++ b/app-crypt/cfssl/cfssl-1.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/cloudflare/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0 BSD BSD-1 MIT MPL-2.0"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
IUSE="hardened"
RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
@@ -21,6 +21,9 @@ PATCHES=(
)
src_compile() {
+ # bug 905997
+ use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
+
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
}
diff --git a/app-crypt/cfssl/cfssl-1.6.4.ebuild b/app-crypt/cfssl/cfssl-1.6.4.ebuild
new file mode 100644
index 000000000000..3d244721ab37
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.6.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+SRC_URI="https://github.com/cloudflare/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-1 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.1-build-fix.patch"
+)
+
+src_compile() {
+ # bug 905997
+ use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
+
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
+}
+
+src_install() {
+ dobin bin/*
+ dodoc CHANGELOG README.md
+}
diff --git a/app-crypt/cfssl/metadata.xml b/app-crypt/cfssl/metadata.xml
index cc044347cf55..73ccf8fb70c5 100644
--- a/app-crypt/cfssl/metadata.xml
+++ b/app-crypt/cfssl/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>williamh@gentoo.org</email>