summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/codecrypt')
-rw-r--r--app-crypt/codecrypt/Manifest1
-rw-r--r--app-crypt/codecrypt/codecrypt-1.7.2.ebuild30
-rw-r--r--app-crypt/codecrypt/codecrypt-1.8-r3.ebuild (renamed from app-crypt/codecrypt/codecrypt-1.8-r1.ebuild)20
-rw-r--r--app-crypt/codecrypt/files/codecrypt-1.8-libcryptopp.pc-rename.patch13
-rw-r--r--app-crypt/codecrypt/metadata.xml9
5 files changed, 30 insertions, 43 deletions
diff --git a/app-crypt/codecrypt/Manifest b/app-crypt/codecrypt/Manifest
index ab0f83414360..2b8abf3d87ff 100644
--- a/app-crypt/codecrypt/Manifest
+++ b/app-crypt/codecrypt/Manifest
@@ -1,2 +1 @@
-DIST codecrypt-1.7.2.tar.gz 446975 BLAKE2B 40b7f97dae84a0fd621ee19c6bfeba47b781a7f856ce9c077445d6387b75b97dce0fc02ee9481241b246b0eb7de6b44ac014a708a8ceba629828ca9d63b8e24c SHA512 4ad2ad9e665e486e353b48efff344436b276eac2dcbddcf4330796b8f1f06284eaeec9c4f4ef63f61e4477c3bce0973f60f76291dce11bee31a75658bee6a3a0
DIST codecrypt-1.8.tar.gz 471273 BLAKE2B 30547c299689547b50e2742e12dbfd32f420217a81813446b36bf5ea52929ca1f3b1968d76937de17e0f003c82186abfa683a6e30dc1fa5dc2ffe89594827ae4 SHA512 0e452f4e93498faa671a5927a3dd93b6dc66cbda7eb71cb33a509f8608573eff5ac8fed0d5e09911e03c153b88c9cb1bb54f7b2aeeb7b6c31eec918ad9685102
diff --git a/app-crypt/codecrypt/codecrypt-1.7.2.ebuild b/app-crypt/codecrypt/codecrypt-1.7.2.ebuild
deleted file mode 100644
index 4b370f10bca4..000000000000
--- a/app-crypt/codecrypt/codecrypt-1.7.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Post-quantum cryptography tool"
-HOMEPAGE="http://e-x-a.org/codecrypt/"
-SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cryptopp"
-
-DEPEND="dev-libs/gmp:=
- cryptopp? ( dev-libs/crypto++ )
- sci-libs/fftw:3.0"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- eapply_user
- # workaround -- gentoo is missing crypto++ pkg-config file
- sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/LDFLAGS="$LDFLAGS -lcrypto++"/' configure.ac
- ./autogen.sh
-}
-
-src_configure() {
- econf \
- $(use_with cryptopp )
-}
diff --git a/app-crypt/codecrypt/codecrypt-1.8-r1.ebuild b/app-crypt/codecrypt/codecrypt-1.8-r3.ebuild
index effd43182526..9c7a5e971a3c 100644
--- a/app-crypt/codecrypt/codecrypt-1.8-r1.ebuild
+++ b/app-crypt/codecrypt/codecrypt-1.8-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -14,18 +14,20 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+cryptopp"
-DEPEND="dev-libs/gmp:=
- cryptopp? ( >=dev-libs/crypto++-7 )
- sci-libs/fftw:3.0"
+DEPEND="
+ dev-libs/gmp:=
+ sci-libs/fftw:3.0=
+ cryptopp? ( >=dev-libs/crypto++-7:= )"
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-libcryptopp.pc-rename.patch )
+
src_prepare() {
default
- # workaround -- the library renamed the pkg-config file
- sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/PKG_CHECK_MODULES([CRYPTOPP], [libcryptopp])/' configure.ac || die
eautoreconf
}
src_configure() {
- econf \
- $(use_with cryptopp )
+ econf $(use_with cryptopp)
}
diff --git a/app-crypt/codecrypt/files/codecrypt-1.8-libcryptopp.pc-rename.patch b/app-crypt/codecrypt/files/codecrypt-1.8-libcryptopp.pc-rename.patch
new file mode 100644
index 000000000000..36cdf8bf4663
--- /dev/null
+++ b/app-crypt/codecrypt/files/codecrypt-1.8-libcryptopp.pc-rename.patch
@@ -0,0 +1,13 @@
+workaround -- the library renamed the pkg-config file
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -37,7 +37,7 @@
+
+ PKG_PROG_PKG_CONFIG([0.25])
+
+- PKG_CHECK_MODULES([CRYPTOPP],[libcrypto++])
++ PKG_CHECK_MODULES([CRYPTOPP],[libcryptopp])
+
+ #crypto++ headers are either in include/crypto++ or include/cryptopp,
+ #the information is otherwise unavailable from standard configuration
diff --git a/app-crypt/codecrypt/metadata.xml b/app-crypt/codecrypt/metadata.xml
index be265ff6c7bb..6b5e15c3f757 100644
--- a/app-crypt/codecrypt/metadata.xml
+++ b/app-crypt/codecrypt/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>exa.exa@gmail.com</email>
<name>Mirek Kratochvil</name>
</maintainer>
@@ -9,7 +9,7 @@
<email>amynka@gentoo.org</email>
<name>Amy Liffey</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
@@ -20,4 +20,7 @@
<use>
<flag name="cryptopp">Build algorithms that need Crypto++ support <pkg>dev-libs/crypto++</pkg></flag>
</use>
+ <upstream>
+ <remote-id type="github">exaexa/codecrypt</remote-id>
+ </upstream>
</pkgmetadata>