summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/efitools/efitools-1.9.2.ebuild')
-rw-r--r--app-crypt/efitools/efitools-1.9.2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/app-crypt/efitools/efitools-1.9.2.ebuild b/app-crypt/efitools/efitools-1.9.2.ebuild
index 5bdfdc911029..8a9b23506766 100644
--- a/app-crypt/efitools/efitools-1.9.2.ebuild
+++ b/app-crypt/efitools/efitools-1.9.2.ebuild
@@ -38,6 +38,11 @@ src_prepare() {
Makefile || die
fi
+ # Let it build with clang.
+ if tc-is-clang; then
+ sed -i -e 's/-fno-toplevel-reorder//g' Make.rules || die
+ fi
+
# Respect users CFLAGS
sed -i -e 's/CFLAGS.*= -O2 -g/CFLAGS += /' Make.rules || die