summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpa/gpa-0.9.4.ebuild')
-rw-r--r--app-crypt/gpa/gpa-0.9.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/gpa/gpa-0.9.4.ebuild b/app-crypt/gpa/gpa-0.9.4.ebuild
new file mode 100644
index 000000000000..4b841e9448ff
--- /dev/null
+++ b/app-crypt/gpa/gpa-0.9.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="The GNU Privacy Assistant (GPA) is a graphical user interface for GnuPG"
+HOMEPAGE="http://gpa.wald.intevation.org"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE_LINGUAS=" ar cs de es fr ja nl pl pt_BR ru sv tr zh_TW"
+IUSE="nls ${IUSE_LINGUAS// / linguas_}"
+
+RDEPEND=">=x11-libs/gtk+-2.10.0:2
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-1.1.0
+ >=app-crypt/gnupg-2
+ >=app-crypt/gpgme-1.2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i 's/Application;//' gpa.desktop
+}
+
+src_configure() {
+ econf \
+ --with-gpgme-prefix=/usr \
+ --with-libassuan-prefix=/usr \
+ $(use_enable nls) \
+ GPGKEYS_LDAP="/usr/libexec/gpgkeys_ldap"
+}