summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpgme/gpgme-1.17.1-r1.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-1.17.1-r1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-crypt/gpgme/gpgme-1.17.1-r1.ebuild b/app-crypt/gpgme/gpgme-1.17.1-r1.ebuild
index 545d22dc9141..db83c2548bf2 100644
--- a/app-crypt/gpgme/gpgme-1.17.1-r1.ebuild
+++ b/app-crypt/gpgme/gpgme-1.17.1-r1.ebuild
@@ -102,15 +102,14 @@ src_compile() {
src_test() {
default
- if use python; then
- test_python() {
- emake -C lang/python/tests check \
- PYTHON=${EPYTHON} \
- PYTHONS=${EPYTHON} \
- TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
- }
- python_foreach_impl test_python
- fi
+ use python && distutils-r1_src_test
+}
+
+python_test() {
+ emake -C lang/python/tests check \
+ PYTHON=${EPYTHON} \
+ PYTHONS=${EPYTHON} \
+ TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
}
src_install() {