summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/hashcat/hashcat-9999.ebuild')
-rw-r--r--app-crypt/hashcat/hashcat-9999.ebuild48
1 files changed, 28 insertions, 20 deletions
diff --git a/app-crypt/hashcat/hashcat-9999.ebuild b/app-crypt/hashcat/hashcat-9999.ebuild
index 1adb6223b74a..d2c503812e53 100644
--- a/app-crypt/hashcat/hashcat-9999.ebuild
+++ b/app-crypt/hashcat/hashcat-9999.ebuild
@@ -1,15 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit pax-utils toolchain-funcs
DESCRIPTION="World's fastest and most advanced password recovery utility"
HOMEPAGE="https://github.com/hashcat/hashcat"
-LICENSE="MIT"
-SLOT="0"
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/hashcat/hashcat.git"
else
@@ -17,33 +15,43 @@ else
SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
+LICENSE="MIT"
+SLOT="0"
IUSE="brain video_cards_nvidia"
-DEPEND="
- app-arch/lzma
+RESTRICT=test
+
+DEPEND="app-arch/lzma
app-arch/unrar
sys-libs/zlib[minizip]
brain? ( dev-libs/xxhash )
- video_cards_nvidia? ( >x11-drivers/nvidia-drivers-440.64
- || ( dev-util/nvidia-cuda-toolkit
- virtual/opencl )
- )
+ video_cards_nvidia? (
+ >x11-drivers/nvidia-drivers-440.64
+ || (
+ dev-util/nvidia-cuda-toolkit
+ virtual/opencl
+ )
+ )
!video_cards_nvidia? ( virtual/opencl )"
RDEPEND="${DEPEND}"
src_prepare() {
- # remove bundled stuff
+ # Remove bundled stuff
rm -r deps/OpenCL-Headers || die "Failed to remove bundled OpenCL Headers"
rm -r deps/xxHash || die "Failed to remove bundled xxHash"
+
# TODO: Gentoo's app-arch/lzma doesn't install the needed files
#rm -r deps/LZMA-SDK || die "Failed to remove bundled LZMA-SDK"
#rm -r deps || die "Failed to remove bundled deps"
- # do not strip
- sed -i "/LFLAGS += -s/d" src/Makefile
- # do not add random CFLAGS
+ # Do not strip
+ sed -i "/LFLAGS += -s/d" src/Makefile || die
+
+ # Do not add random CFLAGS
sed -i "s/-O2//" src/Makefile || die
+
#sed -i "#LZMA_SDK_INCLUDE#d" src/Makefile || die
- # respect CC, CXX, AR
+
+ # Respect CC, CXX, AR
sed -i \
-e 's/:= gcc/:= $(CC)/' \
-e 's/:= g++/:= $(CXX)/' \
@@ -80,14 +88,14 @@ src_test() {
addwrite /dev/nvidia0
addwrite /dev/nvidiactl
addwrite /dev/nvidia-uvm
- if [ ! -w /dev/nvidia0 ]; then
+
+ if [[ ! -w /dev/nvidia0 ]]; then
einfo "To run these tests, portage likely must be in the video group."
einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
fi
- #elif use vidia_cards_fglrx; then
- # addwrite /dev/ati
fi
- #this always exits with 255 despite success
+
+ # This always exits with 255 despite success
#./hashcat -b -m 2500 || die "Test failed"
LD_PRELOAD=./libhashcat.so.${PV} ./hashcat -a 3 -m 1500 nQCk49SiErOgk || die "Test failed"
}