summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/hashcat')
-rw-r--r--app-crypt/hashcat/Manifest3
-rw-r--r--app-crypt/hashcat/files/hashcat-6.0.0-missing-not-fatal.patch53
-rw-r--r--app-crypt/hashcat/hashcat-5.1.0.ebuild68
-rw-r--r--app-crypt/hashcat/hashcat-6.1.1.ebuild (renamed from app-crypt/hashcat/hashcat-6.0.0-r1.ebuild)4
4 files changed, 2 insertions, 126 deletions
diff --git a/app-crypt/hashcat/Manifest b/app-crypt/hashcat/Manifest
index 81244abeb2ec..6a7e552c3328 100644
--- a/app-crypt/hashcat/Manifest
+++ b/app-crypt/hashcat/Manifest
@@ -1,2 +1 @@
-DIST hashcat-5.1.0.tar.gz 4266878 BLAKE2B 677554fc5d6c5a93d0f4955c2e3cb6a40913ca2f7d00a89cf0c00bb48cadcaca94d3fdf55b853208f9fda4ce1bcc13fed865c5128a7c429223bcf8b4b825a15b SHA512 90605c2bcd0ec275d2f6ec581899b95cdc320b1494613a19803192c8a08037a7829b3776ed42c58eb6551ec1a746f47f94ab5b273958ca74e0fc57315e209ece
-DIST hashcat-6.0.0.tar.gz 5360568 BLAKE2B 9d44c94d136a4c4cf7254ee11dc978db6bb1159d66ea525777c0a3dae59149983c9e8220f50cdbe6c24e330c757f3519b48f920662582e914f80068723ba5acd SHA512 b508c77e1735c02bb59c427774a3f4fafdea37d09777ef2dcb6e5081cb993d02c4f46a6ab846dc97a8cef2b0f69bbc191e26b8f1608a299bc2c1a6b3d2474f96
+DIST hashcat-6.1.1.tar.gz 5385180 BLAKE2B a1a90f691222c7810150a23d513bd1d24bca4682dd8dec2ff5bdc9cc9f82d5a2b00407de966a7c7db131cf1c1709b5f78c97d45176598d6bb7ebd381c38b4ba8 SHA512 788539b488ba55684d6d93ce18f3b05fa822a8cbfcdbcde9c2b54001d8927580dca253e0e9ff9a19f4278045046d732e104054fc743c39f47952ca24d2e93724
diff --git a/app-crypt/hashcat/files/hashcat-6.0.0-missing-not-fatal.patch b/app-crypt/hashcat/files/hashcat-6.0.0-missing-not-fatal.patch
deleted file mode 100644
index 52120e0e05c4..000000000000
--- a/app-crypt/hashcat/files/hashcat-6.0.0-missing-not-fatal.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/docs/changes.txt b/docs/changes.txt
-index 1527da46..420c2102 100644
---- a/docs/changes.txt
-+++ b/docs/changes.txt
-@@ -1,3 +1,11 @@
-+* changes v6.0.0 -> v6.0.x
-+
-+##
-+## Improvements
-+##
-+
-+- OpenCL Runtime: Reinterpret return code CL_DEVICE_NOT_FOUND from clGetDeviceIDs() as non-fatal
-+
- * changes v5.1.0 -> v6.0.0
-
- ##
-diff --git a/src/backend.c b/src/backend.c
-index 80fdbb38..7f79879f 100644
---- a/src/backend.c
-+++ b/src/backend.c
-@@ -5185,7 +5185,31 @@ int backend_ctx_init (hashcat_ctx_t *hashcat_ctx)
- {
- event_log_error (hashcat_ctx, "clGetDeviceIDs(): %s", val2cstr_cl (CL_rc));
-
-- return -1;
-+ // Special handling for CL_DEVICE_NOT_FOUND, see: https://github.com/hashcat/hashcat/issues/2455
-+
-+ #define IGNORE_DEVICE_NOT_FOUND 1
-+
-+ if (IGNORE_DEVICE_NOT_FOUND)
-+ {
-+ backend_ctx_t *backend_ctx = hashcat_ctx->backend_ctx;
-+
-+ OCL_PTR *ocl = (OCL_PTR *) backend_ctx->ocl;
-+
-+ const cl_int CL_err = ocl->clGetDeviceIDs (opencl_platform, CL_DEVICE_TYPE_ALL, DEVICES_MAX, opencl_platform_devices, &opencl_platform_devices_cnt);
-+
-+ if (CL_err == CL_DEVICE_NOT_FOUND)
-+ {
-+ // we ignore this error
-+ }
-+ else
-+ {
-+ return -1;
-+ }
-+ }
-+ else
-+ {
-+ return -1;
-+ }
- }
-
- opencl_platforms_devices[opencl_platforms_idx] = opencl_platform_devices;
diff --git a/app-crypt/hashcat/hashcat-5.1.0.ebuild b/app-crypt/hashcat/hashcat-5.1.0.ebuild
deleted file mode 100644
index bc8b3fb95c51..000000000000
--- a/app-crypt/hashcat/hashcat-5.1.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils pax-utils multilib
-
-DESCRIPTION="World's fastest and most advanced password recovery utility"
-HOMEPAGE="https://github.com/hashcat/hashcat"
-LICENSE="MIT"
-SLOT="0"
-if [ "${PV}" = "9999" ]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hashcat/hashcat.git"
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-IUSE="brain video_cards_nvidia"
-DEPEND="virtual/opencl
- app-arch/lzma
- brain? ( dev-libs/xxhash )
- video_cards_nvidia? ( >x11-drivers/nvidia-drivers-367.0 )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- #remove bundled stuff
- rm -r deps/OpenCL-Headers || die "Failed to remove bundled OpenCL Headers"
- rm -r deps/xxHash || die "Failed to remove bundled xxHash"
- #rm -r deps/LZMA-SDK || die "Failed to remove bundled LZMA-SDK"
- #rm -r deps || die "Failed to remove bundled deps"
- #do not strip
- sed -i "/LFLAGS += -s/d" src/Makefile
- #do not add random CFLAGS
- sed -i "s/-O2//" src/Makefile || die
- sed -i "#LZMA_SDK_INCLUDE#d" src/Makefile || die
- export PREFIX=/usr
- export LIBRARY_FOLDER="/usr/$(get_libdir)"
- export DOCUMENT_FOLDER="/usr/share/doc/${P}"
- eapply_user
-}
-
-src_compile() {
- emake SHARED=1 PRODUCTION=1 ENABLE_BRAIN=$(usex brain 1 0) USE_SYSTEM_LZMA=0 USE_SYSTEM_OPENCL=1 USE_SYSTEM_XXHASH=1 VERSION_PURE="${PV}"
- pax-mark -mr hashcat
-}
-
-src_test() {
- if use video_cards_nvidia; then
- addwrite /dev/nvidia0
- addwrite /dev/nvidiactl
- addwrite /dev/nvidia-uvm
- if [ ! -w /dev/nvidia0 ]; then
- einfo "To run these tests, portage likely must be in the video group."
- einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
- fi
- #elif use vidia_cards_fglrx; then
- # addwrite /dev/ati
- fi
- #this always exits with 255 despite success
- #./hashcat -b -m 2500 || die "Test failed"
- LD_PRELOAD=./libhashcat.so.${PV} ./hashcat -a 3 -m 1500 nQCk49SiErOgk || die "Test failed"
-}
-
-src_install() {
- emake DESTDIR="${ED}" SHARED=1 PRODUCTION=1 ENABLE_BRAIN=$(usex brain 1 0) USE_SYSTEM_LZMA=0 USE_SYSTEM_OPENCL=1 USE_SYSTEM_XXHASH=1 VERSION_PURE="${PV}" install
-}
diff --git a/app-crypt/hashcat/hashcat-6.0.0-r1.ebuild b/app-crypt/hashcat/hashcat-6.1.1.ebuild
index eab3098c5c18..2f467f39c054 100644
--- a/app-crypt/hashcat/hashcat-6.0.0-r1.ebuild
+++ b/app-crypt/hashcat/hashcat-6.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,8 +28,6 @@ DEPEND="
!video_cards_nvidia? ( virtual/opencl )"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-missing-not-fatal.patch" )
-
src_prepare() {
#remove bundled stuff
rm -r deps/OpenCL-Headers || die "Failed to remove bundled OpenCL Headers"