summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/heimdal/files')
-rw-r--r--app-crypt/heimdal/files/heimdal_build-headers-before-use.patch29
-rw-r--r--app-crypt/heimdal/files/heimdal_fix-db60.patch11
-rw-r--r--app-crypt/heimdal/files/heimdal_hcrypto.patch45
3 files changed, 85 insertions, 0 deletions
diff --git a/app-crypt/heimdal/files/heimdal_build-headers-before-use.patch b/app-crypt/heimdal/files/heimdal_build-headers-before-use.patch
new file mode 100644
index 000000000000..9460e3dcc245
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal_build-headers-before-use.patch
@@ -0,0 +1,29 @@
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906623
+
+--- a/lib/hx509/Makefile.am 2019-05-16 08:59:34.326758842 +0300
++++ b/lib/hx509/Makefile.am 2019-05-16 08:58:43.140804423 +0300
+@@ -147,8 +147,8 @@
+
+ $(ALL_OBJECTS): $(HX509_PROTOS)
+
+-$(libhx509_la_OBJECTS): $(srcdir)/hx_locl.h
+-$(libhx509_la_OBJECTS): ocsp_asn1.h pkcs10_asn1.h
++$(ALL_OBJECTS): $(srcdir)/hx_locl.h
++$(ALL_OBJECTS): ocsp_asn1.h pkcs10_asn1.h $(dist_include_HEADERS)
+
+ $(srcdir)/hx509-protos.h: $(dist_libhx509_la_SOURCES)
+ $(heim_verbose)cd $(srcdir) && perl ../../cf/make-proto.pl -R '^(_|^C)' -E HX509_LIB -q -P comment -o hx509-protos.h $(dist_libhx509_la_SOURCES) || rm -f hx509-protos.h
+--- a/lib/hcrypto/Makefile.am 2019-05-16 09:02:28.154602045 +0300
++++ b/lib/hcrypto/Makefile.am 2019-05-16 09:02:10.600617878 +0300
+@@ -102,6 +102,11 @@
+
+ TESTS = $(PROGRAM_TESTS) $(SCRIPT_TESTS)
+
++ALL_OBJECTS = $(libhcrypto_la_OBJECTS)
++ALL_OBJECTS += $(test_rand_OBJECTS)
++ALL_OBJECTS += $(libhctest_la_OBJECTS)
++$(ALL_OBJECTS): | install-build-headers
++
+ LDADD = $(lib_LTLIBRARIES) $(LIB_roken) $(LIB_openssl_crypto)
+ test_rand_LDADD = $(LDADD) -lm
+
diff --git a/app-crypt/heimdal/files/heimdal_fix-db60.patch b/app-crypt/heimdal/files/heimdal_fix-db60.patch
new file mode 100644
index 000000000000..7f012007e1ed
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal_fix-db60.patch
@@ -0,0 +1,11 @@
+--- a/lib/roken/ndbm_wrap.c 2016-12-20 17:23:06.000000000 +0300
++++ b/lib/roken/ndbm_wrap.c 2019-05-17 10:00:00.107905769 +0300
+@@ -175,7 +175,7 @@
+ return NULL;
+ }
+
+-#if (DB_VERSION_MAJOR > 3) && (DB_VERSION_MINOR > 0)
++#if DB_VERSION_MAJOR > 4 || (DB_VERSION_MAJOR > 3 && DB_VERSION_MINOR > 0)
+ if(db->open(db, NULL, fn, NULL, DB_BTREE, myflags, mode) != 0) {
+ #else
+ if(db->open(db, fn, NULL, DB_BTREE, myflags, mode) != 0) {
diff --git a/app-crypt/heimdal/files/heimdal_hcrypto.patch b/app-crypt/heimdal/files/heimdal_hcrypto.patch
new file mode 100644
index 000000000000..ff3228d4973a
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal_hcrypto.patch
@@ -0,0 +1,45 @@
+From 329918bd671c89de6e1c2874baba48d658a89a10 Mon Sep 17 00:00:00 2001
+From: Damir Franusic <df@release14.org>
+Date: Sun, 9 Dec 2018 19:53:58 +0100
+Subject: [PATCH] hcrypto: fix include path
+
+---
+ lib/hcrypto/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/lib/hcrypto/Makefile.am b/lib/hcrypto/Makefile.am
+index 469176b6c6..195117d174 100644
+--- a/lib/hcrypto/Makefile.am
++++ b/lib/hcrypto/Makefile.am
+@@ -9,7 +9,8 @@ AM_CPPFLAGS += $(INCLUDE_openssl_crypto)
+ endif
+
+ AM_CPPFLAGS += -I$(top_srcdir)/lib/hx509 \
+- -I$(srcdir)/libtommath -DUSE_HCRYPTO_LTM=1
++ -I$(srcdir)/libtommath -DUSE_HCRYPTO_LTM=1 \
++ -I$(srcdir)/..
+
+ lib_LTLIBRARIES = libhcrypto.la
+ check_LTLIBRARIES = libhctest.la
+From 572a6fd7ac41e9210ef3eb765fe7da4ec8a94bb2 Mon Sep 17 00:00:00 2001
+From: Luke Howard <lukeh@padl.com>
+Date: Mon, 24 Dec 2018 02:21:32 +0000
+Subject: [PATCH] hx509: fix dependency, hxtool requires ASN.1 headers
+
+---
+ lib/hx509/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/hx509/Makefile.am b/lib/hx509/Makefile.am
+index b58deb3e37..09643c43a0 100644
+--- a/lib/hx509/Makefile.am
++++ b/lib/hx509/Makefile.am
+@@ -164,7 +164,7 @@ hxtool-commands.c hxtool-commands.h: hxtool-commands.in $(SLC)
+ dist_hxtool_SOURCES = hxtool.c
+ nodist_hxtool_SOURCES = hxtool-commands.c hxtool-commands.h
+
+-$(hxtool_OBJECTS): hxtool-commands.h hx509_err.h
++$(hxtool_OBJECTS): hxtool-commands.h $(nodist_include_HEADERS)
+
+ hxtool_LDADD = \
+ libhx509.la \