summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/Manifest4
-rw-r--r--app-crypt/heimdal/files/heimdal-7.8.0-CVE-2022-45142.patch36
-rw-r--r--app-crypt/heimdal/files/heimdal-7.8.0-configure-clang16.patch54
-rw-r--r--app-crypt/heimdal/files/heimdal_hcrypto.patch45
-rw-r--r--app-crypt/heimdal/heimdal-7.8.0-r1.ebuild (renamed from app-crypt/heimdal/heimdal-7.6.0.ebuild)36
-rw-r--r--app-crypt/heimdal/heimdal-7.8.0-r2.ebuild (renamed from app-crypt/heimdal/heimdal-7.7.0-r1.ebuild)35
-rw-r--r--app-crypt/heimdal/heimdal-7.8.0-r3.ebuild (renamed from app-crypt/heimdal/heimdal-7.5.0.ebuild)87
-rw-r--r--app-crypt/heimdal/metadata.xml10
8 files changed, 181 insertions, 126 deletions
diff --git a/app-crypt/heimdal/Manifest b/app-crypt/heimdal/Manifest
index cb3e185d2dac..1c1d72c4ec6f 100644
--- a/app-crypt/heimdal/Manifest
+++ b/app-crypt/heimdal/Manifest
@@ -1,3 +1 @@
-DIST heimdal-7.5.0.tar.gz 10071281 BLAKE2B 917f5855248c333e5ec35bf992973d8b5fb84581b9c3bc8d42c328e5f878ce24c5596c5a1e3fbca786a71be04984068efbb817f7336135056d1feae38895758f SHA512 6d1ad77e795df786680b5e68e2bfefee27bd0207eab507295d7af7053135de9c9ebb517d2c0235bc3a7d50945e18044515f0d76c0899b6b74aa839f1f3e5b131
-DIST heimdal-7.6.0.tar.gz 10186832 BLAKE2B 456b495a3d0a196cf02d6042c6db72c772327545fbc84f7bb758f55f3fca025432bf319fc33e9e0b5fe5ca78b83aea9dc47d77bf1f5b69ae88f1286a22c41263 SHA512 3f7ce090cf8da91f19675a1d9f6bd65c83b3a847337739481506f09d74001cb44283b103ba684dac8a5f11ec48605b5476240c534f6fc36442fb874b73680200
-DIST heimdal-7.7.0.tar.gz 10189293 BLAKE2B db9cdd1861dc9214a7f76b3d8b9656cfc0bad11cb6eadffa4fa29ea7f9aabd4c3d1b628c510644ec9abe1b3bf27a413ccf8cd590d602c4a4ac54ba3deb4cedc4 SHA512 6660939b5a36ce36310721a08a089fb671d1e3d2e8ac74ea4775bfa5f8f772d32de805551456200fe96cc486c092c44beb84f5dd877008bc305490ee971bbf99
+DIST heimdal-7.8.0.tar.gz 10024936 BLAKE2B bab8ed12a5257395b34bb88e22147912857015c652f0899c54809582c49f9c33b9ac748b28dd38ac7072d245e86e44c5dafb8725103fcb4a6dae16c8d1d4b623 SHA512 0167345aca77d65b7a1113874eee5b65ec6e1fec1f196d57e571265409fa35ef95a673a4fd4aafbb0ab5fb5b246b97412353a68d6613a8aff6393a9f1e72999e
diff --git a/app-crypt/heimdal/files/heimdal-7.8.0-CVE-2022-45142.patch b/app-crypt/heimdal/files/heimdal-7.8.0-CVE-2022-45142.patch
new file mode 100644
index 000000000000..dad75df4b3b8
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-7.8.0-CVE-2022-45142.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/893722
+https://www.openwall.com/lists/oss-security/2023/02/08/1
+
+From: Helmut Grohne <helmut@...divi.de>
+Subject: [PATCH v3] CVE-2022-45142: gsskrb5: fix accidental logic inversions
+
+The referenced commit attempted to fix miscompilations with gcc-9 and
+gcc-10 by changing `memcmp(...)` to `memcmp(...) != 0`. Unfortunately,
+it also inverted the result of the comparison in two occasions. This
+inversion happened during backporting the patch to 7.7.1 and 7.8.0.
+
+Fixes: f6edaafcfefd ("gsskrb5: CVE-2022-3437 Use constant-time memcmp()
+ for arcfour unwrap")
+Signed-off-by: Helmut Grohne <helmut@...divi.de>
+--- a/lib/gssapi/krb5/arcfour.c
++++ b/lib/gssapi/krb5/arcfour.c
+@@ -365,7 +365,7 @@ _gssapi_verify_mic_arcfour(OM_uint32 * minor_status,
+ return GSS_S_FAILURE;
+ }
+
+- cmp = (ct_memcmp(cksum_data, p + 8, 8) == 0);
++ cmp = (ct_memcmp(cksum_data, p + 8, 8) != 0);
+ if (cmp) {
+ *minor_status = 0;
+ return GSS_S_BAD_MIC;
+@@ -730,7 +730,7 @@ OM_uint32 _gssapi_unwrap_arcfour(OM_uint32 *minor_status,
+ return GSS_S_FAILURE;
+ }
+
+- cmp = (ct_memcmp(cksum_data, p0 + 16, 8) == 0); /* SGN_CKSUM */
++ cmp = (ct_memcmp(cksum_data, p0 + 16, 8) != 0); /* SGN_CKSUM */
+ if (cmp) {
+ _gsskrb5_release_buffer(minor_status, output_message_buffer);
+ *minor_status = 0;
+--
+2.38.1
diff --git a/app-crypt/heimdal/files/heimdal-7.8.0-configure-clang16.patch b/app-crypt/heimdal/files/heimdal-7.8.0-configure-clang16.patch
new file mode 100644
index 000000000000..6e948bc51c3b
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-7.8.0-configure-clang16.patch
@@ -0,0 +1,54 @@
+https://bugs.gentoo.org/899072
+https://github.com/heimdal/heimdal/issues/790
+https://github.com/heimdal/heimdal/pull/1085
+
+From 5b872a635c9c8f04f58e03c43e7953c35e1f66b7 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 13 Apr 2023 13:13:59 +0200
+Subject: [PATCH 1/2] cf: Include <string.h> for memset in AC_HAVE_STRUCT_FIELD
+
+Otherwise, the check relies on an implicit function declaration,
+and will fail unconditionally with compilers that do not support
+them.
+--- a/cf/have-struct-field.m4
++++ b/cf/have-struct-field.m4
+@@ -7,7 +7,8 @@ dnl AC_HAVE_STRUCT_FIELD(struct, field, headers)
+ AC_DEFUN([AC_HAVE_STRUCT_FIELD], [
+ define(cache_val, translit(ac_cv_type_$1_$2, [A-Z ], [a-z_]))
+ AC_CACHE_CHECK([for $2 in $1], cache_val,[
+-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[$3]],
++AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <string.h>
++$3]],
+ [[$1 x; memset(&x, 0, sizeof(x)); x.$2]])],
+ [cache_val=yes],
+ [cache_val=no])
+
+From fc6d5b5c7677bb7271361c4bd60ea1bd36d944b9 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 13 Apr 2023 13:26:29 +0200
+Subject: [PATCH 2/2] cf: Do not use headers and argument lists in
+ AC_FIND_FUNC_NO_LIBS2
+
+The callers of this macro generally do not supply this information.
+Without it, the checks rely on compiler support for implicit function
+declarations. It would be possible to supply this information in
+the callers. But even then, with the existing macro interface, it
+would be necessary to pass eg. null pointers where they trigger
+undefined behavior. Therefore, use the same kludge that autoconf
+uses to make up prototypes, avoiding those implicit function
+declarations.
+
+The includes/arguments macro parameters are now ignored, but preserved
+for interface compatibility.
+--- a/cf/find-func-no-libs2.m4
++++ b/cf/find-func-no-libs2.m4
+@@ -21,7 +21,7 @@ if eval "test \"\$ac_cv_func_$1\" != yes" ; then
+ *) ac_lib="-l$ac_lib" ;;
+ esac
+ LIBS="$6 $ac_lib $5 $ac_save_LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[$3]],[[$1($4)]])],[eval "if test -n \"$ac_lib\";then ac_cv_funclib_$1=$ac_lib; else ac_cv_funclib_$1=yes; fi";break])
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[char $1 (void);]],[[$1()]])],[eval "if test -n \"$ac_lib\";then ac_cv_funclib_$1=$ac_lib; else ac_cv_funclib_$1=yes; fi";break])
+ done
+ eval "ac_cv_funclib_$1=\${ac_cv_funclib_$1-no}"
+ LIBS="$ac_save_LIBS"
+
diff --git a/app-crypt/heimdal/files/heimdal_hcrypto.patch b/app-crypt/heimdal/files/heimdal_hcrypto.patch
deleted file mode 100644
index ff3228d4973a..000000000000
--- a/app-crypt/heimdal/files/heimdal_hcrypto.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 329918bd671c89de6e1c2874baba48d658a89a10 Mon Sep 17 00:00:00 2001
-From: Damir Franusic <df@release14.org>
-Date: Sun, 9 Dec 2018 19:53:58 +0100
-Subject: [PATCH] hcrypto: fix include path
-
----
- lib/hcrypto/Makefile.am | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/lib/hcrypto/Makefile.am b/lib/hcrypto/Makefile.am
-index 469176b6c6..195117d174 100644
---- a/lib/hcrypto/Makefile.am
-+++ b/lib/hcrypto/Makefile.am
-@@ -9,7 +9,8 @@ AM_CPPFLAGS += $(INCLUDE_openssl_crypto)
- endif
-
- AM_CPPFLAGS += -I$(top_srcdir)/lib/hx509 \
-- -I$(srcdir)/libtommath -DUSE_HCRYPTO_LTM=1
-+ -I$(srcdir)/libtommath -DUSE_HCRYPTO_LTM=1 \
-+ -I$(srcdir)/..
-
- lib_LTLIBRARIES = libhcrypto.la
- check_LTLIBRARIES = libhctest.la
-From 572a6fd7ac41e9210ef3eb765fe7da4ec8a94bb2 Mon Sep 17 00:00:00 2001
-From: Luke Howard <lukeh@padl.com>
-Date: Mon, 24 Dec 2018 02:21:32 +0000
-Subject: [PATCH] hx509: fix dependency, hxtool requires ASN.1 headers
-
----
- lib/hx509/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/hx509/Makefile.am b/lib/hx509/Makefile.am
-index b58deb3e37..09643c43a0 100644
---- a/lib/hx509/Makefile.am
-+++ b/lib/hx509/Makefile.am
-@@ -164,7 +164,7 @@ hxtool-commands.c hxtool-commands.h: hxtool-commands.in $(SLC)
- dist_hxtool_SOURCES = hxtool.c
- nodist_hxtool_SOURCES = hxtool-commands.c hxtool-commands.h
-
--$(hxtool_OBJECTS): hxtool-commands.h hx509_err.h
-+$(hxtool_OBJECTS): hxtool-commands.h $(nodist_include_HEADERS)
-
- hxtool_LDADD = \
- libhx509.la \
diff --git a/app-crypt/heimdal/heimdal-7.6.0.ebuild b/app-crypt/heimdal/heimdal-7.8.0-r1.ebuild
index 36aee840b6d5..2db7d36fe6fe 100644
--- a/app-crypt/heimdal/heimdal-7.6.0.ebuild
+++ b/app-crypt/heimdal/heimdal-7.8.0-r1.ebuild
@@ -1,39 +1,42 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{10..11} )
VIRTUALX_REQUIRED="manual"
-inherit autotools db-use multilib multilib-minimal python-any-r1 virtualx flag-o-matic
+inherit autotools db-use multilib-minimal python-any-r1 virtualx flag-o-matic
MY_P="${P}"
DESCRIPTION="Kerberos 5 implementation from KTH"
-HOMEPAGE="http://www.h5l.org/"
+HOMEPAGE="https://www.heimdal.software/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ~ppc64 s390 sparc x86"
-IUSE="afs +berkdb caps gdbm hdb-ldap ipv6 libressl +lmdb otp selinux ssl static-libs test X"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="afs +berkdb caps gdbm hdb-ldap +lmdb otp selinux ssl static-libs test X"
RESTRICT="!test? ( test )"
+# 717740
+REQUIRED_USE="otp? ( berkdb )"
+
CDEPEND="
+ virtual/libcrypt:=[${MULTILIB_USEDEP}]
ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
)
berkdb? ( >=sys-libs/db-4.8.30-r1:*[${MULTILIB_USEDEP}] )
gdbm? ( >=sys-libs/gdbm-1.10-r1:=[${MULTILIB_USEDEP}] )
- lmdb? ( dev-db/lmdb )
+ lmdb? ( dev-db/lmdb:= )
caps? ( sys-libs/libcap-ng )
>=dev-db/sqlite-3.8.2[${MULTILIB_USEDEP}]
- >=sys-libs/e2fsprogs-libs-1.42.9[${MULTILIB_USEDEP}]
+ >=sys-fs/e2fsprogs-1.46.4-r51[${MULTILIB_USEDEP}]
sys-libs/ncurses:0=
>=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}]
afs? ( net-fs/openafs )
- hdb-ldap? ( >=net-nds/openldap-2.3.0 )
+ hdb-ldap? ( >=net-nds/openldap-2.3.0:= )
X? (
x11-libs/libX11
x11-libs/libXau
@@ -46,7 +49,8 @@ DEPEND="${CDEPEND}
${PYTHON_DEPS}
dev-perl/JSON
virtual/pkgconfig
- >=sys-devel/autoconf-2.62
+ sys-apps/texinfo
+ >=dev-build/autoconf-2.62
test? ( X? ( ${VIRTUALX_DEPEND} ) )"
RDEPEND="${CDEPEND}
@@ -70,9 +74,9 @@ MULTILIB_CHOST_TOOLS=(
PATCHES=(
"${FILESDIR}/heimdal_disable-check-iprop.patch"
"${FILESDIR}/heimdal_tinfo.patch"
- "${FILESDIR}/heimdal_hcrypto.patch"
"${FILESDIR}/heimdal_build-headers-before-use.patch"
"${FILESDIR}/heimdal_fix-db60.patch"
+ "${FILESDIR}/heimdal-7.8.0-CVE-2022-45142.patch"
)
src_prepare() {
@@ -99,6 +103,7 @@ multilib_src_configure() {
--enable-pthread-support
--enable-kx509
--enable-pk-init
+ --with-ipv6
$(use_enable afs afs-support)
$(use_enable gdbm ndbm-db)
$(use_enable lmdb mdb-db)
@@ -106,7 +111,6 @@ multilib_src_configure() {
$(use_enable static-libs static)
$(multilib_native_use_with caps capng)
$(multilib_native_use_with hdb-ldap openldap "${EPREFIX}"/usr)
- $(use_with ipv6)
$(use_with ssl openssl "${EPREFIX}"/usr)
$(multilib_native_use_with X x)
)
@@ -121,7 +125,7 @@ multilib_src_configure() {
)
fi
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+ CONFIG_SHELL="${BROOT}"/bin/bash ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_compile() {
diff --git a/app-crypt/heimdal/heimdal-7.7.0-r1.ebuild b/app-crypt/heimdal/heimdal-7.8.0-r2.ebuild
index 1f5dcf3141cf..8645dd099c0d 100644
--- a/app-crypt/heimdal/heimdal-7.7.0-r1.ebuild
+++ b/app-crypt/heimdal/heimdal-7.8.0-r2.ebuild
@@ -1,39 +1,42 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{10..11} )
VIRTUALX_REQUIRED="manual"
-inherit autotools db-use multilib multilib-minimal python-any-r1 virtualx flag-o-matic
+inherit autotools db-use multilib-minimal python-any-r1 virtualx flag-o-matic
MY_P="${P}"
DESCRIPTION="Kerberos 5 implementation from KTH"
-HOMEPAGE="http://www.h5l.org/"
+HOMEPAGE="https://www.heimdal.software/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="afs +berkdb caps gdbm hdb-ldap libressl +lmdb otp selinux ssl static-libs test X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="afs +berkdb caps gdbm hdb-ldap +lmdb otp selinux ssl static-libs test X"
RESTRICT="!test? ( test )"
+# 717740
+REQUIRED_USE="otp? ( berkdb )"
+
CDEPEND="
+ virtual/libcrypt:=[${MULTILIB_USEDEP}]
ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
)
berkdb? ( >=sys-libs/db-4.8.30-r1:*[${MULTILIB_USEDEP}] )
gdbm? ( >=sys-libs/gdbm-1.10-r1:=[${MULTILIB_USEDEP}] )
- lmdb? ( dev-db/lmdb )
+ lmdb? ( dev-db/lmdb:= )
caps? ( sys-libs/libcap-ng )
>=dev-db/sqlite-3.8.2[${MULTILIB_USEDEP}]
- >=sys-libs/e2fsprogs-libs-1.42.9[${MULTILIB_USEDEP}]
+ >=sys-fs/e2fsprogs-1.46.4-r51[${MULTILIB_USEDEP}]
sys-libs/ncurses:0=
>=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}]
afs? ( net-fs/openafs )
- hdb-ldap? ( >=net-nds/openldap-2.3.0 )
+ hdb-ldap? ( >=net-nds/openldap-2.3.0:= )
X? (
x11-libs/libX11
x11-libs/libXau
@@ -46,7 +49,8 @@ DEPEND="${CDEPEND}
${PYTHON_DEPS}
dev-perl/JSON
virtual/pkgconfig
- >=sys-devel/autoconf-2.62
+ sys-apps/texinfo
+ >=dev-build/autoconf-2.62
test? ( X? ( ${VIRTUALX_DEPEND} ) )"
RDEPEND="${CDEPEND}
@@ -70,9 +74,10 @@ MULTILIB_CHOST_TOOLS=(
PATCHES=(
"${FILESDIR}/heimdal_disable-check-iprop.patch"
"${FILESDIR}/heimdal_tinfo.patch"
- "${FILESDIR}/heimdal_hcrypto.patch"
"${FILESDIR}/heimdal_build-headers-before-use.patch"
"${FILESDIR}/heimdal_fix-db60.patch"
+ "${FILESDIR}/heimdal-7.8.0-CVE-2022-45142.patch"
+ "${FILESDIR}/heimdal-7.8.0-configure-clang16.patch"
)
src_prepare() {
@@ -121,7 +126,7 @@ multilib_src_configure() {
)
fi
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+ CONFIG_SHELL="${BROOT}"/bin/bash ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_compile() {
diff --git a/app-crypt/heimdal/heimdal-7.5.0.ebuild b/app-crypt/heimdal/heimdal-7.8.0-r3.ebuild
index 0710a88ee3d1..597d9cf695c5 100644
--- a/app-crypt/heimdal/heimdal-7.5.0.ebuild
+++ b/app-crypt/heimdal/heimdal-7.8.0-r3.ebuild
@@ -1,50 +1,47 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-VIRTUALX_REQUIRED="manual"
+EAPI=8
-inherit autotools db-use multilib multilib-minimal python-any-r1 virtualx flag-o-matic
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit autotools db-use multilib-minimal python-any-r1 flag-o-matic
MY_P="${P}"
DESCRIPTION="Kerberos 5 implementation from KTH"
-HOMEPAGE="http://www.h5l.org/"
+HOMEPAGE="https://www.heimdal.software/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 ~sparc x86"
-IUSE="afs +berkdb caps hdb-ldap ipv6 libressl otp +pkinit selinux ssl static-libs test X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="afs +berkdb caps gdbm hdb-ldap +lmdb otp selinux static-libs test X"
RESTRICT="!test? ( test )"
+# 717740
+REQUIRED_USE="otp? ( berkdb )"
+
CDEPEND="
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
- )
+ virtual/libcrypt:=[${MULTILIB_USEDEP}]
berkdb? ( >=sys-libs/db-4.8.30-r1:*[${MULTILIB_USEDEP}] )
- !berkdb? ( >=sys-libs/gdbm-1.10-r1:=[${MULTILIB_USEDEP}] )
+ gdbm? ( >=sys-libs/gdbm-1.10-r1:=[${MULTILIB_USEDEP}] )
+ lmdb? ( dev-db/lmdb:= )
caps? ( sys-libs/libcap-ng )
>=dev-db/sqlite-3.8.2[${MULTILIB_USEDEP}]
- >=sys-libs/e2fsprogs-libs-1.42.9[${MULTILIB_USEDEP}]
+ >=sys-fs/e2fsprogs-1.46.4-r51[${MULTILIB_USEDEP}]
sys-libs/ncurses:0=
>=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}]
afs? ( net-fs/openafs )
- hdb-ldap? ( >=net-nds/openldap-2.3.0 )
- X? (
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXt
- )
+ hdb-ldap? ( >=net-nds/openldap-2.3.0:= )
!!app-crypt/mit-krb5
!!app-crypt/mit-krb5-appl"
DEPEND="${CDEPEND}
${PYTHON_DEPS}
+ dev-perl/JSON
virtual/pkgconfig
- >=sys-devel/autoconf-2.62
- test? ( X? ( ${VIRTUALX_DEPEND} ) )"
+ sys-apps/texinfo
+ >=dev-build/autoconf-2.62"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-kerberos )"
@@ -64,10 +61,17 @@ MULTILIB_CHOST_TOOLS=(
/usr/bin/krb5-config
)
+PATCHES=(
+ "${FILESDIR}/heimdal_disable-check-iprop.patch"
+ "${FILESDIR}/heimdal_tinfo.patch"
+ "${FILESDIR}/heimdal_build-headers-before-use.patch"
+ "${FILESDIR}/heimdal_fix-db60.patch"
+ "${FILESDIR}/heimdal-7.8.0-CVE-2022-45142.patch"
+ "${FILESDIR}/heimdal-7.8.0-configure-clang16.patch"
+)
+
src_prepare() {
- eapply "${FILESDIR}/heimdal_disable-check-iprop.patch"
- eapply "${FILESDIR}/heimdal_tinfo.patch"
- eapply_user
+ default
eautoreconf
}
@@ -88,16 +92,17 @@ multilib_src_configure() {
--with-sqlite3="${EPREFIX}"/usr
--libexecdir="${EPREFIX}"/usr/sbin
--enable-pthread-support
+ --enable-kx509
+ --enable-pk-init
+ --with-ipv6
+ --without-openssl
$(use_enable afs afs-support)
+ $(use_enable gdbm ndbm-db)
+ $(use_enable lmdb mdb-db)
$(use_enable otp)
- $(use_enable pkinit kx509)
- $(use_enable pkinit pk-init)
$(use_enable static-libs static)
$(multilib_native_use_with caps capng)
$(multilib_native_use_with hdb-ldap openldap "${EPREFIX}"/usr)
- $(use_with ipv6)
- $(use_with ssl openssl "${EPREFIX}"/usr)
- $(multilib_native_use_with X x)
)
if use berkdb; then
myeconfargs+=(
@@ -110,18 +115,18 @@ multilib_src_configure() {
)
fi
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+ CONFIG_SHELL="${BROOT}"/bin/bash ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_compile() {
if multilib_is_native_abi; then
- emake -j1
+ emake
else
- emake -C include -j1
- emake -C lib -j1
- emake -C kdc -j1
- emake -C tools -j1
- emake -C tests/plugin -j1
+ emake -C include
+ emake -C lib
+ emake -C kdc
+ emake -C tools
+ emake -C tests/plugin
fi
}
@@ -145,8 +150,8 @@ multilib_src_install_all() {
dodoc ChangeLog* README NEWS TODO
# client rename
- mv "${ED%/}"/usr/share/man/man1/{,k}su.1
- mv "${ED%/}"/usr/bin/{,k}su
+ mv "${ED}"/usr/share/man/man1/{,k}su.1
+ mv "${ED}"/usr/bin/{,k}su
newinitd "${FILESDIR}"/heimdal-kdc.initd-r2 heimdal-kdc
newinitd "${FILESDIR}"/heimdal-kadmind.initd-r2 heimdal-kadmind
@@ -166,7 +171,9 @@ multilib_src_install_all() {
doins "${S}/lib/hdb/hdb.schema"
fi
- find "${ED}" -name "*.la" -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
# default database dir
keepdir /var/heimdal
diff --git a/app-crypt/heimdal/metadata.xml b/app-crypt/heimdal/metadata.xml
index c31b6673e508..9ac91f9e56c9 100644
--- a/app-crypt/heimdal/metadata.xml
+++ b/app-crypt/heimdal/metadata.xml
@@ -1,23 +1,19 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>kerberos@gentoo.org</email>
<name>Kerberos</name>
</maintainer>
- <longdescription>Kerberos 5 implementation from KTH</longdescription>
<use>
<flag name="otp">
Adds support for one-time passwords
</flag>
- <flag name="pkinit">
- Adds support for PKINIT for the initial ticket
- </flag>
<flag name="hdb-ldap">
Adds support for LDAP as a database backend
</flag>
<flag name="lmdb">
- Add support for using dev-db/lmdb for lookup tables
+ Add support for using <pkg>dev-db/lmdb</pkg> for lookup tables
</flag>
</use>
<upstream>