summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild')
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild
new file mode 100644
index 000000000000..70bd50516567
--- /dev/null
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Supporting tools for IMA and EVM"
+HOMEPAGE="http://linux-ima.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-ima/${P}.tar.gz"
+
+DEPEND="sys-apps/keyutils"
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i 's:pkglib_PROGRAMS:pkglibexec_PROGRAMS:g' tests/Makefile.am
+ sed -i 's:pkglib_SCRIPTS:pkglibexec_SCRIPTS:g' tests/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}