summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libmd')
-rw-r--r--app-crypt/libmd/Manifest4
-rw-r--r--app-crypt/libmd/files/libmd-1.0.4-fix-version-script-linker-support-detection.patch38
-rw-r--r--app-crypt/libmd/libmd-1.0.0-r1.ebuild26
-rw-r--r--app-crypt/libmd/libmd-1.0.0.ebuild13
-rw-r--r--app-crypt/libmd/libmd-1.0.1.ebuild26
-rw-r--r--app-crypt/libmd/libmd-1.0.4.ebuild34
-rw-r--r--app-crypt/libmd/libmd-1.1.0.ebuild23
-rw-r--r--app-crypt/libmd/libmd-99999.ebuild29
-rw-r--r--app-crypt/libmd/metadata.xml12
9 files changed, 105 insertions, 100 deletions
diff --git a/app-crypt/libmd/Manifest b/app-crypt/libmd/Manifest
index cbd59f348c45..b76f741df088 100644
--- a/app-crypt/libmd/Manifest
+++ b/app-crypt/libmd/Manifest
@@ -1,2 +1,2 @@
-DIST libmd-1.0.0.tar.xz 254852 BLAKE2B af0d3c645a18262965e708d678cb30c7ed168af8055885b08084fafd7299e9aaea95efb8437ffa756e43c5bb75fac99af067c6a560f3bb2b8b93ee889d5e664b SHA512 54c3cae1308f7686a1f642d25ae5d8cfb0fce2b98b33cf5e2891682893715c7de7e9700c70a6bd7e4ab4cf7f54c87643b259319e09e03f529b70d273477fc8be
-DIST libmd-1.0.1.tar.xz 257372 BLAKE2B e954ab6b1247952abcf6964d8d714c2a47a644e206a455db547a0159a97ebbc323cf1258a24c744cea3106f267f1a319a689fe545b672580f4e134d96cc7cb3d SHA512 6f343101f9ad8f927d862e6bae948d35ba596ecfd375c255fefb86efc621cf6e9de3597770ad66e0a48e8f4ea018df78debb571ea6746a7457d8900fec87069b
+DIST libmd-1.0.4.tar.xz 264472 BLAKE2B ddc2da74635f5cc009c66a58ae82b83e6e0930e18af8a6b0ecec7cbf378246707b493a99fb97d3491d0d626a0d5ef068baea6a3ba2ec311c5a1516ba5b4e2fd5 SHA512 731553ecc5e0e1eb228cced8fccd531fe31fb5c7627ca30013d287e1aeb8222959cf7498fbb7414bbabb967b25d4e8b0edd54fc47f6ccf55fc91087db0725ce3
+DIST libmd-1.1.0.tar.xz 271228 BLAKE2B a4dc72be4a46609d41453b19ba3110043e74fd0810d59f872e11151dbe87b0bdab203ef72c9d19255db32493b229bc0d33549e787979a42db08c838a810e1cdc SHA512 5d0da3337038e474fae7377bbc646d17214e72dc848a7aadc157f49333ce7b5ac1456e45d13674bd410ea08477c6115fc4282fed6c8e6a0bf63537a418c0df96
diff --git a/app-crypt/libmd/files/libmd-1.0.4-fix-version-script-linker-support-detection.patch b/app-crypt/libmd/files/libmd-1.0.4-fix-version-script-linker-support-detection.patch
new file mode 100644
index 000000000000..bcee3a06611f
--- /dev/null
+++ b/app-crypt/libmd/files/libmd-1.0.4-fix-version-script-linker-support-detection.patch
@@ -0,0 +1,38 @@
+From e408786075b9540f76783f5c3ce87f6d1ece13cf Mon Sep 17 00:00:00 2001
+From: Guillem Jover <guillem@hadrons.org>
+Date: Sun, 12 Feb 2023 23:55:09 +0100
+Subject: [PATCH] build: Fix version script linker support detection
+
+When the linker uses --no-undefined-version either specified by the user
+or as the default behavior (such as with newer clang >= 16 releases), a missing symbol definition will cause a linker error if that symbol is
+listed in the version script.
+
+
+Bug: https://bugs.gentoo.org/894010
+Upstream issue: https://gitlab.freedesktop.org/libbsd/libmd/-/issues/1
+Upstream commit: https://gitlab.freedesktop.org/libbsd/libmd/-/commit/e408786075b9540f76783f5c3ce87f6d1ece13cf
+
+---
+ m4/libmd-linker.m4 | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/m4/libmd-linker.m4 b/m4/libmd-linker.m4
+index 7d1236a..3d6edcd 100644
+--- a/m4/libmd-linker.m4
++++ b/m4/libmd-linker.m4
+@@ -8,7 +8,11 @@ AC_DEFUN([LIBMD_LINKER_VERSION_SCRIPT], [
+ save_LDFLAGS=$LDFLAGS
+ LDFLAGS="$LDFLAGS -Wl,--version-script=conftest.map"
+ AC_LINK_IFELSE([
+- AC_LANG_PROGRAM([], [])
++ AC_LANG_PROGRAM([[
++extern int symbol(void);
++int symbol(void) { return 0; }
++]], [[
++]])
+ ], [
+ libmd_cv_version_script=yes
+ ], [
+--
+GitLab
+
diff --git a/app-crypt/libmd/libmd-1.0.0-r1.ebuild b/app-crypt/libmd/libmd-1.0.0-r1.ebuild
deleted file mode 100644
index d27a6c00ff63..000000000000
--- a/app-crypt/libmd/libmd-1.0.0-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit multilib
-
-DESCRIPTION="Message Digest functions from BSD systems"
-HOMEPAGE="https://www.hadrons.org/software/libmd/"
-SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
-
-LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static-libs"
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- if ! use static-libs; then
- rm "${D}"/usr/$(get_libdir)/libmd.la || die
- fi
-}
diff --git a/app-crypt/libmd/libmd-1.0.0.ebuild b/app-crypt/libmd/libmd-1.0.0.ebuild
deleted file mode 100644
index aed0b60e74e8..000000000000
--- a/app-crypt/libmd/libmd-1.0.0.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Message Digest functions from BSD systems"
-HOMEPAGE="https://www.hadrons.org/software/libmd/"
-SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
-
-LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
diff --git a/app-crypt/libmd/libmd-1.0.1.ebuild b/app-crypt/libmd/libmd-1.0.1.ebuild
deleted file mode 100644
index b3776d95ea2a..000000000000
--- a/app-crypt/libmd/libmd-1.0.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit multilib
-
-DESCRIPTION="Message Digest functions from BSD systems"
-HOMEPAGE="https://www.hadrons.org/software/libmd/"
-SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
-
-LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- if ! use static-libs; then
- rm "${ED}"/usr/$(get_libdir)/libmd.la || die
- fi
-}
diff --git a/app-crypt/libmd/libmd-1.0.4.ebuild b/app-crypt/libmd/libmd-1.0.4.ebuild
new file mode 100644
index 000000000000..1cae95fb395f
--- /dev/null
+++ b/app-crypt/libmd/libmd-1.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-version-script-linker-support-detection.patch"
+)
+
+src_prepare() {
+ default
+
+ # Drop on next release, only needed for lld patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/app-crypt/libmd/libmd-1.1.0.ebuild b/app-crypt/libmd/libmd-1.1.0.ebuild
new file mode 100644
index 000000000000..3d3edc297844
--- /dev/null
+++ b/app-crypt/libmd/libmd-1.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/app-crypt/libmd/libmd-99999.ebuild b/app-crypt/libmd/libmd-99999.ebuild
deleted file mode 100644
index c0ad8d6375b2..000000000000
--- a/app-crypt/libmd/libmd-99999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools git-r3
-
-DESCRIPTION="Message Digest functions from BSD systems"
-HOMEPAGE="https://www.hadrons.org/software/libmd/"
-EGIT_REPO_URI="https://git.hadrons.org/git/libmd.git"
-
-LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
-SLOT="0"
-KEYWORDS=""
-IUSE="static-libs"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/app-crypt/libmd/metadata.xml b/app-crypt/libmd/metadata.xml
index 8dc9c113fc65..0c7ca90940c4 100644
--- a/app-crypt/libmd/metadata.xml
+++ b/app-crypt/libmd/metadata.xml
@@ -1,7 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type='project'>
-<email>deb-tools@gentoo.org</email>
-</maintainer>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">libbsd/libmd</remote-id>
+ </upstream>
</pkgmetadata>