summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/mcrypt/mcrypt-2.6.8-r2.ebuild')
-rw-r--r--app-crypt/mcrypt/mcrypt-2.6.8-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/mcrypt/mcrypt-2.6.8-r2.ebuild b/app-crypt/mcrypt/mcrypt-2.6.8-r2.ebuild
new file mode 100644
index 000000000000..b90de3e9c3d8
--- /dev/null
+++ b/app-crypt/mcrypt/mcrypt-2.6.8-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="replacement of the old unix crypt(1)"
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~x86-macos"
+IUSE="nls"
+
+DEPEND=">=dev-libs/libmcrypt-2.5.8
+ >=app-crypt/mhash-0.9.9
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.6.7-qa.patch"
+ epatch "${FILESDIR}/${P}-stdlib.h.patch"
+ epatch "${FILESDIR}/${P}-segv.patch"
+ epatch "${FILESDIR}/${P}-sprintf.patch"
+ epatch "${FILESDIR}/${P}-format-string.patch"
+ epatch "${FILESDIR}/${P}-overflow.patch"
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README THANKS TODO
+}