summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/md5deep')
-rw-r--r--app-crypt/md5deep/files/md5deep-4.4-pointer-comparison.patch11
-rw-r--r--app-crypt/md5deep/md5deep-4.4.ebuild22
-rw-r--r--app-crypt/md5deep/metadata.xml7
3 files changed, 25 insertions, 15 deletions
diff --git a/app-crypt/md5deep/files/md5deep-4.4-pointer-comparison.patch b/app-crypt/md5deep/files/md5deep-4.4-pointer-comparison.patch
new file mode 100644
index 000000000000..dbd6e74519d6
--- /dev/null
+++ b/app-crypt/md5deep/files/md5deep-4.4-pointer-comparison.patch
@@ -0,0 +1,11 @@
+--- a/src/hash.cpp
++++ b/src/hash.cpp
+@@ -279,7 +279,7 @@
+ MAP_FILE|
+ #endif
+ MAP_SHARED,fd,0);
+- if(fdht->base>0){
++ if(fdht->base){
+ /* mmap is successful, so set the bounds.
+ * if it is not successful, we default to reading the fd
+ */
diff --git a/app-crypt/md5deep/md5deep-4.4.ebuild b/app-crypt/md5deep/md5deep-4.4.ebuild
index a7637a6fdfde..dd3d03223bfe 100644
--- a/app-crypt/md5deep/md5deep-4.4.ebuild
+++ b/app-crypt/md5deep/md5deep-4.4.ebuild
@@ -1,25 +1,27 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="Expanded md5sum program with recursive and comparison options"
-HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="https://github.com/jessek/hashdeep/archive/release-${PV}.tar.gz
- -> ${P}.tar.gz"
+HOMEPAGE="https://md5deep.sourceforge.net/"
+SRC_URI="https://github.com/jessek/hashdeep/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/hashdeep-release-${PV}"
LICENSE="public-domain GPL-2"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~mips ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-S=${WORKDIR}/hashdeep-release-${PV}
-
-DOCS=( AUTHORS ChangeLog FILEFORMAT NEWS README.md TODO )
+PATCHES=( "${FILESDIR}"/${PN}-4.4-pointer-comparison.patch )
src_prepare() {
- eapply_user
+ default
eautoreconf
}
+
+src_install() {
+ default
+ dodoc FILEFORMAT
+}
diff --git a/app-crypt/md5deep/metadata.xml b/app-crypt/md5deep/metadata.xml
index d162c6244ad1..a6f43809217d 100644
--- a/app-crypt/md5deep/metadata.xml
+++ b/app-crypt/md5deep/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>blueness@gentoo.org</email>
- <name>Anthony G. Basile</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="github">jessek/hashdeep</remote-id>
<remote-id type="sourceforge">md5deep</remote-id>