summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/monkeysphere/files')
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.36_default_shell.patch12
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.36_hd_od.patch14
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.36_non_default_port.patch14
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.36_openpgp2ssh_sanity_check.patch34
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.36_tests_gnupg2.patch50
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.36_userid_empty_line.patch12
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.37_default_shell.patch12
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.37_hd_od.patch14
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.38-asprintf.patch45
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.38-revert-executable-patch.patch98
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.38-syssharedir-whitespace.patch53
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.39-make-tests-work-with-gnupg-2.1.15.patch45
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.44-install-uncompressed-man-pages.patch28
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.44-no-werror.patch12
14 files changed, 40 insertions, 403 deletions
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.36_default_shell.patch b/app-crypt/monkeysphere/files/monkeysphere-0.36_default_shell.patch
deleted file mode 100644
index f979114181d1..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.36_default_shell.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r d0c02fe6a949 src/share/common
---- a/src/share/common Sun Oct 06 19:21:18 2013 +0200
-+++ b/src/share/common Sun Oct 06 19:21:49 2013 +0200
-@@ -108,7 +108,7 @@
- # if root, su command as monkeysphere user
- 'root')
- # requote arguments using bash builtin feature (see "help printf"):
-- su "$MONKEYSPHERE_USER" -c "$(printf "%q " "$@")"
-+ su -s /bin/bash "$MONKEYSPHERE_USER" -c "$(printf "%q " "$@")"
- ;;
-
- # otherwise, fail
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.36_hd_od.patch b/app-crypt/monkeysphere/files/monkeysphere-0.36_hd_od.patch
deleted file mode 100644
index 7cdaa74b5735..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.36_hd_od.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -r 6150774ec7f4 tests/keytrans
---- a/tests/keytrans Sun Feb 16 20:11:02 2014 +0100
-+++ b/tests/keytrans Sun Feb 16 20:11:40 2014 +0100
-@@ -104,8 +104,8 @@
- <(gpg --list-packets < "$TEMPDIR"/converted.secret.key)
-
- diff -u \
-- <(hd "$TEMPDIR"/secret.key) \
-- <(hd "$TEMPDIR"/converted.secret.key)
-+ <(od -xc "$TEMPDIR"/secret.key) \
-+ <(od -xc "$TEMPDIR"/converted.secret.key)
-
- KEYFPR=$(gpg --fingerprint --with-colons --list-keys | grep ^fpr | cut -f10 -d:)
- KEYID=$(printf "%s" "$KEYFPR" | cut -b25-40)
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.36_non_default_port.patch b/app-crypt/monkeysphere/files/monkeysphere-0.36_non_default_port.patch
deleted file mode 100644
index f14550280fcf..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.36_non_default_port.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -r 5f7ee764ec1f src/share/common
---- a/src/share/common Mon Oct 07 19:22:36 2013 +0200
-+++ b/src/share/common Mon Oct 07 19:22:58 2013 +0200
-@@ -863,6 +863,10 @@
- ;;
- ('known_hosts')
- host=${userID#ssh://}
-+ if [[ "${host}" == *:* ]]; then
-+ IFS=':' read -a ARR <<< "${host}"
-+ host="[${ARR[0]}]:${ARR[1]}"
-+ fi
- remove_line "$keyFile" "$host" "$sshKey"
- ;;
- esac
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.36_openpgp2ssh_sanity_check.patch b/app-crypt/monkeysphere/files/monkeysphere-0.36_openpgp2ssh_sanity_check.patch
deleted file mode 100644
index aec90eb07661..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.36_openpgp2ssh_sanity_check.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git a/src/monkeysphere-authentication b/src/monkeysphere-authentication
-index edc7995..2711ff2 100755
---- a/src/monkeysphere-authentication
-+++ b/src/monkeysphere-authentication
-@@ -84,6 +84,13 @@ gpg_sphere() {
- su_monkeysphere_user gpg --fixed-list-mode --no-greeting --quiet --no-tty "$@"
- }
-
-+check_openpgp2ssh_sanity() {
-+ if [[ `su_monkeysphere_user openpgp2ssh ABC &>/dev/null || echo $?` != "255" ]]; then
-+ echo "openpgp2ssh command gives unexpected return code. This can lead to a scenario where no authorized keys are populated, even though they are otherwise valid. Aborting!"
-+ exit 1
-+ fi;
-+}
-+
- # output to stdout the core fingerprint from the gpg core secret
- # keyring
- core_fingerprint() {
-@@ -163,6 +170,7 @@ case $COMMAND in
- 'update-users'|'update-user'|'update'|'u')
- source "${MASHAREDIR}/setup"
- setup
-+ check_openpgp2ssh_sanity
- source "${MASHAREDIR}/update_users"
- OUTPUT_STDOUT= update_users "$@"
- ;;
-@@ -171,6 +179,7 @@ case $COMMAND in
- (( $# > 0 )) || failure "Must specify user."
- source "${MASHAREDIR}/setup"
- setup
-+ check_openpgp2ssh_sanity
- source "${MASHAREDIR}/update_users"
- OUTPUT_STDOUT=true update_users "$1"
- ;;
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.36_tests_gnupg2.patch b/app-crypt/monkeysphere/files/monkeysphere-0.36_tests_gnupg2.patch
deleted file mode 100644
index 712734459054..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.36_tests_gnupg2.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff -r c13f4b11061e tests/keytrans
---- a/tests/keytrans Sun Feb 16 19:24:08 2014 +0100
-+++ b/tests/keytrans Sun Feb 16 19:27:42 2014 +0100
-@@ -131,9 +131,9 @@
- cat >"$TEMPDIR"/expectedout <<EOF
- pub:u:1024:1:$KEYID:$timestamp:::u:::scSC:
- uid:u::::$timestamp::E90EC72E68C6C2A0751DADC70F54F60D27B88C3D::monkeymonkey:
--sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:
-+sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8:
- uid:u::::$timestamp::8200BD0425CC70C7D698DF3FE412044EAAB83F94::testtest:
--sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:
-+sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8:
- EOF
-
- diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -v ^tru)
-@@ -159,10 +159,10 @@
- cat >"$TEMPDIR"/expectedout <<EOF
- pub:u:1024:1:$KEYID:$timestamp:::u:::scSC:
- uid:u::::$timestamp::E90EC72E68C6C2A0751DADC70F54F60D27B88C3D::monkeymonkey:
--sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:
-+sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8:
- uid:r::::::8200BD0425CC70C7D698DF3FE412044EAAB83F94::testtest:
--sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:
--rev:!::1:$KEYID:$revtime::::monkeymonkey:30x:
-+sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8:
-+rev:!::1:$KEYID:$revtime::::monkeymonkey:30x:::::8:
- EOF
-
-
-@@ -190,15 +190,15 @@
- cat >"$TEMPDIR"/expectedout <<EOF
- pub:u:1024:1:$KEYID:$timestamp:::u:::scSC:
- uid:u::::$timestamp::E90EC72E68C6C2A0751DADC70F54F60D27B88C3D::monkeymonkey:
--sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:
-+sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8:
- uid:r::::::8200BD0425CC70C7D698DF3FE412044EAAB83F94::testtest:
--sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:
--rev:!::1:$KEYID:$revtime::::monkeymonkey:30x:
-+sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8:
-+rev:!::1:$KEYID:$revtime::::monkeymonkey:30x:::::8:
- uid:u::::$timestamp::EDDC32D783E7F4C7B6982D9AE5DC4A61000648BA::baz:
--sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:
-+sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8:
- pub:-:1024:1:$NEWKEYID:$(($timestamp + 1)):::-:::caCA:
- uid:-::::$(($timestamp + 1))::A0D708F51CC257DEFC01AEDE1E0A5F329DFD8F16::fubar:
--sig:!::1:$NEWKEYID:$(($timestamp + 1))::::fubar:13x:
-+sig:!::1:$NEWKEYID:$(($timestamp + 1))::::fubar:13x:::::8:
- EOF
-
- echo "test: diff expected gpg list output"
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.36_userid_empty_line.patch b/app-crypt/monkeysphere/files/monkeysphere-0.36_userid_empty_line.patch
deleted file mode 100644
index 70c7cffe7dc4..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.36_userid_empty_line.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r 2315bb7781c6 src/share/common
---- a/src/share/common Thu Oct 10 19:25:10 2013 +0200
-+++ b/src/share/common Thu Oct 10 19:25:50 2013 +0200
-@@ -917,7 +917,7 @@
- IFS=$'\n'
- while read line ; do
- case "$line" in
-- ("#"*)
-+ ("#"*|"")
- continue
- ;;
- (" "*|$'\t'*)
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.37_default_shell.patch b/app-crypt/monkeysphere/files/monkeysphere-0.37_default_shell.patch
deleted file mode 100644
index f979114181d1..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.37_default_shell.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r d0c02fe6a949 src/share/common
---- a/src/share/common Sun Oct 06 19:21:18 2013 +0200
-+++ b/src/share/common Sun Oct 06 19:21:49 2013 +0200
-@@ -108,7 +108,7 @@
- # if root, su command as monkeysphere user
- 'root')
- # requote arguments using bash builtin feature (see "help printf"):
-- su "$MONKEYSPHERE_USER" -c "$(printf "%q " "$@")"
-+ su -s /bin/bash "$MONKEYSPHERE_USER" -c "$(printf "%q " "$@")"
- ;;
-
- # otherwise, fail
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.37_hd_od.patch b/app-crypt/monkeysphere/files/monkeysphere-0.37_hd_od.patch
deleted file mode 100644
index 7cdaa74b5735..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.37_hd_od.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -r 6150774ec7f4 tests/keytrans
---- a/tests/keytrans Sun Feb 16 20:11:02 2014 +0100
-+++ b/tests/keytrans Sun Feb 16 20:11:40 2014 +0100
-@@ -104,8 +104,8 @@
- <(gpg --list-packets < "$TEMPDIR"/converted.secret.key)
-
- diff -u \
-- <(hd "$TEMPDIR"/secret.key) \
-- <(hd "$TEMPDIR"/converted.secret.key)
-+ <(od -xc "$TEMPDIR"/secret.key) \
-+ <(od -xc "$TEMPDIR"/converted.secret.key)
-
- KEYFPR=$(gpg --fingerprint --with-colons --list-keys | grep ^fpr | cut -f10 -d:)
- KEYID=$(printf "%s" "$KEYFPR" | cut -b25-40)
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.38-asprintf.patch b/app-crypt/monkeysphere/files/monkeysphere-0.38-asprintf.patch
deleted file mode 100644
index dbf9d5f590ca..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.38-asprintf.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From b756fd2e58ab013b5c9bfc2658ed9ad48868067c Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Sun, 7 Aug 2016 18:24:47 -0400
-Subject: [PATCH] avoid warning about unused asprintf return value
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-some versions of gcc produce this warning, which is treated as an
-error due to our conservative defaults in Makefile:
-
-src/agent-transfer/main.c: In function ‘main’:
-src/agent-transfer/main.c:676:5: error: ignoring return value of ‘asprintf’, declared with attribute warn_unused_result [-Werror=unused-result]
- asprintf (&alt_comment, "GnuPG keygrip %s", args.keygrip);
- ^
-cc1: all warnings being treated as errors
-
-this patch avoids the warning.
----
- src/agent-transfer/main.c | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/src/agent-transfer/main.c b/src/agent-transfer/main.c
-index 406aaa3..3038f5c 100644
---- a/src/agent-transfer/main.c
-+++ b/src/agent-transfer/main.c
-@@ -672,8 +672,13 @@ int main (int argc, const char* argv[]) {
- return 1;
- }
-
-- if (!args.comment)
-- asprintf (&alt_comment, "GnuPG keygrip %s", args.keygrip);
-+ if (!args.comment) {
-+ err = asprintf (&alt_comment, "GnuPG keygrip %s", args.keygrip);
-+ if (err < 0) {
-+ fprintf (stderr, "failed to generate key comment\n");
-+ return 1;
-+ }
-+ }
-
- err = send_to_ssh_agent (&e, ssh_sock_fd, args.seconds, args.confirm,
- args.comment ? args.comment : alt_comment);
---
-2.7.3
-
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.38-revert-executable-patch.patch b/app-crypt/monkeysphere/files/monkeysphere-0.38-revert-executable-patch.patch
deleted file mode 100644
index 4d98c0a7cf5b..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.38-revert-executable-patch.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From c75c7553a88e387013e2b4310f4c4956adfd8a98 Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Mon, 8 Aug 2016 20:45:07 -0400
-Subject: [PATCH 1/2] avoid treating src/share/common as an executable
-
-having src/share/common treated as an executable (commit
-ed10318d3760b56e57d5e1bef04ab57761ab8bd1) was actually a terrible
-idea.
-
-In addition to causing "monkeysphere version" to print the version
-number twice, it meant that any invocation of a monkeysphere command
-that sourced src/share/common and had a first argument that happened
-to be a function name would accidentally invoke that function.
-
-This commit reverts that idea.
----
- Makefile | 2 +-
- src/share/common | 5 -----
- src/share/ma/add_certifier | 2 +-
- src/share/ma/update_users | 2 +-
- src/share/mh/add_revoker | 2 +-
- 5 files changed, 4 insertions(+), 9 deletions(-)
- mode change 100755 => 100644 src/share/common
-
-diff --git a/Makefile b/Makefile
-index 608a317..768564a 100755
---- a/Makefile
-+++ b/Makefile
-@@ -55,7 +55,7 @@ install: all installman
- install src/monkeysphere-authentication $(DESTDIR)$(PREFIX)/sbin
- sed -i 's:__SYSSHAREDIR_PREFIX__:$(PREFIX):' $(DESTDIR)$(PREFIX)/sbin/monkeysphere-authentication
- install src/monkeysphere-authentication-keys-for-user $(DESTDIR)$(PREFIX)/share/monkeysphere
-- install -m 0755 src/share/common $(DESTDIR)$(PREFIX)/share/monkeysphere
-+ install -m 0644 src/share/common $(DESTDIR)$(PREFIX)/share/monkeysphere
- install -m 0644 src/share/defaultenv $(DESTDIR)$(PREFIX)/share/monkeysphere
- sed -i 's:__SYSCONFDIR_PREFIX__:$(ETCPREFIX):' $(DESTDIR)$(PREFIX)/share/monkeysphere/defaultenv
- sed -i 's:__SYSDATADIR_PREFIX__:$(LOCALSTATEDIR):' $(DESTDIR)$(PREFIX)/share/monkeysphere/defaultenv
-diff --git a/src/share/common b/src/share/common
-old mode 100755
-new mode 100644
-index 66181a3..b10a040
---- a/src/share/common
-+++ b/src/share/common
-@@ -1,4 +1,3 @@
--#!/usr/bin/env bash
- # -*-shell-script-*-
- # This should be sourced by bash (though we welcome changes to make it POSIX sh compliant)
-
-@@ -1022,7 +1021,3 @@ report_cruft() {
- printf "The directories above are backups left over from a monkeysphere transition.\nThey may contain copies of sensitive data (host keys, certifier lists), but\nthey are no longer needed by monkeysphere.\nYou may remove them at any time.\n\n" | log info
- fi
- }
--
--if [ -n "$1" ] && [ "$(type -t "$1" || true)" = "function" ]; then
-- "$@"
--fi
-diff --git a/src/share/ma/add_certifier b/src/share/ma/add_certifier
-index 1d450e7..5416aa9 100644
---- a/src/share/ma/add_certifier
-+++ b/src/share/ma/add_certifier
-@@ -101,7 +101,7 @@ if [ -f "$keyID" -o "$keyID" = '-' ] ; then
- # check the key is ok as monkeysphere user before loading
- log debug "checking keys in file..."
- fingerprint=$(su_monkeysphere_user \
-- "${SYSSHAREDIR}/common" list_primary_fingerprints < "$keyID")
-+ bash -c ". ${SYSSHAREDIR}/common && list_primary_fingerprints" < "$keyID")
-
- if [ $(printf "%s" "$fingerprint" | egrep -c '^[A-F0-9]{40}$') -ne 1 ] ; then
- failure "There was not exactly one gpg key in the file."
-diff --git a/src/share/ma/update_users b/src/share/ma/update_users
-index d23c125..4f83e0c 100644
---- a/src/share/ma/update_users
-+++ b/src/share/ma/update_users
-@@ -79,7 +79,7 @@ for uname in $unames ; do
-
- # process authorized_user_ids file, as monkeysphere user
- su_monkeysphere_user \
-- /usr/bin/env "STRICT_MODES=$STRICT_MODES" "${SYSSHAREDIR}/common" process_authorized_user_ids - \
-+ /usr/bin/env "STRICT_MODES=$STRICT_MODES" bash -c ". ${SYSSHAREDIR}/common && process_authorized_user_ids -" \
- < "$authorizedUserIDs" \
- > "$tmpAuthorizedKeys"
-
-diff --git a/src/share/mh/add_revoker b/src/share/mh/add_revoker
-index 28b11ac..e00ac4e 100644
---- a/src/share/mh/add_revoker
-+++ b/src/share/mh/add_revoker
-@@ -52,7 +52,7 @@ if [ -f "$revokerKeyID" -o "$revokerKeyID" = '-' ] ; then
- # check the key is ok as monkeysphere user before loading
- log debug "checking keys in file..."
- fingerprint=$(su_monkeysphere_user \
-- "${SYSSHAREDIR}/common" list_primary_fingerprints < "$revokerKeyID")
-+ bash -c ". ${SYSSHAREDIR}/common && list_primary_fingerprints" < "$revokerKeyID")
-
- if [ $(printf "%s" "$fingerprint" | egrep -c '^[A-F0-9]{40}$') -ne 1 ] ; then
- failure "There was not exactly one gpg key in the file."
---
-2.7.3
-
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.38-syssharedir-whitespace.patch b/app-crypt/monkeysphere/files/monkeysphere-0.38-syssharedir-whitespace.patch
deleted file mode 100644
index 65d3ba6a95aa..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.38-syssharedir-whitespace.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 0e339de4772b6de1849dc55790821c3dd5943be3 Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Tue, 9 Aug 2016 09:39:45 -0400
-Subject: [PATCH 2/2] ensure that this works even if SYSSHAREDIR has whitespace
-
----
- src/share/ma/add_certifier | 2 +-
- src/share/ma/update_users | 2 +-
- src/share/mh/add_revoker | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/share/ma/add_certifier b/src/share/ma/add_certifier
-index 5416aa9..9488806 100644
---- a/src/share/ma/add_certifier
-+++ b/src/share/ma/add_certifier
-@@ -101,7 +101,7 @@ if [ -f "$keyID" -o "$keyID" = '-' ] ; then
- # check the key is ok as monkeysphere user before loading
- log debug "checking keys in file..."
- fingerprint=$(su_monkeysphere_user \
-- bash -c ". ${SYSSHAREDIR}/common && list_primary_fingerprints" < "$keyID")
-+ bash -c "$(printf ". %q && list_primary_fingerprints" "${SYSSHAREDIR}/common")" < "$keyID")
-
- if [ $(printf "%s" "$fingerprint" | egrep -c '^[A-F0-9]{40}$') -ne 1 ] ; then
- failure "There was not exactly one gpg key in the file."
-diff --git a/src/share/ma/update_users b/src/share/ma/update_users
-index 4f83e0c..a0ec21b 100644
---- a/src/share/ma/update_users
-+++ b/src/share/ma/update_users
-@@ -79,7 +79,7 @@ for uname in $unames ; do
-
- # process authorized_user_ids file, as monkeysphere user
- su_monkeysphere_user \
-- /usr/bin/env "STRICT_MODES=$STRICT_MODES" bash -c ". ${SYSSHAREDIR}/common && process_authorized_user_ids -" \
-+ /usr/bin/env "STRICT_MODES=$STRICT_MODES" bash -c "$(printf ". %q && process_authorized_user_ids -" "${SYSSHAREDIR}/common")"\
- < "$authorizedUserIDs" \
- > "$tmpAuthorizedKeys"
-
-diff --git a/src/share/mh/add_revoker b/src/share/mh/add_revoker
-index e00ac4e..de08961 100644
---- a/src/share/mh/add_revoker
-+++ b/src/share/mh/add_revoker
-@@ -52,7 +52,7 @@ if [ -f "$revokerKeyID" -o "$revokerKeyID" = '-' ] ; then
- # check the key is ok as monkeysphere user before loading
- log debug "checking keys in file..."
- fingerprint=$(su_monkeysphere_user \
-- bash -c ". ${SYSSHAREDIR}/common && list_primary_fingerprints" < "$revokerKeyID")
-+ bash -c "$(printf ". %q && list_primary_fingerprints" "${SYSSHAREDIR}/common")" < "$revokerKeyID")
-
- if [ $(printf "%s" "$fingerprint" | egrep -c '^[A-F0-9]{40}$') -ne 1 ] ; then
- failure "There was not exactly one gpg key in the file."
---
-2.7.3
-
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.39-make-tests-work-with-gnupg-2.1.15.patch b/app-crypt/monkeysphere/files/monkeysphere-0.39-make-tests-work-with-gnupg-2.1.15.patch
deleted file mode 100644
index 776e633b3d73..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.39-make-tests-work-with-gnupg-2.1.15.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From b1dd8fb1b84c6eea25523c3ea746852b3dce6034 Mon Sep 17 00:00:00 2001
-From: Valo <valo@autoproduzioni.net>
-Date: Wed, 31 Aug 2016 14:00:05 -0400
-Subject: [PATCH] Make tests pass with GnuPG 2.1.15
-
-2.1.15 appears to always emit the fingerprint lines in these cases,
-while 2.1.14 did not.
----
- tests/keytrans | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/tests/keytrans b/tests/keytrans
-index 3076e3f..5c7d2c8 100755
---- a/tests/keytrans
-+++ b/tests/keytrans
-@@ -140,7 +140,7 @@ uid:u::::$timestamp::8200BD0425CC70C7D698DF3FE412044EAAB83F94::testtest
- sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8
- EOF
-
--diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -v ^tru | sed 's/:*$//')
-+diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -vE '^(tru|fpr):' | sed 's/:*$//')
-
- echo "##################################################"
- echo "### sleeping to avoid test suite breakage on fast"
-@@ -170,7 +170,7 @@ rev:!::1:$KEYID:$revtime::::monkeymonkey:30x:::::8
- EOF
-
-
--diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -v ^tru | sed 's/:*$//')
-+diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -vE '^(tru|fpr):' | sed 's/:*$//')
-
-
- echo "##################################################"
-@@ -206,7 +206,7 @@ sig:!::1:$NEWKEYID:$(($timestamp + 1))::::fubar:13x:::::8
- EOF
-
- echo "test: diff expected gpg list output"
--diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -v ^tru | sed 's/:*$//')
-+diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -vE '^(tru|fpr):' | sed 's/:*$//')
-
- sort >"$TEMPDIR"/expectedout <<EOF
- $KEYFPR
---
-2.7.3
-
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.44-install-uncompressed-man-pages.patch b/app-crypt/monkeysphere/files/monkeysphere-0.44-install-uncompressed-man-pages.patch
new file mode 100644
index 000000000000..c26f3d4ea90a
--- /dev/null
+++ b/app-crypt/monkeysphere/files/monkeysphere-0.44-install-uncompressed-man-pages.patch
@@ -0,0 +1,28 @@
+--- a/Makefile
++++ b/Makefile
+@@ -27,7 +27,7 @@ src/transitions/*)
+
+ REPLACED_COMPRESSED_MANPAGES = $(addsuffix .gz,$(addprefix replaced/,$(wildcard man/*/*)))
+
+-all: src/agent-transfer/agent-transfer $(addprefix replaced/,$(REPLACEMENTS)) $(REPLACED_COMPRESSED_MANPAGES)
++all: src/agent-transfer/agent-transfer $(addprefix replaced/,$(REPLACEMENTS)) $(addprefix replaced/,$(wildcard man/*/*))
+
+ src/agent-transfer/agent-transfer: src/agent-transfer/main.c src/agent-transfer/ssh-agent-proto.h
+ $(CC) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $< $(LIBS)
+@@ -91,13 +91,13 @@ install: all installman
+ install -m 0644 etc/monkeysphere-host.conf $(DESTDIR)$(ETCPREFIX)/etc/monkeysphere/monkeysphere-host.conf$(ETCSUFFIX)
+ install -m 0644 etc/monkeysphere-authentication.conf $(DESTDIR)$(ETCPREFIX)/etc/monkeysphere/monkeysphere-authentication.conf$(ETCSUFFIX)
+
+-installman: $(REPLACED_COMPRESSED_MANPAGES)
++installman:
+ mkdir -p $(DESTDIR)$(MANPREFIX)/man1 $(DESTDIR)$(MANPREFIX)/man7 $(DESTDIR)$(MANPREFIX)/man8
+ install replaced/man/man1/* $(DESTDIR)$(MANPREFIX)/man1
+ install replaced/man/man7/* $(DESTDIR)$(MANPREFIX)/man7
+ install replaced/man/man8/* $(DESTDIR)$(MANPREFIX)/man8
+- ln -sf openpgp2ssh.1.gz $(DESTDIR)$(MANPREFIX)/man1/openpgp2pem.1.gz
+- ln -sf openpgp2ssh.1.gz $(DESTDIR)$(MANPREFIX)/man1/openpgp2spki.1.gz
++ ln -sf openpgp2ssh.1 $(DESTDIR)$(MANPREFIX)/man1/openpgp2pem.1
++ ln -sf openpgp2ssh.1 $(DESTDIR)$(MANPREFIX)/man1/openpgp2spki.1
+
+ # this target depends on you having the monkeysphere-docs
+ # repo checked out as a peer of your monkeysphere repo.
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.44-no-werror.patch b/app-crypt/monkeysphere/files/monkeysphere-0.44-no-werror.patch
new file mode 100644
index 000000000000..671045d7c385
--- /dev/null
+++ b/app-crypt/monkeysphere/files/monkeysphere-0.44-no-werror.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/832365
+--- a/Makefile
++++ b/Makefile
+@@ -17,7 +17,7 @@ LOCALSTATEDIR ?= /var/lib
+
+ CFLAGS += $(shell libassuan-config --cflags)
+ CFLAGS += $(shell libgcrypt-config --cflags)
+-CFLAGS += --pedantic -Wall -Werror -std=c99
++CFLAGS += --pedantic -Wall -std=c99
+ LIBS += $(shell libassuan-config --libs)
+ LIBS += $(shell libgcrypt-config --libs)
+