summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/pius')
-rw-r--r--app-crypt/pius/Manifest1
-rw-r--r--app-crypt/pius/files/pius-3.0.0-Fix-typo-in-readme-135.patch25
-rw-r--r--app-crypt/pius/files/pius-3.0.0-Fix-typos-132.patch43
-rw-r--r--app-crypt/pius/files/pius-3.0.0-Minor-fixes-for-pius-report-137.patch78
-rw-r--r--app-crypt/pius/files/pius-3.0.0-pius-keyring-mgr-Fix-constants-134.patch58
-rw-r--r--app-crypt/pius/metadata.xml6
-rw-r--r--app-crypt/pius/pius-2.2.4.ebuild20
-rw-r--r--app-crypt/pius/pius-3.0.0-r1.ebuild (renamed from app-crypt/pius/pius-3.0.0.ebuild)11
8 files changed, 216 insertions, 26 deletions
diff --git a/app-crypt/pius/Manifest b/app-crypt/pius/Manifest
index 177e05820905..c3aa6c7e2f05 100644
--- a/app-crypt/pius/Manifest
+++ b/app-crypt/pius/Manifest
@@ -1,2 +1 @@
-DIST pius-2.2.4.tar.bz2 40578 BLAKE2B e7989631813658ff888c72b825269482ff33296abf0b9780ecb24df4628c499087a7591372ef96449b4899b1bcd730b0c75411bcd3c8839c57d3d4b5de374862 SHA512 3a178d30d98d0ed7ddf6819578a54ccfb9719f77c1f6385e3b254e28cd890817f328685c02cc464d4d592961c28ba314ca3175056b412dcdb301b851d874eb60
DIST pius-3.0.0.tar.bz2 46643 BLAKE2B 18abe6a93bd719adf50fa4bcbf5128845d732b598d611e716a536f78f4930e6e63e7f60d7444775fbc32072935c13b1828377a9e843114255a4101f4e3199f98 SHA512 0c906574ac703f45e3318ae3e7994fe6580fd172849b2956d9084033d6fbfd69fec942b95bc2edadadc223fa0685ff0b9799ad03570b712b9cdb09d69491cc91
diff --git a/app-crypt/pius/files/pius-3.0.0-Fix-typo-in-readme-135.patch b/app-crypt/pius/files/pius-3.0.0-Fix-typo-in-readme-135.patch
new file mode 100644
index 000000000000..bc67e97950b2
--- /dev/null
+++ b/app-crypt/pius/files/pius-3.0.0-Fix-typo-in-readme-135.patch
@@ -0,0 +1,25 @@
+From 5f24833c50ac6d831c03309e9bbb6b62224ac0ac Mon Sep 17 00:00:00 2001
+From: Ross Smith II <ross@smithii.com>
+Date: Mon, 9 Mar 2020 16:45:29 -0700
+Subject: [PATCH] Fix typo in readme (#135)
+
+---
+ README.md | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/README.md b/README.md
+index 3ead858..4cb98ce 100644
+--- a/README.md
++++ b/README.md
+@@ -91,7 +91,7 @@ docs](https://support.google.com/accounts/answer/185833?hl=en).
+ ## Other Platforms
+
+ On non-UNIX platforms such as MacOS and Windows, the default gpg path will
+-likley be incorrect, so you'll want to use `-b` to specify the path.
++likely be incorrect, so you'll want to use `-b` to specify the path.
+
+
+ ## Config File
+--
+2.29.2
+
diff --git a/app-crypt/pius/files/pius-3.0.0-Fix-typos-132.patch b/app-crypt/pius/files/pius-3.0.0-Fix-typos-132.patch
new file mode 100644
index 000000000000..ed03995d34c2
--- /dev/null
+++ b/app-crypt/pius/files/pius-3.0.0-Fix-typos-132.patch
@@ -0,0 +1,43 @@
+From 6a92664fe0cfacffb03e6f3312c1c5fb4d785297 Mon Sep 17 00:00:00 2001
+From: Maxim Baz <github@maximbaz.com>
+Date: Sat, 5 Oct 2019 23:52:17 +0200
+Subject: [PATCH] Fix typos (#132)
+
+---
+ pius | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/pius b/pius
+index 7cf09b5..cc2333b 100755
+--- a/pius
++++ b/pius
+@@ -25,7 +25,7 @@ from optparse import OptionParser
+
+ from libpius import mailer as pmailer
+ from libpius import signer as psigner
+-from libpius.util import PiusUtil, MyOption
++from libpius.util import PiusUtil, MyOption, check_email
+ from libpius.constants import (
+ DEFAULT_GPG_PATH,
+ DEFAULT_KEYRING,
+@@ -61,7 +61,7 @@ def check_options(parser, options, args):
+
+ if options.debug == True:
+ print("Setting debug")
+- util.DEBUG_ON = True
++ PiusUtil.DEBUG_ON = True
+
+ if not os.path.exists(options.gpg_path):
+ parser.error("GnuPG binary not found at %s." % options.gpg_path)
+@@ -288,7 +288,7 @@ def main():
+ )
+ if ans in ("y", "Y", "yes", "YES", "Yes"):
+ ans = input("What email address should we send from? ")
+- util.check_email(parser, "-m", ans)
++ check_email(parser, "-m", ans)
+ options.mail = ans
+ print()
+
+--
+2.29.2
+
diff --git a/app-crypt/pius/files/pius-3.0.0-Minor-fixes-for-pius-report-137.patch b/app-crypt/pius/files/pius-3.0.0-Minor-fixes-for-pius-report-137.patch
new file mode 100644
index 000000000000..c77f26649ce6
--- /dev/null
+++ b/app-crypt/pius/files/pius-3.0.0-Minor-fixes-for-pius-report-137.patch
@@ -0,0 +1,78 @@
+From 19b61c3b0dc31ee60341b3ca708f8e459e44ce3f Mon Sep 17 00:00:00 2001
+From: Phil Dibowitz <phil@ipom.com>
+Date: Mon, 23 Mar 2020 08:57:09 -0700
+Subject: [PATCH] Minor fixes for pius-report (#137)
+
+Signed-off-by: Phil Dibowitz <phil@ipom.com>
+---
+ libpius/mailer.py | 2 +-
+ pius-keyring-mgr | 4 +++-
+ pius-report | 5 +++--
+ 3 files changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/libpius/mailer.py b/libpius/mailer.py
+index ba6b50a..f5b097f 100644
+--- a/libpius/mailer.py
++++ b/libpius/mailer.py
+@@ -403,7 +403,7 @@ class PiusMailer:
+ # BCC the user...
+ env_to = [msg["To"], self.mail]
+
+- smtp.sendmail(self.mail, env_to, msg.as_string())
++ smtp.sendmail(self.mail, env_to, msg.as_string().encode('utf-8'))
+ smtp.quit()
+ except smtplib.SMTPException as emsg:
+ raise MailSendError(emsg)
+diff --git a/pius-keyring-mgr b/pius-keyring-mgr
+index fb0b46a..ec3528a 100755
+--- a/pius-keyring-mgr
++++ b/pius-keyring-mgr
+@@ -1,4 +1,5 @@
+ #!/usr/bin/env python3
++
+ """A utility to create and manage party keyrings."""
+
+ # vim:tw=80:ai:tabstop=4:expandtab:shiftwidth=4
+@@ -446,7 +447,7 @@ class KeyringBuilder:
+ # stolen from pius
+ def get_all_keyids(self, sort_keyring):
+ """Given a keyring, get all the KeyIDs from it."""
+- util.debug("extracting all keyids from keyring")
++ util.debug("extracting all keyids from keyring, sort: %s" % sort_keyring)
+ extra_opts = GPG_QUIET_OPTS + self.AUTO_OPTS + ["--fixed-list-mode"]
+ cmd = self.basecmd + extra_opts + ["--fingerprint"]
+ util.logcmd(cmd)
+@@ -776,6 +777,7 @@ before distributing they keyring.
+ prune.add_option(
+ "--no-sort-keyring",
+ dest="sort_keyring",
++ default=True,
+ action="store_false",
+ help="Do not sort the keyring by name.",
+ )
+diff --git a/pius-report b/pius-report
+index 47f57b5..744da35 100755
+--- a/pius-report
++++ b/pius-report
+@@ -15,7 +15,8 @@ from optparse import OptionParser
+ from libpius import mailer as pmailer
+ from libpius import signer as psigner
+ from libpius.util import PiusUtil, MyOption
+-from libpius.constants import DEFAULT_GPG_PATH, UID_RE, GPG_MIN_OPTS
++from libpius.constants import DEFAULT_GPG_PATH, UID_RE, GPG_MIN_OPTS, \
++ GPG_BASE_OPTS
+ from libpius.exceptions import MailSendError
+ from libpius.state import SignState
+
+@@ -401,7 +402,7 @@ Generated by PIUS Report BETA (http://www.phildev.net/pius/).
+
+ def refresh_keys(gpg, keys):
+ cmd = [gpg] + GPG_MIN_OPTS + ["--refresh-keys"] + keys
+- PiusPiusUtil.logcmd(cmd)
++ PiusUtil.logcmd(cmd)
+ gpg = subprocess.Popen(cmd, stdout=subprocess.PIPE, close_fds=True)
+ gpg.wait()
+
+--
+2.29.2
+
diff --git a/app-crypt/pius/files/pius-3.0.0-pius-keyring-mgr-Fix-constants-134.patch b/app-crypt/pius/files/pius-3.0.0-pius-keyring-mgr-Fix-constants-134.patch
new file mode 100644
index 000000000000..20c43fcbdca4
--- /dev/null
+++ b/app-crypt/pius/files/pius-3.0.0-pius-keyring-mgr-Fix-constants-134.patch
@@ -0,0 +1,58 @@
+From f54adce7ba47ad8882441aec3b0583ee788ea8e1 Mon Sep 17 00:00:00 2001
+From: Phil Dibowitz <phil@ipom.com>
+Date: Tue, 4 Feb 2020 09:33:40 -0800
+Subject: [PATCH] [pius-keyring-mgr] Fix constants (#134)
+
+The refactor of the code meant these constants are now in the
+constants module, not in self.
+
+Fixes #133
+
+Signed-off-by: Phil Dibowitz <phil@ipom.com>
+---
+ pius-keyring-mgr | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/pius-keyring-mgr b/pius-keyring-mgr
+index 1daddeb..fb0b46a 100755
+--- a/pius-keyring-mgr
++++ b/pius-keyring-mgr
+@@ -28,6 +28,8 @@ from libpius.constants import (
+ GPG_BASE_OPTS,
+ GPG_QUIET_OPTS,
+ GPG_FD_OPTS,
++ FP_RE,
++ FIXFP_RE,
+ )
+
+ BADKEYS_RE = re.compile(r"00000000|12345678|no pgp key")
+@@ -143,10 +145,10 @@ class PiusParser:
+ def parse_flatfile(self, filename):
+ with open(filename, "r") as fd:
+ contents = fd.read()
+- matches = self.FP_RE.findall(contents)
++ matches = FP_RE.findall(contents)
+ keys = []
+ for match in matches:
+- flatfp = self.FIXFP_RE.sub("", match)
++ flatfp = FIXFP_RE.sub("", match)
+ keyid = flatfp[-8:]
+ keys.append(
+ {
+@@ -199,11 +201,11 @@ class PiusParser:
+ tmp["key"] = match
+ keys.append(tmp)
+ continue
+- matches = self.FP_RE.findall(decoded)
++ matches = FP_RE.findall(decoded)
+ if matches:
+ for match in matches:
+ num_fps = num_fps + 1
+- fp = self.FIXFP_RE.sub("", match)
++ fp = FIXFP_RE.sub("", match)
+ keyid = keyid_from_fp(fp)
+ tmp = data.copy()
+ tmp.update({"fingerprint": fp, "keyid": keyid})
+--
+2.29.2
+
diff --git a/app-crypt/pius/metadata.xml b/app-crypt/pius/metadata.xml
index 0be0c7e0c49f..702fa93f9162 100644
--- a/app-crypt/pius/metadata.xml
+++ b/app-crypt/pius/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>nickaristocrates@gmail.com</email>
<name>Nicholas Meyer</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
diff --git a/app-crypt/pius/pius-2.2.4.ebuild b/app-crypt/pius/pius-2.2.4.ebuild
deleted file mode 100644
index ff4114878a2b..000000000000
--- a/app-crypt/pius/pius-2.2.4.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool for signing and email all UIDs on a set of PGP keys"
-HOMEPAGE="https://www.phildev.net/pius/"
-SRC_URI="https://github.com/jaymzh/pius/releases/download/v${PV}/pius-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=app-crypt/gnupg-2.0.0"
-RDEPEND="${DEPEND}
- dev-lang/perl"
diff --git a/app-crypt/pius/pius-3.0.0.ebuild b/app-crypt/pius/pius-3.0.0-r1.ebuild
index f7f3745afd4d..cf60ccbe13a5 100644
--- a/app-crypt/pius/pius-3.0.0.ebuild
+++ b/app-crypt/pius/pius-3.0.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -22,6 +22,13 @@ DEPEND=">=app-crypt/gnupg-2.0.0"
RDEPEND="${DEPEND}
dev-lang/perl"
+PATCHES=(
+ "${FILESDIR}/${P}-Fix-typos-132.patch"
+ "${FILESDIR}/${P}-pius-keyring-mgr-Fix-constants-134.patch"
+ "${FILESDIR}/${P}-Fix-typo-in-readme-135.patch"
+ "${FILESDIR}/${P}-Minor-fixes-for-pius-report-137.patch"
+)
+
python_test() {
${EPYTHON} -m unittest discover -s test/* -v || die
}