summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/sign')
-rw-r--r--app-crypt/sign/Manifest1
-rw-r--r--app-crypt/sign/files/1.0.7-as-needed.patch10
-rw-r--r--app-crypt/sign/files/1.0.7-openssl-0.9.8.patch12
-rw-r--r--app-crypt/sign/metadata.xml14
-rw-r--r--app-crypt/sign/sign-1.0.7.ebuild38
5 files changed, 0 insertions, 75 deletions
diff --git a/app-crypt/sign/Manifest b/app-crypt/sign/Manifest
deleted file mode 100644
index 3ac332087c04..000000000000
--- a/app-crypt/sign/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST sign-1.0.7.tar.gz 28535 BLAKE2B e75811aa60f5408af8272503b7b6909eb03e58ab2f70a72efc73a9827af39aa9d5587e2366bc4be4eb67ca88b583d3c75927a0ab94f9f3441ffc60fb6e0e9d6f SHA512 9adb9e520da654e7196451e20501be8e1b84ee750a26344cb7e1816e56e4e8b88773a76a2707a6428faa7828658807eaaef2073b6940e212435ed915881885c0
diff --git a/app-crypt/sign/files/1.0.7-as-needed.patch b/app-crypt/sign/files/1.0.7-as-needed.patch
deleted file mode 100644
index 56574d7131d7..000000000000
--- a/app-crypt/sign/files/1.0.7-as-needed.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -Nur sign-1.0.7.orig/src/Makefile sign-1.0.7/src/Makefile
---- sign-1.0.7.orig/src/Makefile 2004-08-07 07:15:00.000000000 +0000
-+++ sign-1.0.7/src/Makefile 2006-09-16 17:21:12.400977608 +0000
-@@ -1,5 +1,5 @@
- CFLAGS += -Wall -DNDEBUG -g
--LDFLAGS += -lcrypto
-+LDLIBS += -lcrypto
-
- OBJS = buf.o die.o msg.o digest.o uue.o pki.o str.o system-nix.o \
- system-nix-readpass.o util.o
diff --git a/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch b/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch
deleted file mode 100644
index 179efbe77ef5..000000000000
--- a/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur sign-1.0.7.orig/src/pki.c sign-1.0.7/src/pki.c
---- sign-1.0.7.orig/src/pki.c 2004-08-04 04:10:35.000000000 +0000
-+++ sign-1.0.7/src/pki.c 2006-09-16 17:17:34.335535125 +0000
-@@ -286,7 +286,7 @@
-
- /* if it's not a decryption problem - bail out */
- if (ERR_get_error() != ERR_PACK(ERR_LIB_EVP,
-- EVP_F_EVP_DECRYPTFINAL,
-+ EVP_F_EVP_DECRYPTFINAL_EX,
- EVP_R_BAD_DECRYPT))
- goto cleanup;
-
diff --git a/app-crypt/sign/metadata.xml b/app-crypt/sign/metadata.xml
deleted file mode 100644
index 15e7b65be77a..000000000000
--- a/app-crypt/sign/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>alicef@gentoo.org</email>
- <name>Alice Ferrazzi</name>
-</maintainer>
-<longdescription>
-sign is a file signing and signature verification utility. It's main purpose is
-to be a simple and convenient extension to a tar/gz/bzip2 line of tools to check
-file integrity and authenticity. It's small and simple, it does just one thing
-and hopefully does it well.
-</longdescription>
-</pkgmetadata>
diff --git a/app-crypt/sign/sign-1.0.7.ebuild b/app-crypt/sign/sign-1.0.7.ebuild
deleted file mode 100644
index a1e2bbeaf1d0..000000000000
--- a/app-crypt/sign/sign-1.0.7.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="File signing and signature verification utility"
-HOMEPAGE="http://swapped.cc/sign/"
-SRC_URI="http://swapped.cc/${PN}/files/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="libressl"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-openssl-0.9.8.patch
- epatch "${FILESDIR}"/${PV}-as-needed.patch
- # remove -g from CFLAGS, it happens to break the build on ppc-macos
- sed -i -e 's/-g//' src/Makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- dobin ${PN}
- doman man/${PN}.1
- dodoc README
- dosym ${PN} /usr/bin/un${PN}
-}