summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/stan')
-rw-r--r--app-crypt/stan/files/stan-0.4.1-errno.patch8
-rw-r--r--app-crypt/stan/stan-0.4.1-r1.ebuild13
2 files changed, 12 insertions, 9 deletions
diff --git a/app-crypt/stan/files/stan-0.4.1-errno.patch b/app-crypt/stan/files/stan-0.4.1-errno.patch
index a63810c1ac1b..6bce4ba7e0d4 100644
--- a/app-crypt/stan/files/stan-0.4.1-errno.patch
+++ b/app-crypt/stan/files/stan-0.4.1-errno.patch
@@ -1,5 +1,5 @@
---- src/data.c.orig 2005-12-05 13:23:44.000000000 +0200
-+++ src/data.c 2005-12-05 13:24:31.000000000 +0200
+--- a/src/data.c 2005-12-05 13:23:44.000000000 +0200
++++ b/src/data.c 2005-12-05 13:24:31.000000000 +0200
@@ -55,7 +55,9 @@
#include <stats.h>
#include <config.h>
@@ -11,8 +11,8 @@
extern tnode_t **treap;
extern bnode_t *bintree;
size_t size = 0;
---- src/stan.c.orig 2005-12-05 13:23:49.000000000 +0200
-+++ src/stan.c 2005-12-05 13:24:57.000000000 +0200
+--- a/src/stan.c 2005-12-05 13:23:49.000000000 +0200
++++ b/src/stan.c 2005-12-05 13:24:57.000000000 +0200
@@ -46,7 +46,9 @@
#include <bits.h>
#include <config.h>
diff --git a/app-crypt/stan/stan-0.4.1-r1.ebuild b/app-crypt/stan/stan-0.4.1-r1.ebuild
index 4826bbb7abae..ab3a2ca49637 100644
--- a/app-crypt/stan/stan-0.4.1-r1.ebuild
+++ b/app-crypt/stan/stan-0.4.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Stan analyzes binary streams and calculates statistical information"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -14,13 +14,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+PATCHES=(
+ "${FILESDIR}/${P}-errno.patch"
+)
+
src_prepare() {
- eapply -p0 "${FILESDIR}/${P}-errno.patch"
- # Update autotools deprecated file name and macro for bug 468750
+ default
+
mv configure.{in,ac} || die
sed -i \
-e "s/-O3/${CFLAGS}/" \
-e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g" configure.ac || die
eautoreconf
- default
}