summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/stoken')
-rw-r--r--app-crypt/stoken/metadata.xml2
-rw-r--r--app-crypt/stoken/stoken-0.92-r3.ebuild41
-rw-r--r--app-crypt/stoken/stoken-0.92.ebuild30
3 files changed, 42 insertions, 31 deletions
diff --git a/app-crypt/stoken/metadata.xml b/app-crypt/stoken/metadata.xml
index 920373f43e65..8178a08045fb 100644
--- a/app-crypt/stoken/metadata.xml
+++ b/app-crypt/stoken/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>prometheanfire@gentoo.org</email>
diff --git a/app-crypt/stoken/stoken-0.92-r3.ebuild b/app-crypt/stoken/stoken-0.92-r3.ebuild
new file mode 100644
index 000000000000..11e11adeb2f1
--- /dev/null
+++ b/app-crypt/stoken/stoken-0.92-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Software Token for Linux/UNIX"
+HOMEPAGE="https://github.com/cernekee/stoken"
+SRC_URI="https://github.com/cernekee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
+IUSE="gtk"
+
+# TODO: add a USE flag to enable optional use of tomcrypt instead of nettle.
+RDEPEND="
+ dev-libs/nettle:=
+ gtk? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with gtk)
+ --with-nettle
+ --without-tomcrypt
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -type f -delete || die
+}
diff --git a/app-crypt/stoken/stoken-0.92.ebuild b/app-crypt/stoken/stoken-0.92.ebuild
deleted file mode 100644
index 5774eec2cf50..000000000000
--- a/app-crypt/stoken/stoken-0.92.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools
-
-DESCRIPTION="Software Token for Linux/UNIX"
-HOMEPAGE="https://github.com/cernekee/stoken"
-SRC_URI="https://github.com/cernekee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc64 x86"
-IUSE="gtk"
-
-# || ( dev-libs/nettle dev-libs/libtomcrypt ) libtomcrypt is not packaged
-RDEPEND="
- dev-libs/nettle
- gtk? ( >=x11-libs/gtk+-3.12:3 )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- eautoreconf
- eapply_user
-}
-
-src_configure() {
- econf $(use_with gtk)
-}