summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tpm2-totp/tpm2-totp-0.1.1.ebuild')
-rw-r--r--app-crypt/tpm2-totp/tpm2-totp-0.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/tpm2-totp/tpm2-totp-0.1.1.ebuild b/app-crypt/tpm2-totp/tpm2-totp-0.1.1.ebuild
new file mode 100644
index 000000000000..8b2622c25865
--- /dev/null
+++ b/app-crypt/tpm2-totp/tpm2-totp-0.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Attest the trustworthiness of a device against a human using time-based OTP"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-totp"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0:=
+ media-gfx/qrencode:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-defaultflags
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}