summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-3.0.5.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index a8adb2bd5b95..fa73c6781456 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1,2 +1 @@
-DIST acme.sh-3.0.5.tar.gz 270092 BLAKE2B daba86ec09df80d374d1ea632f2bc84ecfbf665874d10fcb410e1bde7787551bb8b128e1ed0a4dc7943f821aaba6f9ae43b83225875f389d02d20d47b6fdf8f3 SHA512 882768c84182a8b11f4f315a9b429cd84399145a97b64772a42e0c7fc478c6c5f93a6c73289410b4d2108786a7c275e99f2e47991bdca315fd7d80a4282eefc9
DIST acme.sh-3.0.6.tar.gz 275569 BLAKE2B 8b7989e7a6e59e7263a343d7d22ae4c6998dc7fc7e8340fde1dc4226681430c2fca00755781c9a1a9b5c564fc1a25a30cc36c131a81cc11a9c2f15a67c870bc8 SHA512 2ddd561356586a289bcd08770b7347ef2e1cb121948987031a9e53d19abd5beda433e50c659aa3ee5dc3b06bdf8e479b5b31ba0b52c4a283d2c491aead4d10ac
diff --git a/app-crypt/acme-sh/acme-sh-3.0.5.ebuild b/app-crypt/acme-sh/acme-sh-3.0.5.ebuild
deleted file mode 100644
index c83e0e967104..000000000000
--- a/app-crypt/acme-sh/acme-sh-3.0.5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PN="${PN/-/.}"
-MY_P="${MY_PN}-${PV}"
-
-inherit optfeature
-
-DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
-HOMEPAGE="https://github.com/acmesh-official/acme.sh"
-SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-IUSE="selinux"
-
-RDEPEND="
- dev-libs/openssl:0
- net-misc/curl
- net-misc/socat
- selinux? ( sec-policy/selinux-certbot )
-"
-
-src_install() {
- newdoc deploy/README.md README-deploy.md
- newdoc dnsapi/README.md README-dnsapi.md
- rm {deploy,dnsapi}/README.md || die
- einstalldocs
-
- exeinto /usr/share/acme.sh
- doexe acme.sh
-
- insinto /usr/share/acme.sh
- doins -r deploy dnsapi notify
-
- keepdir /etc/acme-sh
- doenvd "${FILESDIR}"/99acme-sh
-
- insinto /etc/bash/bashrc.d
- doins "${FILESDIR}"/acme.sh
-
- dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
-}
-
-pkg_postinst() {
- optfeature_header "For webserver mode, install a supported web server:"
- optfeature "using apache2 webserver mode" www-servers/apache
- optfeature "using nginx webserver mode" www-servers/nginx
-}