summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/nwipe/Manifest1
-rw-r--r--app-crypt/nwipe/nwipe-0.35.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/nwipe/Manifest b/app-crypt/nwipe/Manifest
index 82dc0693e1ce..5bd7b09b5986 100644
--- a/app-crypt/nwipe/Manifest
+++ b/app-crypt/nwipe/Manifest
@@ -1 +1,2 @@
DIST nwipe-0.34.tar.gz 6377241 BLAKE2B 1fb785b8f3911124c1982284792b943416c6a33a151fe17aadc851478c45a16d0f16881dc6c8ade2b6eaf06710be59bfb6de1d69fed8d4cf7c4442e0b36a6d60 SHA512 8a9a0bba0e888d2578f41c985ba35ecfb9920f32eca089a73c9926afa8538835682c7ada96a720d928bb0902668b774ebe88bb50c67545f55245623f7140e9c0
+DIST nwipe-0.35.tar.gz 7287854 BLAKE2B 86f9894405067518a0120b47ed31c06bfc12a2bcb22cfb7fee50a5668cedc8b0032caae7de30c840eba03542617e72736240c1c787ee3baf70e67c1ebb231574 SHA512 29032f8eaefa4f116edf19503c8af543a3b2aa011f153e0821aeab188a55b6dafdbfe2722990a66f96f3173a7ccb3e42d2ba063c3e245ae52795e0ef2e7c04b2
diff --git a/app-crypt/nwipe/nwipe-0.35.ebuild b/app-crypt/nwipe/nwipe-0.35.ebuild
new file mode 100644
index 000000000000..d65ee9b2fa41
--- /dev/null
+++ b/app-crypt/nwipe/nwipe-0.35.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Securely erase disks using a variety of recognized methods"
+HOMEPAGE="https://github.com/martijnvanbrummelen/nwipe/"
+SRC_URI="https://github.com/martijnvanbrummelen/nwipe/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libconfig:=
+ sys-block/parted
+ sys-libs/ncurses:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}