summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/eid-mw/Manifest1
-rw-r--r--app-crypt/eid-mw/eid-mw-5.0.28.ebuild118
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild8
3 files changed, 127 insertions, 0 deletions
diff --git a/app-crypt/eid-mw/Manifest b/app-crypt/eid-mw/Manifest
index 61ef6b681744..e0c3eb7c79ad 100644
--- a/app-crypt/eid-mw/Manifest
+++ b/app-crypt/eid-mw/Manifest
@@ -1 +1,2 @@
DIST eid-mw-5.0.23.tar.gz 13614039 BLAKE2B 5df1ad1cfd658586352800119eca17b2c57f642678cb131bd46af7b3cd3e4599e4d84b91c139d47082f07a1a80d6719f352151982085c6a577b01a75b6875782 SHA512 35be133c81cd5824dcffd9d74dae2aaf4cecffc56cf0e106832ea930d7d8a9a7ae115aab19d21cc79d011fe98108b0d67a3a69e5cb27ff3ec0ec059a9d9e0035
+DIST eid-mw-5.0.28.tar.gz 13615312 BLAKE2B 1dbc39267688ad322059009ee0aecdd52e7133d3029285255d019819075249755153b7bf10acd775cee7fef86603de4440ff4e47338a28ff9a1ddfce79ff7adc SHA512 05705180f69cb68617660a793baf314486407557f40a223e474047e2f7f9ca8e125feb60f6b0cd47cba6e84653cfe02cdbf48c7169fe78b39b08ec621e3a7898
diff --git a/app-crypt/eid-mw/eid-mw-5.0.28.ebuild b/app-crypt/eid-mw/eid-mw-5.0.28.ebuild
new file mode 100644
index 000000000000..97045c329e89
--- /dev/null
+++ b/app-crypt/eid-mw/eid-mw-5.0.28.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop gnome2-utils xdg-utils
+
+DESCRIPTION="Electronic Identity Card middleware supplied by the Belgian Federal Government"
+HOMEPAGE="https://eid.belgium.be"
+SRC_URI="https://codeload.github.com/fedict/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+dialogs +gtk p11-kit"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.2.9
+ gtk? (
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:3
+ dev-libs/libxml2
+ net-misc/curl[ssl]
+ net-libs/libproxy
+ >=app-crypt/pinentry-1.1.0-r4[gtk]
+ )
+ p11-kit? ( app-crypt/p11-kit )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="dialogs? ( gtk )"
+
+src_prepare() {
+ default
+
+ # Buggy internal versioning when autoreconf a tarball release.
+ # Weird numbering is required otherwise we get a seg fault in
+ # about-eid-mw program.
+ echo "${PV}-v${PV}" > .version
+
+ # xpi module : we don't want it anymore
+ sed -i -e '/SUBDIRS/ s:plugins_tools/xpi ::' Makefile.am || die
+ sed -i -e '/plugins_tools\/xpi/ d' configure.ac || die
+
+ # hardcoded lsb_info
+ sed -i \
+ -e "s:get_lsb_info('i'):strdup(_(\"Gentoo\")):" \
+ -e "s:get_lsb_info('r'):strdup(_(\"n/a\")):" \
+ -e "s:get_lsb_info('c'):strdup(_(\"n/a\")):" \
+ plugins_tools/aboutmw/gtk/about-main.c || die
+
+ # Fix libdir for pkcs11_manifestdir
+ sed -i \
+ -e "/pkcs11_manifestdir/ s:prefix)/lib:libdir):" \
+ cardcomm/pkcs11/src/Makefile.am || die
+
+ # See bug #732994
+ sed -i \
+ -e '/LDFLAGS="/ s:$CPPFLAGS:$LDFLAGS:' \
+ configure.ac || die
+
+ # See bug #751472
+ eapply "${FILESDIR}/use-printf-in-Makefile.patch"
+
+ # See bug #811270 (remove uml build)
+ sed -i \
+ -e 's:cardlayer/uml::' \
+ cardcomm/pkcs11/src/Makefile.am || die
+ sed -i \
+ -e 's:uml::' \
+ plugins_tools/eid-viewer/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable dialogs) \
+ $(use_enable p11-kit p11kit) \
+ $(use_with gtk gtkvers 'detect') \
+ --with-gnu-ld \
+ --disable-static
+}
+
+src_install() {
+ default
+ rm -r "${ED}"/usr/$(get_libdir)/*.la || die
+ if use gtk; then
+ domenu plugins_tools/eid-viewer/eid-viewer.desktop
+ doicon plugins_tools/eid-viewer/gtk/eid-viewer.png
+ fi
+}
+
+pkg_postinst() {
+ if use gtk; then
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gnome*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not supported by eid-mw."
+ ewarn "You may be prompted for your pin code in an inaccessible shell!!"
+ ewarn "Please select pinentry-gnome3 as default pinentry provider:"
+ ewarn " # eselect pinentry set pinentry-gnome3"
+ ;;
+ esac
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
index 9d56a10ca2be..cce8d5f2d95f 100644
--- a/app-crypt/eid-mw/eid-mw-9999.ebuild
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -56,6 +56,14 @@ src_prepare() {
# See bug #751472
eapply "${FILESDIR}/use-printf-in-Makefile.patch"
+ # See bug #811270 (remove uml build)
+ sed -i \
+ -e 's:cardlayer/uml::' \
+ cardcomm/pkcs11/src/Makefile.am || die
+ sed -i \
+ -e 's:uml::' \
+ plugins_tools/eid-viewer/Makefile.am || die
+
eautoreconf
}