summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm-tools/Manifest1
-rw-r--r--app-crypt/tpm-tools/tpm-tools-1.3.9.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/tpm-tools/Manifest b/app-crypt/tpm-tools/Manifest
index 72623e1db74b..535189128143 100644
--- a/app-crypt/tpm-tools/Manifest
+++ b/app-crypt/tpm-tools/Manifest
@@ -1 +1,2 @@
+DIST tpm-tools-1.3.9.1.tar.gz 482859 BLAKE2B ee915679e23bead04672bf719ce59bb6f20b550be39855b5304caeff554bf54d3cfe9104d464af7762388995e51d2bed0f9bedad83e42146cb7457382d09f4b2 SHA512 63a9c0e761cd890cc0a218de79a9c0169e151aba7824c19bf6b7ec894cf41c4950de1f63bd849aa93a4bdff36cf0fe557bc17113912b6d77f57f2bf1190b6a08
DIST tpm-tools-1.3.9.tar.gz 484023 BLAKE2B 5f9809a8dd4c565c647ceb394e6a6086cd42d256feb39599331b979f73150f60881ba9f25a3b0171173d66da8718f1475c6945b243b86c2261c4e8c489802803 SHA512 460e56031aa65ede6b7aebf0c594d4093d870fb46f7c453c429e53cca442d4c7797ac29b519bca28d42133bc6d7701cdf938adbdf11f8be841157d4f4a3e17ca
diff --git a/app-crypt/tpm-tools/tpm-tools-1.3.9.1.ebuild b/app-crypt/tpm-tools/tpm-tools-1.3.9.1.ebuild
new file mode 100644
index 000000000000..4b922742df44
--- /dev/null
+++ b/app-crypt/tpm-tools/tpm-tools-1.3.9.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic ltprune
+
+DESCRIPTION="TrouSerS' support tools for the Trusted Platform Modules"
+HOMEPAGE="http://trousers.sourceforge.net"
+SRC_URI="mirror://sourceforge/trousers/${PN}/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~s390 ~sh ~x86"
+IUSE="libressl nls pkcs11 debug"
+
+COMMON_DEPEND="
+ >=app-crypt/trousers-0.3.0
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pkcs11? ( dev-libs/opencryptoki )
+ "
+RDEPEND="${COMMON_DEPEND}
+ nls? ( virtual/libintl )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ sed -i -r \
+ -e '/CFLAGS/s/ -m64//' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags $(usex debug -DDEBUG -DNDEBUG)
+
+ econf \
+ $(use_enable nls) \
+ $(use pkcs11 || echo --disable-pkcs11-support)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}