summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/dictd-vera/dictd-vera-1.24.ebuild')
-rw-r--r--app-dicts/dictd-vera/dictd-vera-1.24.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-dicts/dictd-vera/dictd-vera-1.24.ebuild b/app-dicts/dictd-vera/dictd-vera-1.24.ebuild
new file mode 100644
index 000000000000..382ad1a157a1
--- /dev/null
+++ b/app-dicts/dictd-vera/dictd-vera-1.24.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="V.E.R.A. -- Virtual Entity of Relevant Acronyms for dict"
+HOMEPAGE="http://home.snafu.de/ohei/vera/vueber-e.html"
+SRC_URI="mirror://gnu/vera/vera-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="FDL-1.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/vera-${PV}
+PATCHES=(
+ "${FILESDIR}"/${P}-U+D7.patch
+)
+
+src_compile() {
+ cat vera.[0-9a-z] | dictfmt -f -u http://home.snafu.de/ohei \
+ -s "V.E.R.A. -- Virtual Entity of Relevant Acronyms" \
+ vera || die
+ dictzip -v vera.dict || die
+}
+
+src_install() {
+ insinto /usr/lib/dict
+ doins vera.dict.dz
+ doins vera.index
+
+ dodoc changelog README
+}