summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/ipadic/ipadic-2.7.0-r2.ebuild')
-rw-r--r--app-dicts/ipadic/ipadic-2.7.0-r2.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild b/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
index fba0b8b37b2d..eb7764de4425 100644
--- a/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
+++ b/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
@@ -1,23 +1,25 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Japanese dictionary for ChaSen"
HOMEPAGE="http://sourceforge.jp/projects/ipadic/"
SRC_URI="mirror://sourceforge.jp/${PN}/24435/${P}.tar.gz"
LICENSE="ipadic"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
-IUSE=""
+KEYWORDS="amd64 ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+BDEPEND=">=app-text/chasen-2.3.1"
-DEPEND=">=app-text/chasen-2.3.1"
-RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PF}-gentoo.patch )
src_prepare() {
- epatch "${FILESDIR}/${PF}-gentoo.patch"
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -26,5 +28,4 @@ src_install() {
insinto /etc
doins chasenrc
- dodoc AUTHORS ChangeLog NEWS README
}