summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/myspell-de')
-rw-r--r--app-dicts/myspell-de/metadata.xml11
-rw-r--r--app-dicts/myspell-de/myspell-de-2017.01.12-r1.ebuild53
-rw-r--r--app-dicts/myspell-de/myspell-de-2017.01.12.ebuild57
3 files changed, 62 insertions, 59 deletions
diff --git a/app-dicts/myspell-de/metadata.xml b/app-dicts/myspell-de/metadata.xml
index fb091364b669..123df3cd5c79 100644
--- a/app-dicts/myspell-de/metadata.xml
+++ b/app-dicts/myspell-de/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gentoo.2019@r123.de</email>
+ <name>Robert Siebeck</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<stabilize-allarches/>
<longdescription lang="en">
German "frami" standard dictionary with spell check, hyphenation patterns and
diff --git a/app-dicts/myspell-de/myspell-de-2017.01.12-r1.ebuild b/app-dicts/myspell-de/myspell-de-2017.01.12-r1.ebuild
new file mode 100644
index 000000000000..d98d9d33d065
--- /dev/null
+++ b/app-dicts/myspell-de/myspell-de-2017.01.12-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+MY_PV=$(ver_rs 1- -) # YYYY-MM-DD
+
+DESCRIPTION="German (AT,CH,DE) dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/german-de-at-frami-dictionaries
+ https://extensions.libreoffice.org/extensions/german-de-ch-frami-dictionaries
+ https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries
+"
+SRC_URI="
+ l10n_de? (
+ https://extensions.libreoffice.org/extensions/german-de-at-frami-dictionaries/$(ver_rs 1 -)/@@download/file/dict-de_AT-frami_${MY_PV}.oxt
+ https://extensions.libreoffice.org/extensions/german-de-ch-frami-dictionaries/$(ver_rs 1 -)/@@download/file/dict-de_CH-frami_${MY_PV}.oxt
+ https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries/${MY_PV}/@@download/file/dict-de_DE-frami_${MY_PV}.oxt )
+ l10n_de-AT? ( https://extensions.libreoffice.org/extensions/german-de-at-frami-dictionaries/$(ver_rs 1 -)/@@download/file/dict-de_AT-frami_${MY_PV}.oxt )
+ l10n_de-CH? ( https://extensions.libreoffice.org/extensions/german-de-ch-frami-dictionaries/$(ver_rs 1 -)/@@download/file/dict-de_CH-frami_${MY_PV}.oxt )
+ l10n_de-DE? ( https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries/${MY_PV}/@@download/file/dict-de_DE-frami_${MY_PV}.oxt )
+"
+
+LICENSE="GPL-3 GPL-2 LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
+
+PLOCALES=( "de-AT" "de-CH" "de-DE" )
+IUSE+="+l10n_de ${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( l10n_de ${PLOCALES[@]/#/l10n_} )"
+
+src_prepare() {
+ # fixing file names
+ for i in *_frami.*; do
+ mv "${i}" "${i/_frami}" || die
+ done
+
+ MYSPELL_DICT=( )
+ MYSPELL_HYPH=( )
+ MYSPELL_THES=( )
+ for lang in "${PLOCALES[@]}"; do
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_de; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ MYSPELL_HYPH+=( "hyph_${mylinguas}.dic" )
+ MYSPELL_THES+=( "th_${mylinguas}_v2.dat" "th_${mylinguas}_v2.idx" )
+ fi
+ done
+
+ default
+}
diff --git a/app-dicts/myspell-de/myspell-de-2017.01.12.ebuild b/app-dicts/myspell-de/myspell-de-2017.01.12.ebuild
deleted file mode 100644
index 8a010614a251..000000000000
--- a/app-dicts/myspell-de/myspell-de-2017.01.12.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MYSPELL_DICT=(
- "de_AT.aff"
- "de_AT.dic"
- "de_DE.aff"
- "de_DE.dic"
- "de_CH.aff"
- "de_CH.dic"
-)
-
-MYSPELL_HYPH=(
- "hyph_de_AT.dic"
- "hyph_de_DE.dic"
- "hyph_de_CH.dic"
-)
-
-MYSPELL_THES=(
- "th_de_AT_v2.dat"
- "th_de_AT_v2.idx"
- "th_de_DE_v2.dat"
- "th_de_DE_v2.idx"
- "th_de_CH_v2.dat"
- "th_de_CH_v2.idx"
-)
-
-inherit myspell-r2
-
-MY_PV=$(ver_rs 1- -) # YYYY-MM-DD
-
-DESCRIPTION="German (AT,CH,DE) dictionaries for myspell/hunspell"
-HOMEPAGE="
- https://extensions.libreoffice.org/extensions/german-de-at-frami-dictionaries
- https://extensions.libreoffice.org/extensions/german-de-ch-frami-dictionaries
- https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries
-"
-SRC_URI="
- https://extensions.libreoffice.org/extensions/german-de-at-frami-dictionaries/$(ver_rs 1 -)/@@download/file/dict-de_AT-frami_${MY_PV}.oxt
- https://extensions.libreoffice.org/extensions/german-de-ch-frami-dictionaries/$(ver_rs 1 -)/@@download/file/dict-de_CH-frami_${MY_PV}.oxt
- https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries/${MY_PV}/@@download/file/dict-de_DE-frami_${MY_PV}.oxt
-"
-
-LICENSE="GPL-3 GPL-2 LGPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-
-src_prepare() {
- # fixing file names
- for i in *_frami.*; do
- mv "${i}" "${i/_frami}" || die
- done
-
- default
-}