summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/myspell-de')
-rw-r--r--app-dicts/myspell-de/Manifest3
-rw-r--r--app-dicts/myspell-de/metadata.xml5
-rw-r--r--app-dicts/myspell-de/myspell-de-2013.12.06.ebuild55
3 files changed, 63 insertions, 0 deletions
diff --git a/app-dicts/myspell-de/Manifest b/app-dicts/myspell-de/Manifest
new file mode 100644
index 000000000000..9271416a4bfd
--- /dev/null
+++ b/app-dicts/myspell-de/Manifest
@@ -0,0 +1,3 @@
+DIST dict-de_at-frami_2013-12-06.oxt 5923995 SHA256 3e1d962188a9a5d49388231d5bd6b286f3c64ba7ed39a2ce84e579ebf40019b5 SHA512 a37e061be99ba074ff52b3e0320bbb814d3f504ad353c4e562ea9617d0b60f9b2feb4d1453b55c78a6b659420c7baf0e7601e66489c9c25df9a8bad92d9aebb5 WHIRLPOOL 61c356dd5ea765ebb470861394aaf7939c30b2006e9a0d2fa78938a3d700b6adb07d2a4a158a0d3cc9ffab8189c7792c244ae587611168fb91f79f5f5f7c2bb3
+DIST dict-de_ch-frami_2013-12-06.oxt 5914138 SHA256 b053ba0f63b276bafbc1910414a735d099b59955d592f01feedbb8faf6af4ad6 SHA512 d93107b639fc9630ccd0f2afa5a9d639ea444f14e08bd4ebe5ba7c082d7cb516c2a59aa8c3ef7c743872687cc47c45b5ffb5f4be70d2449e61bf65e5cf6c84d6 WHIRLPOOL 2573ae9008191182dabbe06b67910aa82bcd76c6ef5d55757bac402f177e8c4ca105104c04dbba0b68447d6e25c0730f9c71fb3247f14c931b3503967b81c6db
+DIST dict-de_de-frami_2013-12-06.oxt 5924352 SHA256 c82ebfc13b047c5acb28a7b12b42447a7e7c07fbdf24ab5ef77bf099cfbab0a9 SHA512 bf852bd6be13ee02673d9011cabb6ac89b4095e529b3c44651473a06c5c0b1f9ad1261934c157654933b1ce35470e9b900f381219654d6ecc81bb3ebb221ab6f WHIRLPOOL 273da46a23667c59092f33a584f559368f1b82149fc78ec5eef78bef9bde0246252affc3097090fa076a3037da88f2fba9b16bd961041e3efea89a2c021a5d74
diff --git a/app-dicts/myspell-de/metadata.xml b/app-dicts/myspell-de/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/app-dicts/myspell-de/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-dicts/myspell-de/myspell-de-2013.12.06.ebuild b/app-dicts/myspell-de/myspell-de-2013.12.06.ebuild
new file mode 100644
index 000000000000..59e2c3c30bf6
--- /dev/null
+++ b/app-dicts/myspell-de/myspell-de-2013.12.06.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MYSPELL_DICT=(
+ "de_AT.aff"
+ "de_AT.dic"
+ "de_DE.aff"
+ "de_DE.dic"
+ "de_CH.aff"
+ "de_CH.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_de_AT.dic"
+ "hyph_de_DE.dic"
+ "hyph_de_CH.dic"
+)
+
+MYSPELL_THES=(
+ "th_de_AT_v2.dat"
+ "th_de_AT_v2.idx"
+ "th_de_DE_v2.dat"
+ "th_de_DE_v2.idx"
+ "th_de_CH_v2.dat"
+ "th_de_CH_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="German dictionaries for myspell/hunspell"
+HOMEPAGE="
+ http://extensions.libreoffice.org/extension-center/german-de-at-frami-dictionaries
+ http://extensions.libreoffice.org/extension-center/german-de-de-frami-dictionaries
+ http://extensions.libreoffice.org/extension-center/german-de-ch-frami-dictionaries
+"
+SRC_URI="
+ http://extensions.libreoffice.org/extension-center/german-de-at-frami-dictionaries/pscreleasefolder.2011-11-05.7614737245/${PV}/dict-de_at-frami_${PV//./-}.oxt
+ http://extensions.libreoffice.org/extension-center/german-de-de-frami-dictionaries/releases/${PV}/dict-de_de-frami_${PV//./-}.oxt
+ http://extensions.libreoffice.org/extension-center/german-de-ch-frami-dictionaries/pscreleasefolder.2011-11-05.5296069116/${PV}/dict-de_ch-frami_${PV//./-}.oxt
+"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ # rename the tarballs
+ for i in *_frami.*; do
+ mv "${i}" "${i/_frami}" || die
+ done
+}