summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/myspell-lt')
-rw-r--r--app-dicts/myspell-lt/Manifest2
-rw-r--r--app-dicts/myspell-lt/metadata.xml5
-rw-r--r--app-dicts/myspell-lt/myspell-lt-1.3-r1.ebuild31
-rw-r--r--app-dicts/myspell-lt/myspell-lt-1.3.ebuild26
4 files changed, 35 insertions, 29 deletions
diff --git a/app-dicts/myspell-lt/Manifest b/app-dicts/myspell-lt/Manifest
index 69c7cc6b43e5..bbacc03bb95d 100644
--- a/app-dicts/myspell-lt/Manifest
+++ b/app-dicts/myspell-lt/Manifest
@@ -1 +1 @@
-DIST myspell-lt-1.3.zip 339657 BLAKE2B 9549d1968d3b60a2b712360dab35fe696369afbdb34097eb7484ea0497b67becb43592878cec5e64691e0069babc9d56817b4d170dbb1ef092d50de64b076420 SHA512 e18f22efb665e3c4cfe0398bafc9e0626c4322009e4b056f3f5cb074778af851bd463be05c55e1bb0bfbc1a04d06d022a3aa37c89e7efac2aa38b525ab415cf2
+DIST openoffice-spellcheck-lt-1-3.oxt 327929 BLAKE2B 9dbc0018e0b077748ecb6312239cc987157b6ba00beb0a19c54c249647b177f9b9a4d44c9e1aad921824154f3655f5b6f52569e26bc0d4d961f04210cfb507fd SHA512 c16e420f0b0c0bd764c144cc771986398d1a72588fc84e0b486991bd424a562f9df5e3e0615db69dee06bd9c630e714ffe8a691da7c23981a573ccc49782f501
diff --git a/app-dicts/myspell-lt/metadata.xml b/app-dicts/myspell-lt/metadata.xml
index 181f1558f9f1..0c31c90e0888 100644
--- a/app-dicts/myspell-lt/metadata.xml
+++ b/app-dicts/myspell-lt/metadata.xml
@@ -1,7 +1,8 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
+ <stabilize-allarches/>
<upstream>
<remote-id type="launchpad">ispell-lt</remote-id>
</upstream>
diff --git a/app-dicts/myspell-lt/myspell-lt-1.3-r1.ebuild b/app-dicts/myspell-lt/myspell-lt-1.3-r1.ebuild
new file mode 100644
index 000000000000..d6f06d67ec83
--- /dev/null
+++ b/app-dicts/myspell-lt/myspell-lt-1.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=(
+ "lt_LT.aff"
+ "lt_LT.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_lt_LT.dic"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Lithuanian dictionaries for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/en/extensions/show/lithuanian-spellcheck-and-hyphenation-dictionaries"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/z/openoffice-spellcheck-lt-$(ver_rs 1 '-').oxt"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
+
+src_prepare() {
+ default
+ # renaming correctly
+ mv lt.aff lt_LT.aff || die
+ mv lt.dic lt_LT.dic || die
+ mv hyph_lt.dic hyph_lt_LT.dic || die
+}
diff --git a/app-dicts/myspell-lt/myspell-lt-1.3.ebuild b/app-dicts/myspell-lt/myspell-lt-1.3.ebuild
deleted file mode 100644
index 21c033bdd0ca..000000000000
--- a/app-dicts/myspell-lt/myspell-lt-1.3.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MYSPELL_DICT=(
- "${P}/lt_LT.aff"
- "${P}/lt_LT.dic"
-)
-
-MYSPELL_HYPH=(
-)
-
-MYSPELL_THES=(
-)
-
-inherit myspell-r2
-
-DESCRIPTION="Lithuanian dictionaries for myspell/hunspell"
-HOMEPAGE="https://launchpad.net/ispell-lt"
-SRC_URI="https://launchpad.net/ispell-lt/main/${PV}/+download/${P}.zip"
-
-LICENSE="BSD LPPL-1.3b"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE=""