summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/gnome-dictionary/Manifest1
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.26.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
index 308dc3575941..691aebe1768f 100644
--- a/app-dicts/gnome-dictionary/Manifest
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -1 +1,2 @@
DIST gnome-dictionary-3.24.1.tar.xz 880500 BLAKE2B f730276612d2578e7b25121b49be9639cf7a9fc67bda9687285f6d3873d3b825301246447d968b24ed29240a1b0e7fc48d63c8454e704b799eebdf340f5f6da2 SHA512 b3ee838888a97e914add58dd4b61fa096b9488aab360815f2e7b674e7a57b237849a1ccaf107c1e94968e534b24ee24d827c42a3a1b0dfd8c5ef25eeb90456d3
+DIST gnome-dictionary-3.26.1.tar.xz 662048 BLAKE2B 3b77d3632629f8502476f029ab9ba3c66225cd619992e185b1403adfeba718b7e0fa0f32762eb086c1e9ef80a08cf79cd872e2ca3026b8cb3975954077c5f7c1 SHA512 da7169795740295c13f02143f5263603f0f6c621e96cecf88a4ee089114399d59f083987bc4571821467da64dc43f00bebbe4ea66b46a035088f85d35d6aee27
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.26.1.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.26.1.ebuild
new file mode 100644
index 000000000000..d5ced459001d
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.26.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0" # does not provide a public libgdict-1.0.so anymore
+IUSE="ipv6"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.21.2:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use ipv6 use_ipv6)
+ -Dbuild_man=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}