summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/devmanual/devmanual-9999.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index 1170493b93eb..13af86d6e06c 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=(python3_{7,8,9})
+EAPI=8
+PYTHON_COMPAT=( python3_{9,10,11,12} )
+PYTHON_REQ_USE="xml(+)"
inherit python-any-r1 readme.gentoo-r1
DESCRIPTION="The Gentoo Development Guide"
@@ -16,18 +17,20 @@ else
# "make dist" in devmanual repo
SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
S="${WORKDIR}/${PN}"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
fi
LICENSE="CC-BY-SA-4.0"
SLOT="0"
-IUSE="+offline"
+IUSE="+offline test"
+RESTRICT="!test? ( test )"
-BDEPEND="dev-libs/libxml2
+BDEPEND=">=dev-libs/libxml2-2.9.12
dev-libs/libxslt
gnome-base/librsvg
media-fonts/open-sans
- ${PYTHON_DEPS}"
+ ${PYTHON_DEPS}
+ test? ( >=app-text/htmltidy-5.8.0 )"
PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )