summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/pms/pms-9999.ebuild')
-rw-r--r--app-doc/pms/pms-9999.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/app-doc/pms/pms-9999.ebuild b/app-doc/pms/pms-9999.ebuild
index 001aee4fd9fb..337c699dd800 100644
--- a/app-doc/pms/pms-9999.ebuild
+++ b/app-doc/pms/pms-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit git-r3
@@ -10,28 +10,25 @@ EGIT_BRANCH="master"
DESCRIPTION="Gentoo Package Manager Specification (draft)"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Package_Manager_Specification"
-LICENSE="CC-BY-SA-3.0"
+LICENSE="CC-BY-SA-4.0"
SLOT="live"
IUSE="html twoside"
-# leaflet: used by eapi-cheatsheet
-# tl-bibtexextra: unsrturl.bst
-# tl-latexextra: chngcntr, gitinfo2, isodate, marginnote, paralist, tocbibind
-# tl-mathscience: algorithm, algorithmic
-BDEPEND="dev-tex/leaflet
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-latexrecommended
+# texlive-bibtexextra for unsrturl.bst
+# texlive-latexextra for chngcntr, gitinfo2, isodate, leaflet, marginnote,
+# paralist, tocbibind
+# texlive-mathscience for algorithm, algorithmic
+BDEPEND="dev-texlive/texlive-bibtexextra
+ >=dev-texlive/texlive-latexextra-2020-r2
dev-texlive/texlive-mathscience
- html? ( >=dev-tex/tex4ht-20090611_p1038-r5 )"
+ virtual/latex-base
+ html? ( >=dev-tex/tex4ht-20090611_p1038-r11 )"
RDEPEND="!app-doc/pms-bin"
src_compile() {
# just in case; we shouldn't be generating any fonts
export VARTEXFONTS="${T}/fonts"
- emake $(usex twoside TWOSIDE=yes "")
+ emake $(usev twoside TWOSIDE=yes)
use html && emake html
}