summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/selflinux/selflinux-0.13.0-r1.ebuild')
-rw-r--r--app-doc/selflinux/selflinux-0.13.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-doc/selflinux/selflinux-0.13.0-r1.ebuild b/app-doc/selflinux/selflinux-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..fae5d5e449a9
--- /dev/null
+++ b/app-doc/selflinux/selflinux-0.13.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="SelfLinux-${PV}"
+
+DESCRIPTION="A german-language hypertext tutorial about Linux"
+HOMEPAGE="https://www.selflinux.org/"
+SRC_URI="https://www.selflinux.org/download/${MY_P}/${MY_P}-html.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+HTML_DOCS=( "." )
+
+BDEPEND="media-gfx/pngcrush"
+
+src_prepare() {
+ default
+
+ # Fix all png files, as they report "broken IDAT window length"
+ for png_file in bilder/mwm_mwm_mwm*; do
+ pngcrush -fix -force -ow "${png_file}" || die
+ done
+}