summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild b/app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild
index c5898b1c2dd7..65e8e0a1bbaf 100644
--- a/app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild
@@ -235,8 +235,12 @@ src_configure() {
einfo "Configuring to build with no toolkit"
myconf+=" --with-x-toolkit=no"
fi
- ! use gtk && use xwidgets && ewarn \
- "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+ if ! use gtk; then
+ use gtk2 && ewarn \
+ "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
+ use xwidgets && ewarn \
+ "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+ fi
elif use aqua; then
einfo "Configuring to build with Nextstep (Cocoa) support"
myconf+=" --with-ns --disable-ns-self-contained"