summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/fe/fe-2.0.ebuild')
-rw-r--r--app-editors/fe/fe-2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/fe/fe-2.0.ebuild b/app-editors/fe/fe-2.0.ebuild
new file mode 100644
index 000000000000..6120b64d7b06
--- /dev/null
+++ b/app-editors/fe/fe-2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A small and easy to use folding editor"
+HOMEPAGE="http://www.moria.de/~michael/fe/"
+SRC_URI="http://www.moria.de/~michael/fe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sendmail"
+
+RDEPEND="sys-libs/ncurses:0=
+ sendmail? ( virtual/mta )"
+DEPEND="${RDEPEND}"
+
+PATCHES=("${FILESDIR}"/${PN}-1.8-makefile.patch)
+
+src_configure() {
+ econf $(use_enable sendmail)
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ datadir="${D}"/usr/share \
+ MANDIR="${D}"/usr/share/man \
+ install
+
+ dodoc NEWS README
+ docinto html
+ dodoc fe.html
+}