summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/featherpad')
-rw-r--r--app-editors/featherpad/Manifest2
-rw-r--r--app-editors/featherpad/featherpad-1.5.0-r1.ebuild34
-rw-r--r--app-editors/featherpad/featherpad-1.5.1.ebuild34
-rw-r--r--app-editors/featherpad/featherpad-9999.ebuild32
-rw-r--r--app-editors/featherpad/metadata.xml30
5 files changed, 132 insertions, 0 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
new file mode 100644
index 000000000000..799914a36ec3
--- /dev/null
+++ b/app-editors/featherpad/Manifest
@@ -0,0 +1,2 @@
+DIST featherpad-1.5.0.tar.gz 1087068 BLAKE2B aef468f426c9c635624fe16f8180647a9f62a12c98d654dfb340758ff524e629341469ec3f37cfe8a481def99ba6c99672aa31c49b03226e2e895dce11e9b5e6 SHA512 984d1fba0e4bcb1eda8c2dd3bee34cf2ee0ba5604dd2c9328cc67531099b8a806e8ab79020510049eb788764cf0ad4486c128eefb43d9ab1ccdc4a3c06c48497
+DIST featherpad-1.5.1.tar.gz 1087189 BLAKE2B ede7cde803f5133ccab847c1fd1279de97b4cc3ad3e56874f26096e2cbf17dd197a3db1e6ff8b41c603501d541e314ea9ff434c0be486abd42ce4c9ec1555e56 SHA512 2fff60896c30402ffc87a8daecd6b80d86ff1b19dcc3946d507c8f37742b033cad60fbcb7df61e7e4cbb53821c0d06b5b732a5728cbbb6af3ea03b5872075ea3
diff --git a/app-editors/featherpad/featherpad-1.5.0-r1.ebuild b/app-editors/featherpad/featherpad-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..9b69e0fe90b1
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.5.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+X"
+
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtbase:6[dbus,gui,widgets]
+ dev-qt/qtsvg:6
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}
diff --git a/app-editors/featherpad/featherpad-1.5.1.ebuild b/app-editors/featherpad/featherpad-1.5.1.ebuild
new file mode 100644
index 000000000000..9b69e0fe90b1
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+X"
+
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtbase:6[dbus,gui,widgets]
+ dev-qt/qtsvg:6
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}
diff --git a/app-editors/featherpad/featherpad-9999.ebuild b/app-editors/featherpad/featherpad-9999.ebuild
new file mode 100644
index 000000000000..5ae9de86c8fd
--- /dev/null
+++ b/app-editors/featherpad/featherpad-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 cmake xdg
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+EGIT_REPO_URI="https://github.com/tsujan/FeatherPad"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+X"
+
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtbase:6[dbus,gui,widgets]
+ dev-qt/qtsvg:6
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}
diff --git a/app-editors/featherpad/metadata.xml b/app-editors/featherpad/metadata.xml
new file mode 100644
index 000000000000..ef220843828f
--- /dev/null
+++ b/app-editors/featherpad/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>hansfn@gmail.com</email>
+ <name>Hans Fredrik Nordhaug</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ FeatherPad (by Pedram Pourang, a.k.a. Tsu Jan) is a lightweight Qt
+ plain-text editor for Linux. It is independent of any desktop
+ environment.
+ </longdescription>
+ <use>
+ <flag name="X">
+ Link application against X11 libraries which adds
+ support for virtual desktop awareness and tab DND
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">tsujan/FeatherPad</remote-id>
+ </upstream>
+</pkgmetadata>