summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gedit/files')
-rw-r--r--app-editors/gedit/files/3.32.2-make-spell-optional.patch61
-rw-r--r--app-editors/gedit/files/3.36-make-gspell-optional.patch62
-rw-r--r--app-editors/gedit/files/3.36-make-python-optional.patch90
-rw-r--r--app-editors/gedit/files/restore-overlay-scrollbars.patch26
4 files changed, 0 insertions, 239 deletions
diff --git a/app-editors/gedit/files/3.32.2-make-spell-optional.patch b/app-editors/gedit/files/3.32.2-make-spell-optional.patch
deleted file mode 100644
index 1d772590f605..000000000000
--- a/app-editors/gedit/files/3.32.2-make-spell-optional.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 72efa486222cde6094c217efc6085f49af1cca85 Mon Sep 17 00:00:00 2001
-From: Sobhan Mohammadpour <sobhan@gentoo.org>
-Date: Sun, 26 May 2019 14:19:17 -0400
-Subject: [PATCH] make spell optional
-
----
- meson.build | 4 +++-
- meson_options.txt | 4 ++++
- plugins/meson.build | 4 +++-
- 3 files changed, 10 insertions(+), 2 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index 2f4d7e5..f67e320 100644
---- a/meson.build
-+++ b/meson.build
-@@ -86,7 +86,8 @@ libxml_dep = dependency('libxml-2.0', version: libxml_req)
- libgd_dep = libgd_sp.get_variable('libgd_dep')
-
- libsoup_dep = dependency('libsoup-2.4', version: libsoup_req, required: true)
--gspell_dep = dependency('gspell-1', version: gspell_req, required: true)
-+with_gspell = get_option('spell')
-+gspell_dep = dependency('gspell-1', version: gspell_req, required: false)
- x11_dep = dependency('x11', required: false)
-
- introspection_dep = dependency('gobject-introspection-1.0', version: introspection_req, required: false)
-@@ -189,6 +190,7 @@ summary = [
- ' Introspection: @0@'.format(generate_gir),
- ' Plugins: @0@'.format(build_plugins),
- ' Vala API: @0@'.format(generate_vapi),
-+ ' Spell: @0@'.format(with_gspell),
- ' Gvfs metadata: @0@'.format(enable_gvfs_metadata),
- '',
- 'Directories:',
-diff --git a/meson_options.txt b/meson_options.txt
-index 90803fa..e1f7349 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -16,3 +16,7 @@ option('documentation',
- option('enable-gvfs-metadata',
- type: 'combo', choices : ['yes', 'no', 'auto'], value : 'auto',
- description: 'Enable using gvfs to store metadata')
-+
-+option('spell',
-+ type:'boolean', value: true,
-+ description: 'Build spell support')
-diff --git a/plugins/meson.build b/plugins/meson.build
-index af94ab7..abeeac5 100644
---- a/plugins/meson.build
-+++ b/plugins/meson.build
-@@ -21,5 +21,7 @@ subdir('quickhighlight')
- subdir('quickopen')
- subdir('snippets')
- subdir('sort')
--subdir('spell')
-+if with_gspell
-+ subdir('spell')
-+endif
- subdir('time')
---
-2.21.0
-
diff --git a/app-editors/gedit/files/3.36-make-gspell-optional.patch b/app-editors/gedit/files/3.36-make-gspell-optional.patch
deleted file mode 100644
index e891f98f0c00..000000000000
--- a/app-editors/gedit/files/3.36-make-gspell-optional.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From d622460b08c7c13ce8e0c23e3afcbd1e4c65d019 Mon Sep 17 00:00:00 2001
-From: Mart Raudsepp <leio@gentoo.org>
-Date: Sun, 16 Aug 2020 23:20:31 +0300
-Subject: [PATCH] build: Make gspell optional
-
----
- meson.build | 3 ++-
- meson_options.txt | 4 ++++
- plugins/spell/meson.build | 4 ++++
- 3 files changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index edb2896a6..b8707f33d 100644
---- a/meson.build
-+++ b/meson.build
-@@ -63,7 +63,7 @@ libpeas_gtk_dep = dependency('libpeas-gtk-1.0', version: libpeas_req)
-
- libgd_dep = libgd_subproject.get_variable('libgd_dep')
-
--gspell_dep = dependency('gspell-1', version: '>= 1.0', required: true)
-+gspell_dep = dependency('gspell-1', version: '>= 1.0', required: get_option('spell'))
- x11_dep = dependency('x11', required: false)
-
- introspection_dep = dependency('gobject-introspection-1.0', required: false)
-@@ -154,6 +154,7 @@ summary = [
- ' User documentation: @0@'.format(get_option('user_documentation')),
- ' GObject Introspection: @0@'.format(generate_gir),
- ' Vala API: @0@'.format(generate_vapi),
-+ ' Spell checker plugin: @0@'.format(gspell_dep.found().to_string()),
- '',
- ]
- message('\n'.join(summary))
-diff --git a/meson_options.txt b/meson_options.txt
-index d0cbf0720..03e07244e 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -10,6 +10,10 @@ option('gtk_doc',
- type: 'boolean', value: false,
- description: 'Build API reference for plugins (requires gtk-doc)')
-
-+option('spell',
-+ type: 'feature', value: 'enabled',
-+ description: 'Build spell checking plugin')
-+
- # This option exists for the developers, to speed up the install.
- option('user_documentation',
- type: 'boolean', value: true,
-diff --git a/plugins/spell/meson.build b/plugins/spell/meson.build
-index 8ce7634b7..cccb42fc1 100644
---- a/plugins/spell/meson.build
-+++ b/plugins/spell/meson.build
-@@ -1,3 +1,7 @@
-+if not gspell_dep.found()
-+ subdir_done()
-+endif
-+
- libspell_sources = files(
- 'gedit-spell-app-activatable.c',
- 'gedit-spell-plugin.c',
---
-2.20.1
-
diff --git a/app-editors/gedit/files/3.36-make-python-optional.patch b/app-editors/gedit/files/3.36-make-python-optional.patch
deleted file mode 100644
index c27a0551f00b..000000000000
--- a/app-editors/gedit/files/3.36-make-python-optional.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From d082ef03b9f545980ab77e6c0a20d5bf4893be69 Mon Sep 17 00:00:00 2001
-From: Mart Raudsepp <leio@gentoo.org>
-Date: Sun, 16 Aug 2020 23:34:42 +0300
-Subject: [PATCH] build: Make python optional
-
----
- gedit/meson.build | 2 ++
- meson.build | 4 +++-
- meson_options.txt | 4 ++++
- plugins/meson.build | 11 +++++++----
- 4 files changed, 16 insertions(+), 5 deletions(-)
-
-diff --git a/gedit/meson.build b/gedit/meson.build
-index 075c001b2..174deba04 100644
---- a/gedit/meson.build
-+++ b/gedit/meson.build
-@@ -214,6 +214,7 @@ if generate_gir == true
- install_dir_typelib: join_paths(pkglibdir, 'girepository-1.0'),
- )
-
-+if get_option('python')
- python3.install_sources(
- 'Gedit.py',
- subdir: join_paths(
-@@ -221,6 +222,7 @@ if generate_gir == true
- 'overrides',
- )
- )
-+endif
-
- libgedit_dep_sources += [
- libgedit_gir,
-diff --git a/meson.build b/meson.build
-index b8707f33d..4e40833ec 100644
---- a/meson.build
-+++ b/meson.build
-@@ -69,7 +69,9 @@ x11_dep = dependency('x11', required: false)
- introspection_dep = dependency('gobject-introspection-1.0', required: false)
- vapigen_dep = dependency('vapigen', version: '>= 0.25.1', required: false)
-
--python3 = python.find_installation('python3')
-+if get_option('python')
-+ python3 = python.find_installation('python3')
-+endif
-
- build_checkupdate_plugin = host_machine.system() == 'windows'
- if build_checkupdate_plugin
-diff --git a/meson_options.txt b/meson_options.txt
-index 03e07244e..cdcec6165 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -10,6 +10,10 @@ option('gtk_doc',
- type: 'boolean', value: false,
- description: 'Build API reference for plugins (requires gtk-doc)')
-
-+option('python',
-+ type: 'boolean', value: true,
-+ description: 'Install GIR python overrides and python plugins')
-+
- option('spell',
- type: 'feature', value: 'enabled',
- description: 'Build spell checking plugin')
-diff --git a/plugins/meson.build b/plugins/meson.build
-index a9167f8d6..97f1b1765 100644
---- a/plugins/meson.build
-+++ b/plugins/meson.build
-@@ -20,13 +20,16 @@ if build_checkupdate_plugin
- endif
-
- subdir('docinfo')
--subdir('externaltools')
- subdir('filebrowser')
- subdir('modelines')
--subdir('pythonconsole')
- subdir('quickhighlight')
--subdir('quickopen')
--subdir('snippets')
- subdir('sort')
- subdir('spell')
- subdir('time')
-+
-+if get_option('python')
-+ subdir('externaltools')
-+ subdir('pythonconsole')
-+ subdir('quickopen')
-+ subdir('snippets')
-+endif
---
-2.20.1
-
diff --git a/app-editors/gedit/files/restore-overlay-scrollbars.patch b/app-editors/gedit/files/restore-overlay-scrollbars.patch
deleted file mode 100644
index 55a353a796bf..000000000000
--- a/app-editors/gedit/files/restore-overlay-scrollbars.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 189ee4514107e70a62d44766f8ca39d815d48581 Mon Sep 17 00:00:00 2001
-From: Michael Catanzaro <mcatanzaro@gnome.org>
-Date: Fri, 20 Mar 2020 11:32:59 -0500
-Subject: [PATCH] Revert "ViewFrame: disable overlay scrolling for the
- GtkScrolledWindow"
-
-This reverts commit 5e0909c19f267b4023131881fac89c58a2a17453.
----
- gedit/resources/ui/gedit-view-frame.ui | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/gedit/resources/ui/gedit-view-frame.ui b/gedit/resources/ui/gedit-view-frame.ui
-index ebf70b013..4c783c711 100644
---- a/gedit/resources/ui/gedit-view-frame.ui
-+++ b/gedit/resources/ui/gedit-view-frame.ui
-@@ -11,7 +11,6 @@
- <property name="visible">True</property>
- <property name="hexpand">True</property>
- <property name="vexpand">True</property>
-- <property name="overlay_scrolling">False</property>
- <child>
- <object class="GeditView" id="view">
- <property name="visible">True</property>
---
-2.25.1
-