summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 0a202597784e..a68b9011e15f 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+# Please bump with app-editors/vim-core and app-editors/gvim
+
VIM_VERSION="8.2"
LUA_COMPAT=( lua5-1 luajit )
PYTHON_COMPAT=( python3_{7..10} )
@@ -17,14 +20,15 @@ if [[ ${PV} == 9999* ]]; then
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
fi
+S="${WORKDIR}"/vim-${PV}
DESCRIPTION="GUI version of the Vim text editor"
HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
-SLOT="0"
LICENSE="vim"
+SLOT="0"
IUSE="acl aqua crypt cscope debug gtk gtk2 lua motif neXt netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
@@ -75,19 +79,18 @@ RDEPEND="
sound? ( media-libs/libcanberra )
tcl? ( dev-lang/tcl:0= )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+# configure runs the Lua interpreter
+BDEPEND="
sys-devel/autoconf
virtual/pkgconfig
+ lua? ( ${LUA_DEPS} )
nls? ( sys-devel/gettext )
"
-# configure runs the Lua interpreter
-BDEPEND="lua? ( ${LUA_DEPS} )"
# various failures (bugs #630042 and #682320)
RESTRICT="test"
-S=${WORKDIR}/vim-${PV}
-
pkg_setup() {
# people with broken alphabets run into trouble. bug 82186.
unset LANG LC_ALL