summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hexedit')
-rw-r--r--app-editors/hexedit/Manifest2
-rw-r--r--app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch10
-rw-r--r--app-editors/hexedit/hexedit-1.2.13.ebuild30
-rw-r--r--app-editors/hexedit/hexedit-1.6.ebuild34
-rw-r--r--app-editors/hexedit/metadata.xml9
5 files changed, 43 insertions, 42 deletions
diff --git a/app-editors/hexedit/Manifest b/app-editors/hexedit/Manifest
index 792220b96ded..949cb6d596a1 100644
--- a/app-editors/hexedit/Manifest
+++ b/app-editors/hexedit/Manifest
@@ -1 +1 @@
-DIST hexedit-1.2.13.src.tgz 68778 BLAKE2B 377c4f0008f6e3b54e4cf2e0249fa344b684b11a6acea9daf7d8e6585524f9d11a4eb199d5289a57a72be5efbdf3060cc47269aad1d218784e7679a469ca4f50 SHA512 df9afb0b9b965e20ea8c427c1986b0200216601b157862199c35bae9e201ccc478ab0bfecd39d0dfaa85bf582f1cf372b0134fadcfeacf4734805a6e6dcaa2bb
+DIST hexedit-1.6.tar.gz 31085 BLAKE2B e576de6aaed35449adbc430c95e8ba3a8ccfba587ef5c4d347d95b84c9764cb644323af23d46ff16429b93e0348c8d310afbad482219aa1b2c1b582332bd06fe SHA512 9783406f253a67fe048ec12306df1a601b7ba92cd7a0399ad2f103aed5a3164cd21ad7c1d547a4c55192cfb7da2b2517152015a4c3db402a9217548b435f602d
diff --git a/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch b/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch
deleted file mode 100644
index 86e7dba4e88e..000000000000
--- a/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -37,6 +37,7 @@
- AC_CHECK_LIB(curses, initscr, LIBS="$LIBS -lcurses",
- AC_CHECK_LIB(ncurses, initscr, LIBS="$LIBS -lncurses")
- )
-+AC_SEARCH_LIBS(nodelay, tinfo)
- AC_CHECK_FUNC(use_default_colors,
- AC_DEFINE(HAVE_COLORS, , "Define if you want colored (fruit salad) display option")
- )
diff --git a/app-editors/hexedit/hexedit-1.2.13.ebuild b/app-editors/hexedit/hexedit-1.2.13.ebuild
deleted file mode 100644
index f06e9e63f500..000000000000
--- a/app-editors/hexedit/hexedit-1.2.13.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils
-
-DESCRIPTION="View and edit files in hex or ASCII"
-HOMEPAGE="http://rigaux.org/hexedit.html"
-SRC_URI="http://rigaux.org/${P}.src.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-
-DEPEND="sys-libs/ncurses:="
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
- mv configure.in configure.ac || die
- eautoreconf
-}
-
-src_install() {
- dobin hexedit
- doman hexedit.1
- dodoc Changes
-}
diff --git a/app-editors/hexedit/hexedit-1.6.ebuild b/app-editors/hexedit/hexedit-1.6.ebuild
new file mode 100644
index 000000000000..605cb66f658d
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+EGIT_REPO_URI="https://github.com/pixel/hexedit.git"
+else
+SRC_URI="https://github.com/pixel/hexedit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}
diff --git a/app-editors/hexedit/metadata.xml b/app-editors/hexedit/metadata.xml
index 4e80019694b1..c51d7729677b 100644
--- a/app-editors/hexedit/metadata.xml
+++ b/app-editors/hexedit/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>tomjbe@gentoo.org</email>
<name>Thomas Beierlein</name>
</maintainer>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pixel/hexedit</remote-id>
+ </upstream>
</pkgmetadata>