summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hteditor/hteditor-2.1.0-r1.ebuild')
-rw-r--r--app-editors/hteditor/hteditor-2.1.0-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild b/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
deleted file mode 100644
index 16a7ab4322f0..000000000000
--- a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools toolchain-funcs
-
-MY_P=${P/editor}
-
-DESCRIPTION="A file viewer, editor and analyzer for text, binary, and executable files"
-HOMEPAGE="http://hte.sourceforge.net/ https://github.com/sebastianbiallas/ht/"
-SRC_URI="mirror://sourceforge/hte/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="X"
-
-RDEPEND="sys-libs/ncurses:0=
- X? ( x11-libs/libX11 )
- >=dev-libs/lzo-2"
-DEPEND="${RDEPEND}
- virtual/yacc
- sys-devel/flex"
-
-DOCS=( AUTHORS ChangeLog KNOWNBUGS README TODO )
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-7.patch
- "${FILESDIR}"/${P}-tinfo.patch
- "${FILESDIR}"/${P}-gcc-6-uchar.patch
- "${FILESDIR}"/${P}-format-security.patch
- "${FILESDIR}"/${P}-gcc-10.patch
- "${FILESDIR}"/${P}-AR.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable X x11-textmode) \
- --enable-maintainermode
-}
-
-src_install() {
- #For prefix
- chmod u+x "${S}/install-sh"
-
- local HTML_DOCS="doc/*.html"
- doinfo doc/*.info
-
- default
-}