summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hteditor')
-rw-r--r--app-editors/hteditor/Manifest1
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-AR.patch14
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-format-security.patch57
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch36
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch32
-rw-r--r--app-editors/hteditor/hteditor-2.1.0-r1.ebuild64
-rw-r--r--app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild16
-rw-r--r--app-editors/hteditor/metadata.xml7
8 files changed, 10 insertions, 217 deletions
diff --git a/app-editors/hteditor/Manifest b/app-editors/hteditor/Manifest
index 269e9e3ca85d..54779c7af5c0 100644
--- a/app-editors/hteditor/Manifest
+++ b/app-editors/hteditor/Manifest
@@ -1,2 +1 @@
-DIST ht-2.1.0.tar.bz2 884139 BLAKE2B c979563cbfc4df7e14f587b250fbf099d9f4683afddb3afc88693284c378c45466dfa3c47555fc69e83e2972cfabab63f3cdd42fd85602842854372131e4063d SHA512 6b5fc5fcbc63b9b7c85721158e044e4578ebfdc38618c760c0e6de06a276bccd3a960ab8bed172de788934515ad94d86349c4abd3228da66b1601deaaa2ce410
DIST ht-2.1.1_pre20161206.tar.gz 1082309 BLAKE2B 4fb00b0aa6115da3b561436f9f9905c48d93d6768bcf207931bb46840727c85fb5c9a1afda8ed805f71e9ce242161a2b95e26add02ff5aedc407df7f11c6ddec SHA512 33d681ee8c978568dd0d187d6846994362625d000c316baab10c237175fa6a47dc0e7b61cfd503c4dfad8a01d27af7fc87cbf20109087e1d9280048c898fa621
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-AR.patch b/app-editors/hteditor/files/hteditor-2.1.0-AR.patch
deleted file mode 100644
index 60a0427a2125..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-AR.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/722040
---- a/configure.ac
-+++ b/configure.ac
-@@ -104,8 +104,8 @@ AC_PROG_CPP
- AC_PROG_CXX
- AC_PROG_YACC
- AM_PROG_LEX
--AC_PATH_PROG(AR, ar)
--AC_PATH_PROG(AR, gar)
-+AC_CHECK_TOOL(AR, ar)
-+AC_CHECK_TOOL(AR, gar)
-
- if test "x$AR" = "x"; then
- AC_MSG_ERROR([*** 'ar' and 'gar' missing, please install one of them or fix your \$PATH ***])
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch b/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch
deleted file mode 100644
index 408d1b9b1be3..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-https://bugs.gentoo.org/521018
-
-From 5839355d67ff822593190473a41512ca19e4280a Mon Sep 17 00:00:00 2001
-From: Anton Gladky <gladk@debian.org>
-Date: Wed, 18 Feb 2015 21:20:39 +0100
-Subject: [PATCH] Fix "format not a string" compilation failure
-
-Compilation with the flag -Werror=format-security fails with
-the message:
-
-error: format not a string literal and no format arguments
-
-This patch solves the issue.
----
- asm/x86dis.cc | 6 +++---
- htpal.cc | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/asm/x86dis.cc b/asm/x86dis.cc
-index 0830d9c..bb9028f 100644
---- a/asm/x86dis.cc
-+++ b/asm/x86dis.cc
-@@ -1218,15 +1218,15 @@ void x86dis::str_op(char *opstr, int *opstrlen, x86dis_insn *insn, x86_insn_op *
- default: {assert(0);}
- }
- if (!insn->rexprefix) {
-- sprintf(opstr, x86_regs[j][op->reg]);
-+ sprintf(opstr, "%s", x86_regs[j][op->reg]);
- } else {
-- sprintf(opstr, x86_64regs[j][op->reg]);
-+ sprintf(opstr, "%s", x86_64regs[j][op->reg]);
- }
- break;
- }
- case X86_OPTYPE_SEG:
- if (x86_segs[op->seg]) {
-- sprintf(opstr, x86_segs[op->seg]);
-+ sprintf(opstr, "%s", x86_segs[op->seg]);
- }
- break;
- case X86_OPTYPE_CRX:
-diff --git a/htpal.cc b/htpal.cc
-index 03dea18..3d5f51e 100644
---- a/htpal.cc
-+++ b/htpal.cc
-@@ -307,7 +307,7 @@ void palette_entry::strvalue(char *buf32bytes)
- text = "normal";
- }
- p = tag_make_color(p, 32, VCP(fg, bg));
-- p += sprintf(p, text);
-+ p += sprintf(p, "%s", text);
- p = tag_make_default_color(p, 32);
- *p = 0;
- }
---
-2.16.2
-
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch
deleted file mode 100644
index 3516efd2871b..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Backport a subset of upstream c++11 fixes.
---- a/htmacho.cc
-+++ b/htmacho.cc
-@@ -146,7 +146,7 @@ void ht_macho::init(Bounds *b, File *f, format_viewer_if **ifs, ht_format_group
- break;
- case MACHO_CPU_TYPE_I386:
- switch (c->flavor) {
-- case -1:
-+ default:
- createHostStruct(&c->state, MACHO_I386_THREAD_STATE_struct, image_endianess);
- break;
- }
---- a/htmachohd.cc
-+++ b/htmachohd.cc
-@@ -313,7 +313,7 @@ static ht_view *htmachoheader_init(Bounds *b, File *file, ht_format_group *group
- switch (macho_shared->header.cputype) {
- case MACHO_CPU_TYPE_I386:
- switch (c->flavor) {
-- case -1:
-+ default:
- m->add_staticmask_ptable(macho_i386_thread_state, ofs+4*4/*4 32bit words in thread_header*/, isbigendian);
- break;
- }
---- a/io/types.h
-+++ b/io/types.h
-@@ -87,8 +87,8 @@ union htmsg_param {
- };
-
- struct htmsg {
-- int msg;
-- int type;
-+ unsigned int msg;
-+ unsigned int type;
- htmsg_param data1;
- htmsg_param data2;
- };
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch
deleted file mode 100644
index ebcc3c0aa43e..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=620732
-
-Fixes build failure on gcc-7:
-
- htapp.cc: In function 'uint isqr(uint)':
- htapp.cc:3026:18: error: call of overloaded 'abs(uint)' is ambiguous
- while (abs(a - b) > 1) {
- ^
-
-Picked upstream patch that fixes it:
-
-commit 3b62f2f7e49e024ec9d3c5ffc8ff9cd87a107af6
-Author: Sebastian Biallas <sb@biallas.net>
-Date: Sun Nov 13 15:25:26 2016 +0100
-
- use unsigned variables
-
-diff --git a/htapp.cc b/htapp.cc
-index 53d8725..03236e2 100644
---- a/htapp.cc
-+++ b/htapp.cc
-@@ -3021,8 +3021,8 @@ void do_modal_resize()
-
- static uint isqr(uint u)
- {
-- uint a = 2;
-- uint b = u/a;
-+ int a = 2;
-+ int b = u/a;
- while (abs(a - b) > 1) {
- a = (a+b)/2;
- b = u/a;
diff --git a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild b/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
deleted file mode 100644
index 1660e108bde7..000000000000
--- a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic toolchain-funcs
-
-MY_P=${P/editor}
-
-DESCRIPTION="A file viewer, editor and analyzer for text, binary, and executable files"
-HOMEPAGE="http://hte.sourceforge.net/ https://github.com/sebastianbiallas/ht/"
-SRC_URI="mirror://sourceforge/hte/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="X"
-
-RDEPEND="sys-libs/ncurses:0=
- X? ( x11-libs/libX11 )
- >=dev-libs/lzo-2"
-DEPEND="${RDEPEND}
- virtual/yacc
- sys-devel/flex"
-
-DOCS=( AUTHORS ChangeLog KNOWNBUGS README TODO )
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-7.patch
- "${FILESDIR}"/${P}-tinfo.patch
- "${FILESDIR}"/${P}-gcc-6-uchar.patch
- "${FILESDIR}"/${P}-format-security.patch
- "${FILESDIR}"/${P}-gcc-10.patch
- "${FILESDIR}"/${P}-AR.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-
- # Many literals are concatenated with macro definitions.
- # Instead of patching them all let's pick old c++ standard
- # and port to c++11 upstream.
- # https://bugs.gentoo.org/729252
- append-cxxflags -std=c++98
-}
-
-src_configure() {
- econf \
- $(use_enable X x11-textmode) \
- --enable-maintainermode
-}
-
-src_install() {
- #For prefix
- chmod u+x "${S}/install-sh"
-
- local HTML_DOCS="doc/*.html"
- doinfo doc/*.info
-
- default
-}
diff --git a/app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild b/app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild
index cd12cdc54f1e..7c8fd69aa594 100644
--- a/app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild
+++ b/app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_P=${P/editor}
-DESCRIPTION="A file viewer, editor and analyzer for text, binary, and executable files"
-HOMEPAGE="http://hte.sourceforge.net/ https://github.com/sebastianbiallas/ht/"
-#SRC_URI="mirror://sourceforge/hte/${MY_P}.tar.bz2"
+DESCRIPTION="File viewer, editor and analyzer for text, binary, and executable files"
+HOMEPAGE="https://hte.sourceforge.net/ https://github.com/sebastianbiallas/ht/"
+#SRC_URI="https://downloads.sourceforge.net/hte/${MY_P}.tar.bz2"
# tarball is done as: 'make dist' and then rename to mention latest commt
-SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${MY_P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ppc ppc64 ~riscv x86"
IUSE="X"
RDEPEND="sys-libs/ncurses:0=
X? ( x11-libs/libX11 )
>=dev-libs/lzo-2"
DEPEND="${RDEPEND}
- virtual/yacc
- sys-devel/flex"
+ app-alternatives/yacc
+ app-alternatives/lex"
DOCS=( AUTHORS ChangeLog KNOWNBUGS README TODO )
diff --git a/app-editors/hteditor/metadata.xml b/app-editors/hteditor/metadata.xml
index ec0e241f14ae..3f845187fef1 100644
--- a/app-editors/hteditor/metadata.xml
+++ b/app-editors/hteditor/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>slyfox@gentoo.org</email>
- <name>Sergei Trofimovich</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="sourceforge">hte</remote-id>
<bugs-to>https://github.com/sebastianbiallas/ht/issues</bugs-to>