summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/jasspa-microemacs')
-rw-r--r--app-editors/jasspa-microemacs/files/20091011-cc-detect.patch32
-rw-r--r--app-editors/jasspa-microemacs/files/20091011-glibc-2.32.patch57
-rw-r--r--app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r4.ebuild (renamed from app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r3.ebuild)29
-rw-r--r--app-editors/jasspa-microemacs/metadata.xml2
4 files changed, 106 insertions, 14 deletions
diff --git a/app-editors/jasspa-microemacs/files/20091011-cc-detect.patch b/app-editors/jasspa-microemacs/files/20091011-cc-detect.patch
new file mode 100644
index 000000000000..123d78c895ff
--- /dev/null
+++ b/app-editors/jasspa-microemacs/files/20091011-cc-detect.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/729258
+
+--- me091011-orig/src/build
++++ me091011/src/build
+@@ -158,12 +158,8 @@
+ exit 1
+ fi
+
+- # use cc by default if available
+ if [ -r $MAKEBAS.mak ] ; then
+- # try to detect cc, if found use it in preference
+- if [ "`type cc | cut -b 1-5`" = "cc is" ] ; then
+- MAKEFILE=$MAKEBAS.mak
+- fi
++ MAKEFILE=$MAKEBAS.mak
+ # Special rules for sun, if cc is /usr/ucb then this is a dummy.
+ if [ $PLATFORM = "SunOS" ] ; then
+ WHATCC=`/usr/bin/which cc`
+@@ -173,12 +169,8 @@
+ fi
+ fi
+ if [ -z "$MAKEFILE" ] ; then
+- # failed to find cc, try gcc
+ if [ -r $MAKEBAS.gmk ] ; then
+- # try to detect gcc, if found use it in preference
+- if [ "`type gcc | cut -b 1-6`" = "gcc is" ] ; then
+- MAKEFILE=$MAKEBAS.gmk
+- fi
++ MAKEFILE=$MAKEBAS.gmk
+ fi
+ fi
+ if [ -z "$MAKEFILE" ] ; then
diff --git a/app-editors/jasspa-microemacs/files/20091011-glibc-2.32.patch b/app-editors/jasspa-microemacs/files/20091011-glibc-2.32.patch
new file mode 100644
index 000000000000..7e2f57c934bf
--- /dev/null
+++ b/app-editors/jasspa-microemacs/files/20091011-glibc-2.32.patch
@@ -0,0 +1,57 @@
+Fix compilation with glibc-2.32.
+
+--- me091011-orig/src/file.c
++++ me091011/src/file.c
+@@ -1325,7 +1325,7 @@
+ )
+ {
+ /* READ ONLY DIR */
+- mlwrite(MWPAUSE,(meUByte *)"%s: %s", dirbuf, sys_errlist[errno]);
++ mlwrite(MWPAUSE,(meUByte *)"%s: %s", dirbuf, strerror(errno));
+ /* Zap the filename - it is invalid.
+ We only want a buffer */
+ mlwrite (0,(meUByte *)"[New buffer %s]", getFileBaseName(fname));
+@@ -1355,7 +1355,7 @@
+ {
+ /* We are not allowed to read the file */
+ #if ((defined _UNIX) || (defined _DOS))
+- mlwrite(MWABORT,(meUByte *)"[%s: %s]", fn, sys_errlist[errno]) ;
++ mlwrite(MWABORT,(meUByte *)"[%s: %s]", fn, strerror(errno)) ;
+ #else
+ mlwrite(MWABORT,"[cannot read: %s]", fn) ;
+ #endif
+--- me091011-orig/src/fileio.c
++++ me091011/src/fileio.c
+@@ -2331,7 +2331,7 @@
+ if(meRename(filename,filename2) && (ffFileOp(filename,filename2,meRWFLAG_DELETE,-1) <= 0))
+ {
+ mlwrite(MWABORT|MWPAUSE,(meUByte *)"[Unable to backup file to %s (%d - %s)]",
+- filename2,errno,sys_errlist[errno]) ;
++ filename2,errno,strerror(errno)) ;
+ if(meUnlink(filename))
+ {
+ mlwrite(MWABORT|MWPAUSE,(meUByte *)"[Unable to remove backup file %s]", filename) ;
+@@ -2346,7 +2346,7 @@
+ mlwrite(MWABORT|MWPAUSE,(meUByte *)"[Unable to remove backup file %s]", filename) ;
+ else if(meRename(filenameOld,filename) && (ffFileOp(filenameOld,filename,meRWFLAG_DELETE,-1) <= 0))
+ mlwrite(MWABORT|MWPAUSE,(meUByte *)"[Unable to backup file to %s (%d - %s)]",
+- filename,errno,sys_errlist[errno]) ;
++ filename,errno,strerror(errno)) ;
+ else if(bp != NULL)
+ {
+ meUShort ss;
+--- me091011-orig/src/spawn.c
++++ me091011/src/spawn.c
+@@ -219,10 +219,10 @@
+ case 0:
+ /* we want the children to die on interrupt */
+ execlp("xterm", "xterm", "-sl", "200", "-sb", NULL);
+- mlwrite(MWABORT,(meUByte *)"exec failed, %s", sys_errlist[errno]);
++ mlwrite(MWABORT,(meUByte *)"exec failed, %s", strerror(errno));
+ meExit(127);
+ case -1:
+- ss = mlwrite(MWABORT,(meUByte *)"exec failed, %s", sys_errlist[errno]);
++ ss = mlwrite(MWABORT,(meUByte *)"exec failed, %s", strerror(errno));
+ default:
+ ss = meTRUE ;
+ }
diff --git a/app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r3.ebuild b/app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r4.ebuild
index 27f5e8a43037..8cfbe0462f16 100644
--- a/app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r3.ebuild
+++ b/app-editors/jasspa-microemacs/jasspa-microemacs-20091011-r4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit desktop toolchain-funcs xdg-utils
@@ -13,30 +13,33 @@ SRC_URI="http://www.jasspa.com/release_20090909/jasspa-mesrc-${PV}.tar.gz
http://www.jasspa.com/release_20090909/jasspa-memacros-${MACROS_PV}.tar.gz
http://www.jasspa.com/release_20090909/jasspa-mehtml-${PV}.tar.gz
http://www.jasspa.com/release_20060909/meicons-extra.tar.gz )"
+S="${WORKDIR}/me${PV:2}"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="nanoemacs X xpm"
+KEYWORDS="amd64 ppc ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="gui nanoemacs xpm"
RDEPEND="sys-libs/ncurses:0=
- X? (
+ gui? (
x11-libs/libX11
xpm? ( x11-libs/libXpm )
)
nanoemacs? ( !app-editors/ne )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- X? (
+ gui? (
x11-base/xorg-proto
x11-libs/libXt
)"
-S="${WORKDIR}/me${PV:2}"
+BDEPEND="virtual/pkgconfig"
+
PATCHES=(
"${FILESDIR}"/${PV}-ncurses.patch
"${FILESDIR}"/${PV}-linux3.patch
+ "${FILESDIR}"/${PV}-cc-detect.patch
+ "${FILESDIR}"/${PV}-glibc-2.32.patch
)
src_unpack() {
@@ -61,7 +64,7 @@ src_compile() {
local pkgdatadir="${EPREFIX}/usr/share/jasspa"
local me="" type=c
use nanoemacs && me="-ne"
- use X && type=cw
+ use gui && type=cw
use xpm || export XPM_INCLUDE=. # prevent Xpm autodetection
cd src || die
@@ -76,23 +79,23 @@ src_compile() {
src_install() {
local me=me type=c
use nanoemacs && me=ne
- use X && type=cw
+ use gui && type=cw
newbin src/${me}${type} ${me}
if ! use nanoemacs; then
keepdir /usr/share/jasspa/site
insinto /usr/share
doins -r "${WORKDIR}"/jasspa
- use X && domenu "${FILESDIR}"/${PN}.desktop
+ use gui && domenu "${FILESDIR}"/${PN}.desktop
fi
dodoc faq.txt readme.txt change.log
}
pkg_postinst() {
- use X && xdg_desktop_database_update
+ use gui && xdg_desktop_database_update
}
pkg_postrm() {
- use X && xdg_desktop_database_update
+ use gui && xdg_desktop_database_update
}
diff --git a/app-editors/jasspa-microemacs/metadata.xml b/app-editors/jasspa-microemacs/metadata.xml
index ab5b22e79f36..1a02f2a6e7d7 100644
--- a/app-editors/jasspa-microemacs/metadata.xml
+++ b/app-editors/jasspa-microemacs/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>emacs@gentoo.org</email>