summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/jove')
-rw-r--r--app-editors/jove/Manifest1
-rw-r--r--app-editors/jove/files/jove-4.16.0.70.3.1-getline.patch81
-rw-r--r--app-editors/jove/files/jove-4.16.0.73-build.patch188
-rw-r--r--app-editors/jove/files/jove-4.16.0.73-doc.patch34
-rw-r--r--app-editors/jove/files/jove-4.16.0.73-sendmail.patch19
-rw-r--r--app-editors/jove/jove-4.16.0.73-r1.ebuild51
6 files changed, 0 insertions, 374 deletions
diff --git a/app-editors/jove/Manifest b/app-editors/jove/Manifest
index 8829818bbfd3..8ee24206e392 100644
--- a/app-editors/jove/Manifest
+++ b/app-editors/jove/Manifest
@@ -1,3 +1,2 @@
DIST jove-4.17.3.7.tar.gz 490070 BLAKE2B bfe95cc8f78993438839b93ebf37567940449e3914dd1963728ee82dc601c371318a34ea0d5d13d9d4dccaf9c4750874c5e0d3af22dcb2421595dca2da7cafdf SHA512 90bd597bb4be3a4589f77ee331cee4fa2784264221fe6247c2535ae34c5689c08f55c2b2919bff34af5631b73b12883dab54df9770b4157ae801079a23222d9a
DIST jove-4.17.5.3.tar.gz 548835 BLAKE2B 12b1f16d82e84cc2d099e2f45f5a42e2d1e811e5a9685c7ee162280ef49ecef8f7955a98679b60c49bbeaa30e3a430b1d6fc969270bee02862ff284a932829d9 SHA512 f91bdf3145ad243cfe8a4d9aca497a3d2cc58711488fa6b845d0d5e70dece6939046743aae1f18fd2614d75420bb747b00e61bb60b13ff35b26409068df40127
-DIST jove4.16.0.73.tgz 465214 BLAKE2B cc1eeca2cdbd7ca98a5deaf27c37bfcdc529f2b388361e0cd5fd6278b72740a06283abd1f60212e6dc0d1e540e4dc4d99edb99b781645b13e1675644db0f38eb SHA512 2198504f9a23590710acba7f27661fa5649fdbed559a4c6bde9d2c1d673c22ce7d99a690be45a4602d37cf6e70399230c4ae3a251d8451af0c5252bdca61b09d
diff --git a/app-editors/jove/files/jove-4.16.0.70.3.1-getline.patch b/app-editors/jove/files/jove-4.16.0.70.3.1-getline.patch
deleted file mode 100644
index 98cef6011f8c..000000000000
--- a/app-editors/jove/files/jove-4.16.0.70.3.1-getline.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-http://bugs.gentoo.org/274352
-Fix build failure with glibc-2.10
-
---- jove4.16.0.70-orig/insert.c
-+++ jove4.16.0.70/insert.c
-@@ -504,7 +504,7 @@
- atchar = 0;
- }
-
-- getline(atline->l_dline, genbuf);
-+ get_line(atline->l_dline, genbuf);
- atchar += tchar;
- linecopy(genbuf, atchar, save);
- atline->l_dline = putline(genbuf);
---- jove4.16.0.70-orig/io.c
-+++ jove4.16.0.70/io.c
-@@ -1347,9 +1347,9 @@
-
- void
- #ifdef USE_PROTOTYPES
--getline proto((daddr addr, register char *buf))
-+get_line proto((daddr addr, register char *buf))
- #else
--getline(addr, buf)
-+get_line(addr, buf)
- daddr addr;
- register char *buf;
- #endif
---- jove4.16.0.70-orig/io.h
-+++ jove4.16.0.70/io.h
-@@ -40,7 +40,7 @@
- close_file proto((File *fp)),
- d_cache_init proto((void)),
- file_write proto((char *fname, bool app)),
-- getline proto((daddr addr, char *buf)),
-+ get_line proto((daddr addr, char *buf)),
- lsave proto((void)),
- putreg proto((File *fp,LinePtr line1,int char1,LinePtr line2,int char2,bool makesure)),
- read_file proto((char *file, bool is_insert)),
---- jove4.16.0.70-orig/recover.c
-+++ jove4.16.0.70/recover.c
-@@ -165,7 +165,7 @@
- private char *getblock proto((daddr atl));
-
- void
--getline(tl, buf)
-+get_line(tl, buf)
- daddr tl;
- char *buf;
- {
-@@ -580,7 +580,7 @@
- Nchars = Nlines = 0L;
- while (--nlines >= 0) {
- addr = getaddr(ptrs_fp);
-- getline(addr, buf);
-+ get_line(addr, buf);
- Nlines += 1;
- Nchars += 1 + strlen(buf);
- fputs(buf, out);
---- jove4.16.0.70-orig/util.c
-+++ jove4.16.0.70/util.c
-@@ -280,7 +280,7 @@
- strcpy(buf, linebuf);
- Jr_Len = strlen(linebuf);
- } else
-- getline(line->l_dline, buf);
-+ get_line(line->l_dline, buf);
- return buf;
- }
-
---- jove4.16.0.70-orig/util.h
-+++ jove4.16.0.70/util.h
-@@ -18,7 +18,7 @@
- #define eobp() (lastp(curline) && eolp())
- #define eolp() (linebuf[curchar] == '\0')
- #define firstp(line) ((line) == curbuf->b_first)
--#define getDOT() getline(curline->l_dline, linebuf)
-+#define getDOT() get_line(curline->l_dline, linebuf)
- #define lastp(line) ((line) == curbuf->b_last)
-
- extern UnivPtr
diff --git a/app-editors/jove/files/jove-4.16.0.73-build.patch b/app-editors/jove/files/jove-4.16.0.73-build.patch
deleted file mode 100644
index 105d163d32be..000000000000
--- a/app-editors/jove/files/jove-4.16.0.73-build.patch
+++ /dev/null
@@ -1,188 +0,0 @@
-Originally based on Debian patch jove_4.16.0.70-3.1.diff.gz
-
---- jove4.16.0.73-orig/doc/jove.rc
-+++ jove4.16.0.73/doc/jove.rc
-@@ -74,6 +74,6 @@
- 1 source jove.rc.$TERM
-
- # source local custom rc file, if present
--1 source jove-local.rc
-+1 source /etc/jove/jove-local.rc
-
- popd
---- jove4.16.0.73-orig/jove.c
-+++ jove4.16.0.73/jove.c
-@@ -1576,7 +1576,7 @@
- char Joverc[FILESIZE];
-
- if (dosys) {
-- PathCat(Joverc, sizeof(Joverc), ShareDir, "jove.rc");
-+ PathCat(Joverc, sizeof(Joverc), CONFIGDIR, "jove.rc");
- (void) joverc(Joverc); /* system wide jove.rc */
- }
-
---- jove4.16.0.73-orig/Makefile
-+++ jove4.16.0.73/Makefile
-@@ -21,13 +21,14 @@
- # If they don't exist, this makefile will try to create the directories
- # LIBDIR and SHAREDIR. All others must already exist.
-
--JOVEHOME = /usr/local
--SHAREDIR = $(JOVEHOME)/lib/jove
-+JOVEHOME = ${DESTDIR}/usr
-+SHAREDIR = $(JOVEHOME)/share/jove
- LIBDIR = $(JOVEHOME)/lib/jove
- BINDIR = $(JOVEHOME)/bin
- XEXT=
--MANDIR = $(JOVEHOME)/man/man$(MANEXT)
-+MANDIR = $(JOVEHOME)/share/man/man$(MANEXT)
- MANEXT = 1
-+CONFIGDIR=${DESTDIR}/etc/jove
-
- # TMPDIR is where the tmp files get stored, usually /tmp, /var/tmp, or
- # /usr/tmp. If you wish to be able to recover buffers after a system
-@@ -38,11 +39,11 @@
- # (in case the system startup salvages tempfiles by moving them,
- # which is probably a good idea).
-
--TMPDIR = /tmp
--RECDIR = /var/preserve
-+TMPDIR = /var/tmp
-+RECDIR = ${DESTDIR}/var/lib/jove/preserve
-
- # DFLTSHELL is the default shell invoked by JOVE and TEACHJOVE.
--DFLTSHELL = /bin/csh
-+DFLTSHELL = /bin/sh
-
- # The install commands of BSD and System V differ in unpleasant ways:
- # -c: copy (BSD); -c dir: destination directory (SysV)
-@@ -56,15 +57,18 @@
- INSTALLFLAGS = # -g bin -o root
-
- # to install executable files
--XINSTALL=cp
-+XINSTALL=install -m 755
- #XINSTALL=/usr/ucb/install $(INSTALLFLAGS) -c -m 755 # -s
- #CYGWIN32: XINSTALL=install $(INSTALLFLAGS) -c -m 755
-
- # to install text files
--TINSTALL=cp
-+TINSTALL=install -m 644
- #TINSTALL=/usr/ucb/install $(INSTALLFLAGS) -c -m 644
- #CYGWIN32: TINSTALL=install $(INSTALLFLAGS) -c -m 644
-
-+# to install directories
-+DINSTALL=install -d 755
-+
- # These should all just be right if the above ones are.
- # You will confuse JOVE if you move anything from LIBDIR or SHAREDIR.
-
-@@ -72,7 +76,7 @@
- TEACHJOVE = $(BINDIR)/teachjove$(XEXT)
- RECOVER = $(LIBDIR)/recover$(XEXT)
- PORTSRV = $(LIBDIR)/portsrv$(XEXT)
--JOVERC = $(SHAREDIR)/jove.rc
-+JOVERC = $(CONFIGDIR)/jove.rc
- TERMSDIR = $(SHAREDIR)
- CMDS.DOC = $(SHAREDIR)/cmds.doc
- TEACH-JOVE = $(SHAREDIR)/teach-jove
-@@ -160,7 +164,7 @@
- # SCO UNIX: TERMCAPLIB = -lcurses
- # AIX on the R6000s: TERMCAPLIB = -lcurses -ltermcap -ls
-
--TERMCAPLIB = -ltermcap
-+TERMCAPLIB = -lncurses
-
- # Extra libraries flags needed by oddball systems.
- # Modern BSD systems using openpty need its library.
-@@ -181,7 +185,7 @@
- # PDP-11 with separate I&D: -i
- # PDP-11 without separate I&D: -n
-
--LDFLAGS =
-+#LDFLAGS =
-
- # for SCO Xenix, set
- # MEMFLAGS = -Mle
-@@ -236,7 +240,8 @@
- TROFF = troff -Tpost
- TROFFPOST = | /usr/lib/lp/postscript/dpost -
-
--MANUALS = $(JOVEM) $(TEACHJOVEM) $(XJOVEM) $(JOVETOOLM)
-+MANUALS = $(JOVEM) $(TEACHJOVEM)
-+# $(XJOVEM) $(JOVETOOLM)
-
- C_SRC = commands.c commands.tab abbrev.c argcount.c ask.c buf.c c.c case.c jctype.c \
- delete.c disp.c extend.c fp.c fmt.c insert.c io.c iproc.c \
-@@ -283,8 +288,7 @@
- # all: default target.
- # Builds everything that "install" needs.
- all: jjove$(XEXT) recover$(XEXT) teachjove$(XEXT) portsrv$(XEXT) \
-- doc/cmds.doc doc/jove.$(MANEXT) doc/teachjove.$(MANEXT) \
-- doc/jovetool.$(MANEXT)
-+ doc/cmds.doc doc/jove.$(MANEXT) doc/teachjove.$(MANEXT)
-
- jjove$(XEXT): $(OBJECTS)
- $(LDCC) $(LDFLAGS) $(OPTFLAGS) -o jjove$(XEXT) $(OBJECTS) $(TERMCAPLIB) $(EXTRALIBS)
-@@ -341,6 +345,7 @@
- @echo \#define LIBDIR \"$(LIBDIR)\" >> paths.h
- @echo \#define SHAREDIR \"$(SHAREDIR)\" >> paths.h
- @echo \#define DFLTSHELL \"$(DFLTSHELL)\" >> paths.h
-+ @echo \#define CONFIGDIR \"$(CONFIGDIR)\" >> paths.h
-
- makexjove:
- ( cd xjove ; make CC="$(CC)" OPTFLAGS="$(OPTFLAGS)" SYSDEFS="$(SYSDEFS)" $(TOOLMAKEEXTRAS) xjove )
-@@ -358,18 +363,31 @@
- # Thus, if "all" is done first, "install" can be invoked with
- # JOVEHOME pointing at a playpen where files are to be marshalled.
- # This property is fragile.
--install: $(LIBDIR) $(SHAREDIR) \
-+install: $(BINDIR) $(LIBDIR) $(SHAREDIR) $(CONFIGDIR) $(RECDIR) \
- $(TEACH-JOVE) $(CMDS.DOC) $(TERMSDIR)docs \
- $(PORTSRVINST) $(RECOVER) $(JOVE) $(TEACHJOVE) $(MANUALS)
-- $(TINSTALL) doc/jove.rc $(JOVERC)
-+ $(TINSTALL) doc/jove.rc $(CONFIGDIR)
- @echo See the README about changes to /etc/rc or /etc/rc.local
- @echo so that the system recovers jove files on reboot after a crash
-
-+$(BINDIR)::
-+ $(DINSTALL) $(BINDIR)
-+
- $(LIBDIR)::
-- test -d $(LIBDIR) || mkdir -p $(LIBDIR)
-+ $(DINSTALL) $(LIBDIR)
-
- $(SHAREDIR)::
-- test -d $(SHAREDIR) || mkdir -p $(SHAREDIR)
-+ $(DINSTALL) $(SHAREDIR)
-+
-+$(CONFIGDIR)::
-+ $(DINSTALL) $(CONFIGDIR)
-+
-+$(RECDIR)::
-+ $(DINSTALL) $(RECDIR)
-+ chmod 1777 $(RECDIR)
-+
-+$(MANDIR)::
-+ $(DINSTALL) $(MANDIR)
-
- $(TEACH-JOVE): doc/teach-jove
- $(TINSTALL) doc/teach-jove $(TEACH-JOVE)
-@@ -410,7 +428,7 @@
- -e 's;<SHAREDIR>;$(SHAREDIR);' \
- -e 's;<SHELL>;$(DFLTSHELL);' doc/jove.nr > doc/jove.$(MANEXT)
-
--$(JOVEM): doc/jove.$(MANEXT)
-+$(JOVEM): $(MANDIR) doc/jove.$(MANEXT)
- $(TINSTALL) doc/jove.$(MANEXT) $(JOVEM)
-
- # doc/jove.doc is the formatted manpage (only needed by DOS)
-@@ -427,7 +445,7 @@
- -e 's;<SHAREDIR>;$(SHAREDIR);' \
- -e 's;<SHELL>;$(DFLTSHELL);' doc/teachjove.nr > doc/teachjove.$(MANEXT)
-
--$(TEACHJOVEM): doc/teachjove.$(MANEXT)
-+$(TEACHJOVEM): $(MANDIR) doc/teachjove.$(MANEXT)
- $(TINSTALL) doc/teachjove.$(MANEXT) $(TEACHJOVEM)
-
- $(XJOVEM): doc/xjove.nr
diff --git a/app-editors/jove/files/jove-4.16.0.73-doc.patch b/app-editors/jove/files/jove-4.16.0.73-doc.patch
deleted file mode 100644
index d62add543af6..000000000000
--- a/app-editors/jove/files/jove-4.16.0.73-doc.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Originally based on Debian patch jove_4.16.0.70-3.1.diff.gz
-
---- jove4.16.0.73-orig/doc/intro.nr
-+++ jove4.16.0.73/doc/intro.nr
-@@ -56,9 +56,8 @@
- ..
- .
- .\" Change the extra vertical spacing around .DS/.DE
--.\" Does not work with groff's version of MS (GS is 1 iff groff MS)
--.if !\n(GS .if n .nr DD 0v
--.if !\n(GS .if t .nr DD \n(PD/2u
-+.if n .nr DD 0v
-+.if t .nr DD \n(PD/2u
- .
- .nr LL 6.5i
- .nr LT 6.5i
-@@ -152,7 +151,7 @@
- }
-
- _
--\fBJOVE\ (C OvrWt)\ \ \ [Main:1]\ \ "hello.c"\ \ \(**\ \ /home/foo\fP <\ the Mode Line
-+\fBJOVE\ (C OvrWt)\ \ \ [Main:1]\ \ "hello.c"\ \ \(**\ \ /home/foo\ \ \ \ 15:23\fP <\ the Mode Line
- _
- : write-file (default hello.c) aloha.c\^\(sq <\ the Message Line
- =
-@@ -1978,7 +1977,7 @@
- \ \ \ \ return 0; <\ second Window
- }\^\(sq
- _
--\fBJOVE\ (C OvrWt)\ \ \ [Main:1]\ \ "aloha.c"\ \ \-\-\ \ /home/foo\fP <\ the Mode Line
-+\fBJOVE\ (C OvrWt)\ \ \ [Main:1]\ \ "aloha.c"\ \ \-\-\ \ /home/foo\ \ \ \ 15:28\fP <\ the Mode Line
- _
- [Point pushed] <\ the Message Line
- =
diff --git a/app-editors/jove/files/jove-4.16.0.73-sendmail.patch b/app-editors/jove/files/jove-4.16.0.73-sendmail.patch
deleted file mode 100644
index 072dd1f843ce..000000000000
--- a/app-editors/jove/files/jove-4.16.0.73-sendmail.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- jove4.16.0.73-orig/recover.c
-+++ jove4.16.0.73/recover.c
-@@ -776,7 +776,7 @@
-
- last_update = ctime(&(rec->UpdTime));
- /* Start up mail */
-- sprintf(mail_cmd, "/bin/mail %s", pw->pw_name);
-+ sprintf(mail_cmd, "/usr/sbin/sendmail -t %s", pw->pw_name);
- setuid(getuid());
- if ((mail_pipe = popen(mail_cmd, "w")) == NULL)
- return;
-@@ -784,6 +784,7 @@
- setbuf(mail_pipe, mail_cmd);
- /* Let's be grammatically correct! */
- buf_string = rec->Nbuffers == 1? "buffer" : "buffers";
-+ fprintf(mail_pipe, "To: %s\n", pw->pw_name);
- fprintf(mail_pipe, "Subject: Jove saved %d %s after \"%s\" crashed\n",
- rec->Nbuffers, buf_string, hname());
- fprintf(mail_pipe, " \n");
diff --git a/app-editors/jove/jove-4.16.0.73-r1.ebuild b/app-editors/jove/jove-4.16.0.73-r1.ebuild
deleted file mode 100644
index c6f1bdcef2e3..000000000000
--- a/app-editors/jove/jove-4.16.0.73-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Jonathan's Own Version of Emacs, a light emacs-like editor without LISP bindings"
-HOMEPAGE="ftp://ftp.cs.toronto.edu/cs/ftp/pub/hugh/jove-dev/"
-SRC_URI="ftp://ftp.cs.toronto.edu/cs/ftp/pub/hugh/jove-dev/${PN}${PV}.tgz"
-
-LICENSE="JOVE"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="doc"
-
-RDEPEND="sys-libs/ncurses:0="
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}${PV}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.16.0.70.3.1-getline.patch
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${P}-sendmail.patch
- "${FILESDIR}"/${P}-doc.patch
-)
-
-src_compile() {
- tc-export CC
-
- emake OPTFLAGS="${CFLAGS}" \
- SYSDEFS="-DSYSVR4 -D_XOPEN_SOURCE=500 -D_XOPEN_STREAMS=-1" \
- TERMCAPLIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
-
- if use doc; then
- # Full manual (*not* man page)
- emake doc/jove.man
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- keepdir /var/lib/jove/preserve
-
- dodoc README
- if use doc; then
- dodoc doc/jove.man
- fi
-}