summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/jupp')
-rw-r--r--app-editors/jupp/Manifest1
-rw-r--r--app-editors/jupp/jupp-3.1_p38.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-editors/jupp/Manifest b/app-editors/jupp/Manifest
index a0550eda72f2..b64114a80130 100644
--- a/app-editors/jupp/Manifest
+++ b/app-editors/jupp/Manifest
@@ -1 +1,2 @@
DIST joe-3.1jupp30.tgz 468421 BLAKE2B 630ef1cd3f3c73060b331126ec8e6a24d7277b3f2bfb293eb6110d1dade34ffe6efc502d0985e603b2c86a10bf27faa6151e28b777189332b805e387b756dea6 SHA512 673d48da41f61797d6aeb548e62720d1a60e3e000445558be88fb0d7ca8a1a7ce7c8bdd5b5bd58ac2c16d46dd4541da7922999256669f693a570a11562d6550f
+DIST joe-3.1jupp38.tgz 498068 BLAKE2B 46909c5f0f14b1d0ec30219b8ddfe9c0ad76b726f7178f7527ad5fad0cec40b7ac663e93645187220280572fa3bbde9bcb621f8816672e69c36587410fd98c7f SHA512 1d21ee5bbd1a042c58a89dd2bed8ec711c59fc383ff0dfd94d3a0eaccb999734915abc202e2112c5d573d8073e748b8024cd710b21803fed7422f5a8bccbc0c5
diff --git a/app-editors/jupp/jupp-3.1_p38.ebuild b/app-editors/jupp/jupp-3.1_p38.ebuild
new file mode 100644
index 000000000000..d8bdab27bf57
--- /dev/null
+++ b/app-editors/jupp/jupp-3.1_p38.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Portable version of Joe's Own Editor"
+HOMEPAGE="https://www.mirbsd.org/jupp.htm"
+SRC_URI="https://www.mirbsd.org/MirOS/dist/${PN}/joe-${PV/_p/${PN}}.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses"
+
+RDEPEND="ncurses? ( sys-libs/ncurses:0= )
+ !app-editors/joe"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+DOCS="HINTS INFO LIST NEWS README TODO"
+
+src_prepare() {
+ default
+ chmod +x configure || die
+}
+
+src_configure() {
+ econf \
+ --enable-search_libs \
+ --enable-termcap \
+ $(use_enable ncurses curses)
+}