summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/lpe')
-rw-r--r--app-editors/lpe/Manifest2
-rw-r--r--app-editors/lpe/files/lpe-1.2.6.13-make-382.patch23
-rw-r--r--app-editors/lpe/lpe-1.2.6.13.ebuild49
-rw-r--r--app-editors/lpe/lpe-1.2.8_p20210401.ebuild71
-rw-r--r--app-editors/lpe/metadata.xml7
5 files changed, 77 insertions, 75 deletions
diff --git a/app-editors/lpe/Manifest b/app-editors/lpe/Manifest
index 36553d794ec2..1bd43eb9570b 100644
--- a/app-editors/lpe/Manifest
+++ b/app-editors/lpe/Manifest
@@ -1 +1 @@
-DIST lpe_1.2.6.13-0.1.tar.gz 600523 BLAKE2B 8866aff63276d5e39ed48b4d9e8b9a23d541c13e196815c29586df83f8c6b5895a8dde8fb16b0929bffc49416907d74d48fdbc5ce736a855f2d2daad6472fb96 SHA512 f02769baca396285fe8f98c934f6274185d2bf8b08f3b007cbfa4e6aadb455abfb7cab13d53a3d1fa71ea0c29c4222784dcbc9a7508501c7d1839671503758ed
+DIST lpe-1.2.8_p20210401.tar.gz 840016 BLAKE2B 81fa0b1c3f9a7164eb219692a2e7bc092d0ee09c9de15f6fd2a4f66cc486be5b744eaa2fb0569a9f44f45d6a19159c55286be76d9ae0f4947f5b7c749e84a8fb SHA512 0b40f2f3fc1241e07291dfdbfcf2466cf5dedc1c91bf36c4f36c8af792ce718be2ad66884b049e25d7b9f9e796d60ce25ca42b37610d26894cd1dc6b74e51157
diff --git a/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch b/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
deleted file mode 100644
index f8d96ef087e9..000000000000
--- a/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-http://bugs.gentoo.org/335324
-
---- intl/Makefile.in
-+++ intl/Makefile.in
-@@ -202,12 +202,12 @@
- # The dependency for intlh.inst is different in gettext and all other
- # packages. Because we cannot you GNU make features we have to solve
- # the problem while rewriting Makefile.in.
--@GT_YES@intlh.inst: intlh.inst.in ../config.status
--@GT_YES@ cd .. \
--@GT_YES@ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
--@GT_YES@ $(SHELL) ./config.status
--@GT_NO@.PHONY: intlh.inst
--@GT_NO@intlh.inst:
-+intlh.inst: intlh.inst.in ../config.status
-+ cd .. \
-+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
-+ $(SHELL) ./config.status
-+.PHONY: intlh.inst
-+intlh.inst:
-
- # Tell versions [3.59,3.63) of GNU make not to export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/app-editors/lpe/lpe-1.2.6.13.ebuild b/app-editors/lpe/lpe-1.2.6.13.ebuild
deleted file mode 100644
index 463f48e14e24..000000000000
--- a/app-editors/lpe/lpe-1.2.6.13.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils ltprune multilib toolchain-funcs
-
-DESCRIPTION="a lightweight programmers editor"
-HOMEPAGE="https://packages.qa.debian.org/l/lpe.html"
-SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}-0.1.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~x86-linux"
-IUSE="nls"
-
-RDEPEND=">=sys-libs/slang-2.2.4
- >=sys-libs/ncurses-5.7-r7:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-make-382.patch
-
- # You should add PKG_CHECK_MODULES(NCURSES, ncurses) to configure.in and
- # replace -lncurses in src/Makefile.am with $(NCURSES_LIBS)
- # That is, if you need eautoreconf
- sed -i \
- -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs-only-l ncurses):" \
- src/Makefile.in || die
-}
-
-src_configure() {
- econf $(use_enable nls)
-}
-
-src_install() {
- emake \
- libdir="${ED}/usr/$(get_libdir)" \
- prefix="${ED}/usr" \
- datadir="${ED}/usr/share" \
- mandir="${ED}/usr/share/man" \
- infodir="${ED}/usr/share/info" \
- docdir="${ED}/usr/share/doc/${PF}" \
- exdir="${ED}/usr/share/doc/${PF}/examples" \
- install
-
- prune_libtool_files --all
-}
diff --git a/app-editors/lpe/lpe-1.2.8_p20210401.ebuild b/app-editors/lpe/lpe-1.2.8_p20210401.ebuild
new file mode 100644
index 000000000000..5c157e7146ee
--- /dev/null
+++ b/app-editors/lpe/lpe-1.2.8_p20210401.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+COMMIT="203c88eae66c6a3bffd050286af6d9aacf85816e"
+DESCRIPTION="A lightweight programmers editor"
+HOMEPAGE="https://packages.qa.debian.org/l/lpe.html"
+SRC_URI="https://github.com/AdamMajer/lpe/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~riscv sparc x86 ~x86-linux"
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/slang
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? (
+ sys-devel/gettext
+ virtual/libintl
+ )
+"
+
+src_prepare() {
+ default
+
+ # You should add PKG_CHECK_MODULES(NCURSES, ncurses) to configure.in and
+ # replace -lncurses in src/Makefile.am with $(NCURSES_LIBS)
+ # That is, if you need eautoreconf
+ sed -i \
+ -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs-only-l ncurses):" \
+ configure.ac || die
+
+ # Actually use what configure discovers (above)
+ # bug #779778
+ sed -i \
+ -e 's:-lncurses:@NCURSES_LIB@:' \
+ src/Makefile.am || die
+
+ # Refresh outdated libtool (elibtoolize insufficient)
+ # Fixes undefined references on macOS/Darwin
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-included-gettext \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake \
+ libdir="${ED}/usr/$(get_libdir)" \
+ prefix="${ED}/usr" \
+ datadir="${ED}/usr/share" \
+ mandir="${ED}/usr/share/man" \
+ infodir="${ED}/usr/share/info" \
+ docdir="${ED}/usr/share/doc/${PF}" \
+ exdir="${ED}/usr/share/doc/${PF}/examples" \
+ install
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-editors/lpe/metadata.xml b/app-editors/lpe/metadata.xml
index 6f49eba8f496..a62b3a23b59d 100644
--- a/app-editors/lpe/metadata.xml
+++ b/app-editors/lpe/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">AdamMajer/lpe</remote-id>
+ </upstream>
</pkgmetadata>