summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mg')
-rw-r--r--app-editors/mg/Manifest5
-rw-r--r--app-editors/mg/metadata.xml13
-rw-r--r--app-editors/mg/mg-20171014.ebuild47
-rw-r--r--app-editors/mg/mg-20220614.ebuild (renamed from app-editors/mg/mg-20200215.ebuild)17
-rw-r--r--app-editors/mg/mg-20230501.ebuild (renamed from app-editors/mg/mg-20180408.ebuild)17
5 files changed, 30 insertions, 69 deletions
diff --git a/app-editors/mg/Manifest b/app-editors/mg/Manifest
index 146459d9c677..ec6ffec6c1d8 100644
--- a/app-editors/mg/Manifest
+++ b/app-editors/mg/Manifest
@@ -1,3 +1,2 @@
-DIST mg-20171014.tar.gz 141045 BLAKE2B a5b3bda6ff3b6416093069b471762687c2279737aa05b297ccd3077aff195cf52831566768613a81dcc977a27ac5ffd6e8a1874aa1010b6d90f4c678b6825cee SHA512 d55818308421aa523fb30b6e4725bb122f37637a822fabafeba9f9da3b97fd7f6af6431fce3015c969d0e656a48e89ed49b790deefc69fbdbb7e257f8a1aeb56
-DIST mg-20180408.tar.gz 141988 BLAKE2B db7da46fb0160acf8695f05234ed0c8e9a45e4239dc3abd433ddfb8b66e2b1aa550ffc4b409486a8990881d791ed73269a8ab78f6846cd4f0bee67761c11d281 SHA512 25fceb18fcbe63010e7a2e107aa5c30356938be2e04ff48869a12b5018dbb83bcf4dc70b03674713516616037247952a51454a28ca418cdc7b020d1f415f8701
-DIST mg-20200215.tar.gz 152254 BLAKE2B 89e47aaa94fd95b9409a53b09c9017e26d3f1cc73ce616e1c29ed22fbaed42cb78e7c9fbcd2424d98f86725fb00cee5160be4fe40abc97a927201557b684f800 SHA512 c6cda5544210bc3d3fa3cbb8494e60949e10ed3716d96b76d0c9e7f5671c7a85f6e7e7a860cfd05466f1bf52112053c722441ff338210c0ada89f10515ac170a
+DIST mg-20220614.tar.gz 157904 BLAKE2B 88141274b379c6117158f85d91d0d643709437f0292fe2f82569c33d85694b39f957e279e262839ef0ba2a7e81e8a9ad6512c621e68f42b0929805028898637a SHA512 bed455cda856e54fae28592ac0a520841d5d542880a7405dadf702d7407ac33ae7fb7b63880805a7e166e0e0a87c76b9fca1700c444f1b999a5af66732c69b65
+DIST mg-20230501.tar.gz 158315 BLAKE2B b8f68d4cd80a1735ce171bf653281104f7c8b5510a45088a136955d6649e969285914d27d2ee5bd4400643507943576e3c42959949aebb81bc1bb2f99a8e660e SHA512 db7b9815a01dc9fb1ff92741748d24d558c329135e591c24450d0a3bc10e38a992ef346dd744854864538f330a018415df539d06543570a3566dbabc6c88a8fd
diff --git a/app-editors/mg/metadata.xml b/app-editors/mg/metadata.xml
index 00486d5abd44..d00cadd0ef61 100644
--- a/app-editors/mg/metadata.xml
+++ b/app-editors/mg/metadata.xml
@@ -1,12 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>emacs@gentoo.org</email>
<name>Gentoo Emacs project</name>
</maintainer>
<longdescription>
- mg is Micro GNU/emacs, this is a portable version of the mg maintained by
- the OpenBSD team.
+ Mg (mg) is intended to be a small, fast, and portable editor for
+ people who can't (or don't want to) run real Emacs for one reason
+ or another. It is compatible with GNU Emacs because there shouldn't
+ be any reason to learn more than one Emacs flavor.
+
+ This is a portable version of the Mg maintained by the OpenBSD team.
</longdescription>
+<upstream>
+ <remote-id type="github">hboetes/mg</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/app-editors/mg/mg-20171014.ebuild b/app-editors/mg/mg-20171014.ebuild
deleted file mode 100644
index 47478a302f6d..000000000000
--- a/app-editors/mg/mg-20171014.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
-HOMEPAGE="https://homepage.boetes.org/software/mg/"
-SRC_URI="https://homepage.boetes.org/software/mg/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ppc ~ppc64 sparc x86"
-IUSE="livecd"
-
-RDEPEND="sys-libs/ncurses:0
- !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- # fix path to tutorial in man page
- sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
-
- eapply_user
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_install() {
- dobin mg
- doman mg.1
- dodoc README tutorial
- # don't compress the tutorial, otherwise mg cannot open it
- docompress -x /usr/share/doc/${PF}/tutorial
-}
-
-pkg_postinst() {
- if use livecd; then
- [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
- fi
-}
diff --git a/app-editors/mg/mg-20200215.ebuild b/app-editors/mg/mg-20220614.ebuild
index 5c0a16154558..47a79e0e9dae 100644
--- a/app-editors/mg/mg-20200215.ebuild
+++ b/app-editors/mg/mg-20220614.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
-HOMEPAGE="https://homepage.boetes.org/software/mg/"
+HOMEPAGE="https://github.com/hboetes/mg"
SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~loong ppc ~ppc64 ~riscv sparc x86"
IUSE="livecd"
-RDEPEND="sys-libs/ncurses:0
- !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="
+ sys-libs/ncurses:0=
+ >=dev-libs/libbsd-0.7.0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
# fix path to tutorial in man page
diff --git a/app-editors/mg/mg-20180408.ebuild b/app-editors/mg/mg-20230501.ebuild
index 5e8bfbef1b6b..dc7838663d6b 100644
--- a/app-editors/mg/mg-20180408.ebuild
+++ b/app-editors/mg/mg-20230501.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
-HOMEPAGE="https://homepage.boetes.org/software/mg/"
+HOMEPAGE="https://github.com/hboetes/mg"
SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ppc ~ppc64 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ~ppc64 ~riscv sparc x86"
IUSE="livecd"
-RDEPEND="sys-libs/ncurses:0
- !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="
+ sys-libs/ncurses:0=
+ >=dev-libs/libbsd-0.7.0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
# fix path to tutorial in man page