summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/nedit/files/nedit-5.7-ldflags.patch')
-rw-r--r--app-editors/nedit/files/nedit-5.7-ldflags.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/app-editors/nedit/files/nedit-5.7-ldflags.patch b/app-editors/nedit/files/nedit-5.7-ldflags.patch
new file mode 100644
index 000000000000..b529d3327dd2
--- /dev/null
+++ b/app-editors/nedit/files/nedit-5.7-ldflags.patch
@@ -0,0 +1,17 @@
+--- a/source/Makefile.common 2019-01-19 14:27:14.927734607 +0100
++++ b/source/Makefile.common 2019-01-19 14:28:46.186729890 +0100
+@@ -20,12 +20,12 @@
+ # we only want natural rebuilds to regenerate the link date.
+ nedit: $(OBJS) ../util/libNUtil.a $(XMLLIB) $(XLTLIB)
+ $(CC) $(CFLAGS) -c linkdate.c -o linkdate.o
+- $(CC) $(CFLAGS) $(OBJS) linkdate.o $(XMLLIB) \
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) linkdate.o $(XMLLIB) \
+ $(XLTLIB) ../util/libNUtil.a $(LIBS) -o $@
+
+ # Note LIBS isn't quite right here; it links unnecessarily against Motif
+ nc: nc.o server_common.o ../util/libNUtil.a
+- $(CC) $(CFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
+
+ help.o: help.c
+ $(CC) $(CFLAGS) $(BIGGER_STRINGS) -c help.c -o $@