summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/okteta')
-rw-r--r--app-editors/okteta/Manifest2
-rw-r--r--app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch35
-rw-r--r--app-editors/okteta/metadata.xml5
-rw-r--r--app-editors/okteta/okteta-0.26.15.ebuild (renamed from app-editors/okteta/okteta-0.26.4.ebuild)17
4 files changed, 49 insertions, 10 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index 9e3080f15686..c962fbeda598 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1 +1 @@
-DIST okteta-0.26.4.tar.xz 969572 BLAKE2B 37f3a0c83c3a922030816813de9a66edff0f4a1ae9f3450f9fe195b52d1b053c23f37c8fb2a06b08ef8df47061123536f202809b3d4954d824103dfb1b912559 SHA512 2410fc73d2685405cef7d3d639ae202632f8781885803aed5e2e5e4ff8b48f7cdf4f8b9565edbc1b5fa3db4bb22ae90019f8cfdf4bda09def7badc559ebe02a7
+DIST okteta-0.26.15.tar.xz 1090764 BLAKE2B 3e96aca3bc1ec1aceb22de23f7aa954c7a41b1b074207bf59acb3be27ababb7a368044b231f587604c42dba16c002fd8f0df488b1828f564b0eb79cd64622fec SHA512 8e63b20ad3e1d238a6006fca834b355825015088a3dff82866e1197c2802e4a3cc57644d50b44407203bea2c2d4a132c89d402e52e4525d257de9a8cde87f1db
diff --git a/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch b/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch
new file mode 100644
index 000000000000..65beb70faae9
--- /dev/null
+++ b/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch
@@ -0,0 +1,35 @@
+From 5ca1bc18272c0ddbb3496fa29076ac2d65c034cf Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 27 Aug 2023 21:55:17 +0200
+Subject: [PATCH] Search for KF5DocTools individually
+
+Makes our ECM_HANDBOOK=forceoptional facility work while upstream is against it.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 17203b22f..3c914f178 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -93,7 +93,6 @@ if( BUILD_DESKTOPPROGRAM )
+ list(APPEND ADDITIONAL_REQUIRED_KF_COMPONENTS
+ Crash
+ DBusAddons
+- DocTools
+ )
+ endif()
+ find_package(KF5 ${REQUIRED_KF_VERSION} REQUIRED
+@@ -117,6 +116,7 @@ ecm_set_disabled_deprecation_versions(
+ # helper libs
+ add_subdirectory( libs )
+ if( BUILD_DESKTOPPROGRAM )
++ find_package(KF5DocTools ${REQUIRED_KF_VERSION} REQUIRED)
+ add_subdirectory( doc )
+ endif()
+
+--
+2.42.0
+
diff --git a/app-editors/okteta/metadata.xml b/app-editors/okteta/metadata.xml
index a50ada50ef0e..0bc83685a440 100644
--- a/app-editors/okteta/metadata.xml
+++ b/app-editors/okteta/metadata.xml
@@ -1,10 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ </upstream>
<use>
<flag name="designer">Build plugins for <pkg>dev-qt/designer</pkg></flag>
</use>
diff --git a/app-editors/okteta/okteta-0.26.4.ebuild b/app-editors/okteta/okteta-0.26.15.ebuild
index 8499c3c2e99b..d7827f1dbd5b 100644
--- a/app-editors/okteta/okteta-0.26.4.ebuild
+++ b/app-editors/okteta/okteta-0.26.15.ebuild
@@ -1,23 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
ECM_DESIGNERPLUGIN="true"
ECM_HANDBOOK="forceoptional"
ECM_TEST="true"
-KFMIN=5.60.0
-QTMIN=5.12.3
+KFMIN=5.92.0
+QTMIN=5.15.5
VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Hex editor by KDE"
-HOMEPAGE="https://apps.kde.org/en/okteta
-https://utils.kde.org/projects/okteta/"
+HOMEPAGE="https://apps.kde.org/okteta/"
if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
- KEYWORDS="amd64 ~arm64 x86"
+ KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
fi
LICENSE="GPL-2 handbook? ( FDL-1.2 )"
@@ -50,10 +49,12 @@ DEPEND="
>=kde-frameworks/kservice-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
- crypt? ( app-crypt/qca:2[qt5(+)] )
+ crypt? ( >=app-crypt/qca-2.3.0:2[qt5(+)] )
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-0.26.13-doctools-optional.patch" ) # downstream
+
src_configure() {
local mycmakeargs=(
-DOMIT_EXAMPLES=ON