summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/retext/retext-9999.ebuild')
-rw-r--r--app-editors/retext/retext-9999.ebuild63
1 files changed, 38 insertions, 25 deletions
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 72e36651206d..38c1165fb129 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,29 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# no pypy{,3} support as PyQt5 does not support it at 2020-07-05 (towelday)
-# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
-PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="ReText"
-inherit distutils-r1 virtualx xdg-utils
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-MY_PN="ReText"
-MY_P="${MY_PN}-${PV/_/~}"
+inherit desktop distutils-r1 optfeature qmake-utils virtualx xdg
DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
-if [[ ${PV} == *9999 ]]
- then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/retext-project/retext.git"
- else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}"/${MY_P}
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
fi
LICENSE="GPL-2+"
@@ -34,25 +29,44 @@ RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/markups[${PYTHON_USEDEP}]
+ >=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/python-markdown-math[${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,network,printsupport,widgets,${PYTHON_USEDEP}]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/PyQt6[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools
+ test? ( dev-python/PyQt6[testlib,${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ # Needed for lrelease
+ export PATH="$(qt5_get_bindir):${PATH}"
+}
src_test() {
virtx distutils-r1_src_test
}
python_test() {
- esetup.py test
+ virtx eunittest
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ newicon data/retext-kde5.png retext.png
+
+ # Fixme: The application actually provides a desktop file which theoretically
+ # could be used, so far though I could not make it install properly.
+ make_desktop_entry ${PN} "ReText" ${PN} "Office;WordProcessor"
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ xdg_pkg_postinst
optfeature "dictionary support" dev-python/pyenchant
@@ -63,6 +77,5 @@ pkg_postinst() {
}
pkg_postrm() {
- xdg_desktop_database_update
xdg_icon_cache_update
}