summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/shed')
-rw-r--r--app-editors/shed/Manifest2
-rw-r--r--app-editors/shed/files/shed-1.15-cflags.patch11
-rw-r--r--app-editors/shed/files/shed-1.15-interix.patch14
-rw-r--r--app-editors/shed/files/shed-1.16-tinfo.patch (renamed from app-editors/shed/files/shed-1.15-tinfo.patch)9
-rw-r--r--app-editors/shed/metadata.xml2
-rw-r--r--app-editors/shed/shed-1.15.ebuild31
-rw-r--r--app-editors/shed/shed-1.16.ebuild26
7 files changed, 33 insertions, 62 deletions
diff --git a/app-editors/shed/Manifest b/app-editors/shed/Manifest
index 5250ae6ee2e8..04900f430aac 100644
--- a/app-editors/shed/Manifest
+++ b/app-editors/shed/Manifest
@@ -1 +1 @@
-DIST shed-1.15.tar.gz 87777 BLAKE2B 7c23f01e649de6ad15b870ef3786bd1747b6ab765f19a748d08bad878325f11e38483b957ed6a791ae4a7de752e96cca2057fd69838625c3fe660d2ba3fbc984 SHA512 fe401303e686fb11975b71de0f84d0cdb84dc5a48e1094356d012f95d8c956ed05bd6b39bf65af924212e83c1db45bbfe556342489150bb0e10fb4c832fb6c78
+DIST shed-1.16.tar.gz 104323 BLAKE2B 30c4d6ec7d497a64cc4e313496d26e3a4b8a8050bcfd05c50d9eef865d987df76cd1d7fa13509bdfed184159676dfc2c8bb8d3eb98f64573845e543d174cae7b SHA512 0c807205540b17ee977c157c8edd916b34ba6c4ace280f59c10a92abbe820ef7fe24c4a64c2fc8b5fcd3d86f71e26672cef469340ddce393d370b53aa8785e7c
diff --git a/app-editors/shed/files/shed-1.15-cflags.patch b/app-editors/shed/files/shed-1.15-cflags.patch
deleted file mode 100644
index 2b675f7449f7..000000000000
--- a/app-editors/shed/files/shed-1.15-cflags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -2,7 +2,7 @@
- AM_INIT_AUTOMAKE(shed,1.15)
- AC_PROG_CC
- AC_PROG_INSTALL
--CFLAGS="-Wall"
-+CFLAGS="$CFLAGS -Wall"
- AC_SUBST(CFLAGS)
-
- AC_ARG_ENABLE(debug, [ --enable-debug gcc -g],enable_debug=yes)
diff --git a/app-editors/shed/files/shed-1.15-interix.patch b/app-editors/shed/files/shed-1.15-interix.patch
deleted file mode 100644
index 46c5eb6b26b1..000000000000
--- a/app-editors/shed/files/shed-1.15-interix.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://sourceforge.net/tracker/?func=detail&aid=3554634&group_id=21862&atid=374571
---- a/shed.c
-+++ b/shed.c
-@@ -31,6 +31,10 @@
- #include <ctype.h> /* tolower */
- #include <unistd.h> /* dup, dup2 */
-
-+#ifdef __INTERIX
-+# include <sys/time.h>
-+#endif
-+
- #include "util.h"
-
- /* function prototypes */
diff --git a/app-editors/shed/files/shed-1.15-tinfo.patch b/app-editors/shed/files/shed-1.16-tinfo.patch
index d1a406521c0f..840b17f1f875 100644
--- a/app-editors/shed/files/shed-1.15-tinfo.patch
+++ b/app-editors/shed/files/shed-1.16-tinfo.patch
@@ -1,6 +1,6 @@
---- a/configure.in
-+++ b/configure.in
-@@ -41,8 +41,7 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -42,9 +42,8 @@
fi
ERR="Required package missing!"
@@ -9,4 +9,5 @@
AC_CHECK_HEADER(getopt.h,:,AC_MSG_ERROR([$ERR]))
-AC_CHECK_LIB(ncurses,initscr)
AC_CHECK_LIB(m,pow)
- AC_OUTPUT(Makefile)
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
diff --git a/app-editors/shed/metadata.xml b/app-editors/shed/metadata.xml
index d14e7209041c..8928a9fb2b53 100644
--- a/app-editors/shed/metadata.xml
+++ b/app-editors/shed/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>hattya@gentoo.org</email>
diff --git a/app-editors/shed/shed-1.15.ebuild b/app-editors/shed/shed-1.15.ebuild
deleted file mode 100644
index 8609122c355e..000000000000
--- a/app-editors/shed/shed-1.15.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit autotools
-
-DESCRIPTION="Simple Hex EDitor"
-HOMEPAGE="http://shed.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-RDEPEND="sys-libs/ncurses:0="
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-cflags.patch
- "${FILESDIR}"/${P}-interix.patch
- "${FILESDIR}"/${P}-tinfo.patch
-)
-
-src_prepare() {
- default
-
- mv configure.{in,ac} || die
- eautoreconf
-}
diff --git a/app-editors/shed/shed-1.16.ebuild b/app-editors/shed/shed-1.16.ebuild
new file mode 100644
index 000000000000..adb9fde8ed45
--- /dev/null
+++ b/app-editors/shed/shed-1.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools
+
+DESCRIPTION="Simple Hex EDitor"
+HOMEPAGE="https://shed.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-tinfo.patch )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}